LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   add ethernet modules (https://www.linuxquestions.org/questions/linux-software-2/add-ethernet-modules-321032/)

piva.francesco 05-07-2005 11:20 AM

add ethernet modules
 
Hi all,
i just have added a new ethernet card into my linux slackware 10.1 box. I already have one inside connected to the internet through a switch. I'd like to have further informations on how to make so that it is reconized from my slackware.
I read somewhere that I should do something with the ifconfig command.
when i do it, it gives me this

Quote:

bash-3.00# ifconfig
eth0 Link encap:Ethernet HWaddr 00:07:E9:62:F2:14
inet addr:192.168.1.12 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:299915 errors:0 dropped:0 overruns:0 frame:0
TX packets:243055 errors:0 dropped:0 overruns:0 carrier:2
collisions:645 txqueuelen:1000
RX bytes:221076290 (210.8 Mb) TX bytes:94919058 (90.5 Mb)
Interrupt:5 Base address:0xb000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:428 (428.0 b) TX bytes:428 (428.0 b)
If I understand correctly my first ethernet card (the one connected to the internet) is eth0, so maybe the second one will be eth1. Really I don't know. The second one will be connected to a second pc.

Can someone explain CLEARLY how can I succeed in 'installing' my new network card?

Thanks so much.
I really need this answer as soon as possible...

Good bye all

fp

acid_kewpie 05-07-2005 12:26 PM

first you need to find the driver for it. if you don't know what the chipset is, use lspci to see. then find the matching module, possibly via the HCL on LQ.org via the main menu link on this page. use "modprobe modulenamehere" to load the module. then use netconfig to configure the network details for it.

to load the module permanently on each boot, you would add a line to /etc/modules.conf, although i don't know if slack uses that file...

piva.francesco 05-08-2005 02:34 AM

When I run lspci it gives me the following:

bash-3.00# lspci
00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Control ler (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 A udio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 420] (re v a3)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139 C+ (rev 10)
02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)
bash-3.00#


My computer has the eth0 card integrated and he is an intel, so I think that my eth0 is: " 02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)"
so if someone can enlighten me on which module I have to download/take... for my second ethernet card it would be great.

Thanks you very much

fp

acid_kewpie 05-08-2005 04:53 AM

you want the e1000 module, which will already be o your system.

piva.francesco 05-08-2005 07:35 AM

I tried to do modprobe e1000 and it gives me the following thing:

bash-3.00# modprobe e1000
/lib/modules/2.4.29/kernel/drivers/net/e1000/e1000.o.gz: init_module: No such device
/lib/modules/2.4.29/kernel/drivers/net/e1000/e1000.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.29/kernel/drivers/net/e1000/e1000.o.gz: insmod /lib/modules/2.4.29/kernel/drivers/net/e1000/e1000.o.gz failed
/lib/modules/2.4.29/kernel/drivers/net/e1000/e1000.o.gz: insmod e1000 failed
bash-3.00#


any clue? I'm really getting near of my deadline, PLEASE, I really need this to work.
Thanks for answering (once again)

fp

acid_kewpie 05-09-2005 03:18 AM

hmm, maybe it's the e100 then. google has pretty varying levels of success with that card. the other card will be much easier, just "modprobe 8139too" and you will be away.


All times are GMT -5. The time now is 07:10 PM.