-   Linux - Software (
-   -   Acrobat Reader "error opening document - permission denied" (

Robhogg 06-24-2006 04:29 AM

Acrobat Reader "error opening document - permission denied"
Acrobat Reader (v. 7.0.1-4) has just started refusing to open pdf files on my PC. The message returned is There was an error opening this document. Permission denied. The files in question are owned by me, with read (and write) permissions, and acroread is running with my user id. I have tried deleting and re-installing the program, with no luck.

Any ideas, please? Could this be a problem with a file acroread is dependent on? The plug-in for Firefox is working fine, by the way.


Andrew Benton 06-24-2006 08:53 AM

Have you tried using another application like Xpdf (my favourite) or Evince?

Robhogg 06-25-2006 06:39 AM

Thanks for the reply.

Yes, I've tried XPDF and Gnome's Document Viewer, which do work, although sometimes give some odd results when printing (such as mismatched margins or nonsense characters in place of text).

I would like to be able to sort out what the problem is with acroread.


hand of fate 06-28-2006 11:53 AM

Have you tried upgrading to the latest version of Adobe Reader (7.0.8)?

I haven't actually had a chance to install this version, but I know a lot of the bugs I experienced in 7.0.1 were solved by version 7.0.5, so 7.0.8 should be quite a big improvement over 7.0.1.

This might not help, but you should probably upgrade anyway.

Robhogg 07-05-2006 02:51 PM

Sorry about not posting for a while. I have tracked down the root of the problem. It was nothing to do with acroread - the culprit was AppArmor!. I found a number of entries in /var/log/messages, which a google search showed to be from AppArmor, which explained several problems I had been having. See this post for more.


fyz123 04-25-2008 08:44 AM


I used to have similar problems, but my files are really corrupted. I finally used a utility called Advanced PDF Repair to repair my PDF file. It works rather well.

Just post to hope this will help.


All times are GMT -5. The time now is 06:28 PM.