LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-13-2017, 07:45 AM   #1
art_st
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Rep: Reputation: 0
Unhappy a2dp sound delayed


I'm having trouble with playing audio through bluetooth (A2DP). Randomly, though quite often, the audio is delayed compared to a video or even is punctuated. Also, when I disconnect A2DP it keeps playing for a few seconds as if the sound was buffered in the bluetooth receiver, or maybe system is not able to switch to the laptop speakers.

I'm having these problem on the latest KDE Neon. Previously I was using Kubuntu 16.10 and the problems were occurring much less frequently or maybe even didn't occur at all. I'm not sure now. I used to have such problems in previous Kubuntu releases, however.

What can I do with that? Maybe it's an issue of some IRQ priorities or something like that?
 
Old 07-16-2017, 10:43 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: voidlinux with LXDE
Posts: 5,509

Rep: Reputation: Disabled
as no-one else has replied yet....and I don't have a BT device you may like to start here
https://wiki.archlinux.org/index.php/bluetooth#Audio

I may be reading your post wrong.....what is the source of audio?
what is the output device?

it looks like you are playing from maybe an smartphone to the laptop speakers.....is that correct?

so you have paired correctly?
 
Old 07-17-2017, 12:48 AM   #3
art_st
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,

I'm playing the audio on my laptop (~5 years old) to a bluetooth adapter (http://www.philips.pl/c-p/AEA2000_12...luetooth-hi-fi) which connects by wires to speakers. I have no problems with pairing the devices.

The key issue is that I had no such problems when Kubuntu 16.10 was installed on the laptop. And also when I play audio from my smartphone there are no problems.
 
Old 07-17-2017, 08:21 PM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: voidlinux with LXDE
Posts: 5,509

Rep: Reputation: Disabled
Ok

so the question I previously asked which I will repeat is what is the souce of the audio ...... answer your PC
what is the output device.....answer....a bluetooth receiver connected by wires to a speaker system not connected by wires to PC

so you may like to read this link which appears to be what you have
http://www.lightofdawn.org/blog/?viewDetailed=00031

good luck
 
  


Reply

Tags
bluetooth, kde, kubuntu, pulseaudio, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sound control delayed, and sound only plays from one programme at a time Stephen Morgan Slackware 2 03-02-2013 08:58 AM
All sound delayed by ~.5 second spiffytech Ubuntu 1 08-04-2006 09:21 AM
SDL_mixer: sound is delayed nexus6 Linux - Software 1 09-03-2005 08:05 AM
q3: sound choppy and delayed redax Linux - Games 14 01-08-2005 02:09 AM
Delayed sound on all games sanmadjack Linux - Games 1 12-04-2004 09:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration