-   Linux - Software (
-   -   A Wine Issue (Upgrade Problems 1.0-1.1.3) (

SKUTR14 09-01-2008 05:04 PM

A Wine Issue (Upgrade Problems 1.0-1.1.3)
Wine refuses to take form 1.1.3. I get the feeling this is the only piece missing in the puzzle for me to be able to play World of Warcraft. Could somebody tell me how to get Wine to work in version 1.1.3. I've already downloaded it, but when I access my winecfg it says that it's still at version 1.0. Assistance would be welcomed very much so. I am running Fedora 9 if that helps find a solution.

{BBI}Nexus{BBI} 09-01-2008 05:25 PM


Before you install Wine, make sure that there is no previous Wine installation on your system, either from a package or from source.
Taken from: 1.0 is the latest stable release.

Try using Wine-Doors:

Wine-doors is an application designed to make installing windows software on Linux, Solaris or other Unix systems easier. Wine-doors is essentially a package management tool for windows software on Linux systems. Most Linux desktop users are familiar with package management style application delivery, so it made sense to apply this model to windows software.
Check it out here:

SKUTR14 09-01-2008 05:47 PM

Alright... how do I apply a game to Wine Doors that I already have installed? Is there something I need to put in the command line of the program to boot it up or what?

{BBI}Nexus{BBI} 09-01-2008 06:04 PM

Warcraft 2 & 3 are already in Wine-Doors. Does the game need WoW to run?

SKUTR14 09-01-2008 06:16 PM

Yeah, Warcraft is something completely separate from World of Warcraft. My account is Burning Crusade too so the "World of Warcraft 2" thing it has won't be enough for me to play.

If somebody could just tell me how to delete the old version of Wine that would be fantastic. I can't find the button to uninstall wine 1.0, but if somebody could tell me how to do that then I could easily get 1.1.3 which has been proven to WORK with World of Warcraft.

{BBI}Nexus{BBI} 09-01-2008 06:52 PM

You could use your package manager to uninstall wine. I just realised what WoW stands for, lol. I found this:

Typical used on a linux system running WoW under wine

SET gxResolution "1024x768"
SET gxRefresh "60"
SET hwDetect "0"
SET movie "0"
SET readTOS "1"
SET realmList ""
SET gxMultisampleQuality "0.000000"
SET readEULA "1"
SET readScanning "-1"
SET realmName "Shadowsong"
SET gameTip "54"
SET gxCursor "0"
SET SmallCull "0.040000"
SET frillDensity "32"
SET farclip "357"
SET Gamma "0.600000"
SET MusicVolume "0.60000002384186"
SET SoundVolume "1"
SET SoundOutputSystem "1"
SET SoundBufferSize "150"
SET MasterVolume "1"
SET ffx "0"
SET AmbienceVolume "0.60000002384186"
SET uiScale "1"
SET mouseSpeed "1"
SET cameraPitchMoveSpeed "90"
SET cameraYawMoveSpeed "180"
SET cameraPitchSmoothSpeed "45"
SET cameraYawSmoothSpeed "180"
SET cameraSmoothStyle "0"
SET cameraSmoothTrackingStyle "0"
SET cameraDistanceMaxFactor "1"
SET SoundZoneMusicNoDelay "1"
SET gxColorBits "24"
SET gxApi "opengl"
SET statusBarText "1"
SET ffxDeath "0"
SET minimapZoom "0"
SET guildMemberNotify "1"
SET profanityFilter "0"
SET readContest "-1"
SET minimapInsideZoom "5"
SET gxDepthBits "24"
SET accountName "linuxwillwin"

Apparently the file is in the WTF directory.

SKUTR14 09-01-2008 06:56 PM

That's great. The only problem is that I can't access the file. I can get to it through Wine, but that's the only way, and once I find it with Wine I can't edit it.

By the way... are you serious with that last line?

SET accountName "linuxwillwin"

That seems like a huge joke to me.

SKUTR14 09-01-2008 06:59 PM

Yeah... I found easily enough using wine. But when I go to open it, it epically fails and just resets without opening the file.

And I can't access the C or Z drives using the Linux file browser. Maybe if I could get instructions doing it that way it would help.

{BBI}Nexus{BBI} 09-01-2008 07:02 PM

In your home folder go to View--> Show Hidden Files then look for a .wine folder.

By the way... are you serious with that last line?

SET accountName "linuxwillwin"

That seems like a huge joke to me.
I got the info from here:

SKUTR14 09-01-2008 07:06 PM

AH HA! Now we're getting somewhere. So, should I just copy the stuff you gave and write that over my or would you say to do something else?

{BBI}Nexus{BBI} 09-01-2008 07:07 PM


Originally Posted by SKUTR14 (Post 3266601)
AH HA! Now we're getting somewhere. So, should I just copy the stuff you gave and write that over my or would you say to do something else?

If you're going to do that, then I suggest you make a copy of your current and save it to another folder first.

SKUTR14 09-01-2008 08:42 PM

Alright... so I made those changes to my config... and it worked... somewhat.

Instead of me typing the command in Terminal, having the wine virtual desktop thing come up, and crashing at that point... I typed the command in terminal, got the virtual desktop, watched the opening cinematic... then it crashed. So I rebooted my computer and tried again... only to have the same thing happen. Once again, I rebooted my computer and this time I tried to skip the opening cinematic by hitting the escape key... it crashed when I did that.

I'm going to try taking out the secondary wine desktop and a few things with the configuration. I noticed in the configuration that a few things were in the original that weren't in the one you gave. So, I'm going to try porting the stuff in the original that isn't in the one you gave me to the config and fill in some holes. I think that will fix this. I still have not upgraded to Wine 1.1.3 so... I suppose I should do that first. Wow... I feel dumb now.

SKUTR14 09-01-2008 09:08 PM

Alright... I can't find my package manager to delete Wine 1.0. I'm running Fedora 9, any help welcome. Thank you.

{BBI}Nexus{BBI} 09-01-2008 09:21 PM

It's called PackageKit.

SKUTR14 09-01-2008 09:37 PM

I can't find it........ what do I need to type in Terminal to bring it up?

All times are GMT -5. The time now is 12:26 PM.