LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-30-2003, 06:32 PM   #1
slice4e
Member
 
Registered: Apr 2003
Location: Daytona Beach
Posts: 30

Rep: Reputation: 15
a VSIPL problem with installation


I am trying to install the VSIPL (Vector Signal Image Processing Library) , because it is needed in order to install HPL (High Performance Linpack)
I tried the Linpack and VSIPL maling lists, but nobody responds to me, so I though that I may get lucky here. Since many people dealing with Linux know about clusters also.

So for VSIPL I modified the Makefile like this:

## Created RJudd
## SPAWARSYSCEN D881
## $Id: Makefile,v 2.0 2003/02/22 15:15:30 judd Exp $

## use gnu's make if possible
MAKE=make

## Any ansi C compiler here
CC=gcc

## To improve the usability of this implementation
## I have added some code options which are selected
## with the -D preprocessor directive. I expect that this
## list will increase as time goes by. By default no macros
## are defined and you get the default library. You can not
## willey nilley chose optional macros. You must chose a set
## that makes sense. So I have defined them in a seprate readme
## file. Currently there are not that many choices but I can
## imagine a fair number being implemented at some time in
## the future. The purpose is to help people trying to improve
## performance or incorporate native librarys with VSIPL as a
## middle ware wrapper. If you are just starting out and trying VSIPL
## just ignore this for now. OPTMACROS is for "implementors" not "users".
OPTMACROS=
## -DVSIP_ALWAYS_INTERLEAVED
## -DVSIP_DEFAULT_SPLIT
## -DVSIP_ALWAYS_SPLIT
## -DVSIP_ASSUME_COMPLEX_IS_INTERLEAVED
## -DVSIP_USE_FFTW_FOR_FFT_F
## -DVSIP_USE_FFTW_FOR_FFT_D
## -DVSIP_USE_FFT_FOR_FFTM_F
## -DVSIP_USE_FFT_FOR_FFTM_D
#
#
## Options appropriate for compiler
OPTIONS= -O2 $(OPTMACROS)
## OPTIONS= -Wall -ansi -pedantic -g $(OPTMACROS)
## OPTIONS= -Wall -ansi -pedantic $(OPTMACROS)

## Archiver
AR=ar
## Archiver options
AR_OPTIONS=rcvs

## What you want to call the VSIPL library
ARLIB=libvsip.a

## What you want to call the VSIPL User library
## The VSIPL user library is just VSIPL code.
## It is not connected with the VSIPL Specification or Forum
## The subroutines are needed to run many of the examples.
ARLIB_VU=libVU.a

all:
(cd src; $(MAKE) MAKE='$(MAKE)' CC='$(CC)' OPTIONS='$(OPTIONS)' \
AR='$(AR)' AR_OPTIONS='$(AR_OPTIONS)' ARLIB='$(ARLIB)'
(cd src_VU; $(MAKE) MAKE='$(MAKE)' CC='$(CC)' OPTIONS='$(OPTIONS)' \
AR='$(AR)' AR_OPTIONS='$(AR_OPTIONS)' ARLIB='$(ARLIB_VU)'

clean:
(cd src; $(MAKE) MAKE='$(MAKE)' clean
(cd src_VU; $(MAKE) MAKE='$(MAKE)' clean


After i type "make" , I do not see that a folder "EXEC" get created. In my installation instructions it sais to test it by
cd EXEC
and then typing the name of the executable.

I am kind of a newbe and I really do not know what to do. and I am stuck

Thank you for your time and help
Martin
 
Old 06-03-2003, 03:18 AM   #2
blix5
LQ Newbie
 
Registered: Jun 2003
Distribution: Mandrake 9.1
Posts: 3

Rep: Reputation: 0
the EXEC directory could be hidden.
are you sure that the directory's name isn't .EXEC?

try finding it by having ls list ALL of the files in the directory that the readme/install file indicates:
ls /whateverdirectory -a
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation problem misterjingo Slackware 11 09-06-2005 10:31 PM
Installation Problem. TheMerk Linux - Newbie 8 01-27-2005 05:59 AM
installation problem petej Red Hat 2 10-28-2003 06:24 PM
LiLo Installation problem ?and (GNOME and KDE problem) hitesh_linux Linux - Software 1 01-01-2002 05:56 AM
Installation problem. gnanabharani Linux - Software 1 05-31-2001 12:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration