LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-19-2016, 09:46 AM   #1
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Rep: Reputation: 3
Question A mystery: RPM says no package requires something that is required.


RPM/yum are installing a dependency for a package but then not reporting it as required. For example:

yum install pkg-abc says Installing for dependencies: pkg-xyz

rpm -q --requires pkg-abc lists pkg-xyz.

rpm -q --whatrequires pkg-xyz says no package requires pkg-xyz

These results are in conflict. How is this possible?

Yum will then allow the erasing of pkg-xyz despite breaking the dependencies of pkg-abc!
 
Old 10-19-2016, 12:19 PM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 17,000

Rep: Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741Reputation: 5741
that is again insufficient information. I can only guess, but probably those packages are not the official rpms of that release (just some hand-made whatever).
Would be much better to tell us the name of those packages, your os, your configured repositories and other related information, otherwise you will get no better answer just something like: try to remove pkg-ert first and install pkg-fgh.
 
Old 10-19-2016, 12:26 PM   #3
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
The packages are made by my company's developers. I am simply trying to understand how a condition could arise in which RPM would both confirm and deny the existence of such dependencies.
 
Old 10-19-2016, 12:36 PM   #4
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,568

Rep: Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093
It might be that pkg-abc requires something that is provided by pkg-xyz, but does not explicitly require pky-xyz itself. You can see the list of what pkg-xyz provides by running "rpm -q --provides pkg-xyz" and match that against what pkg-abc requires ("rpm -q --requires pkg-abc").
 
Old 10-19-2016, 12:41 PM   #5
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
I thought of that too, but the package in question requires "ImageMagick >= 6.7.7" and ImageMagick provides "ImageMagick = 6.7.7-7.2"
 
Old 10-19-2016, 12:56 PM   #6
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,568

Rep: Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093
Quote:
Originally Posted by blueh2o View Post
I thought of that too, but the package in question requires "ImageMagick >= 6.7.7"
That is different from requiring "ImageMagick". Yes, it is quite unlikely that a package other than ImageMagick would provide capability "ImageMagick >= 6.7.7", but the syntax doesn't make that distinction.
 
Old 10-19-2016, 12:58 PM   #7
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
No other package provides the capability yet YUM will allow me to remove it anyway.
 
Old 10-19-2016, 01:05 PM   #8
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,568

Rep: Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093
Quote:
Originally Posted by blueh2o View Post
No other package provides the capability yet YUM will allow me to remove it anyway.
Are you saying that yum allows you to remove ImageMagick without also taking out your "pkg-abc" due to the dependency?
 
Old 10-19-2016, 01:10 PM   #9
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by rknichols View Post
Are you saying that yum allows you to remove ImageMagick without also taking out your "pkg-abc" due to the dependency?
Exactly.
 
Old 10-19-2016, 01:27 PM   #10
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,568

Rep: Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093
What Linux release are you running? I wonder if this is a case of a "soft dependency", i.e. a package that is recommended to provide additiional features but is not a hard requirement. Since AFAIK RHEL is not using that yet, I'm guessing you are running into this in a recent Fedora.
 
Old 10-19-2016, 01:29 PM   #11
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
I'm testing on CentOS 6.8. The software is designed for CentOS 6.x and RHEL 6.x
 
Old 10-19-2016, 01:34 PM   #12
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 4,568

Rep: Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093Reputation: 2093
There is nothing more I can suggest, then, at least not without looking at "pkg-abc" (and I'm not particularly interested in doing that).
 
Old 10-19-2016, 01:46 PM   #13
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
Nor indeed could I allow it. I was just hoping there was a somewhat simple reason for the behavior.
 
Old 10-19-2016, 02:30 PM   #14
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,531

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
if you have been using rpm to install odd things that are not in the cent repos
then it is likely you have a mess on your hands

not quite a "Frankenstein" install but a mess

imagemagick can be a royal pain sometimes
there is the Q8 ,the Q16 and the custom Q32 ( i use the q16 and q32 with a custom install )
matlab/octave needs the q32 and nip needs the q16 and other things need the q8

if these rpm's are from your developers then have them AGREE on using one version or at least the SAME version that is in the cent repos

imagemagick is NOTORIOUS!!!!! for having an EVEN MORE BUGGY NEW VERSION!!@!!!!!

have your developers use the default IM if at all possible
 
Old 10-19-2016, 02:32 PM   #15
blueh2o
Member
 
Registered: Jul 2011
Distribution: CentOS, Ubuntu, Fedora, Solaris, RHEL, Debian
Posts: 100

Original Poster
Rep: Reputation: 3
It's not just ImageMagick it's the entire dep list of the package. Something is fishy about how it's built perhaps.
FWIW, I agree with you on using the released versions. It's just not my decision.

Thanks all for your thoughts on this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Package requires earlier version of an installed package Doug Hutcheson Linux - Software 3 12-30-2010 09:55 PM
Making the - - prefix option required when installing an RPM package sandricky Linux - Software 3 02-09-2009 12:24 AM
Adobe Acrobate Reader Requires A Plugin-That Requires Open LDAP That Requires Berkely Old_Fogie Slackware 10 05-08-2006 05:04 AM
See what an RPM requires? Rotwang Linux - General 4 06-07-2004 11:31 PM
Mystery-RPM Installation DoubleLetter Linux - General 6 08-22-2001 03:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration