LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   A mystery: RPM says no package requires something that is required. (https://www.linuxquestions.org/questions/linux-software-2/a-mystery-rpm-says-no-package-requires-something-that-is-required-4175591742/)

blueh2o 10-19-2016 10:46 AM

A mystery: RPM says no package requires something that is required.
 
RPM/yum are installing a dependency for a package but then not reporting it as required. For example:

yum install pkg-abc says Installing for dependencies: pkg-xyz

rpm -q --requires pkg-abc lists pkg-xyz.

rpm -q --whatrequires pkg-xyz says no package requires pkg-xyz

These results are in conflict. How is this possible?

Yum will then allow the erasing of pkg-xyz despite breaking the dependencies of pkg-abc!

pan64 10-19-2016 01:19 PM

that is again insufficient information. I can only guess, but probably those packages are not the official rpms of that release (just some hand-made whatever).
Would be much better to tell us the name of those packages, your os, your configured repositories and other related information, otherwise you will get no better answer just something like: try to remove pkg-ert first and install pkg-fgh.

blueh2o 10-19-2016 01:26 PM

The packages are made by my company's developers. I am simply trying to understand how a condition could arise in which RPM would both confirm and deny the existence of such dependencies.

rknichols 10-19-2016 01:36 PM

It might be that pkg-abc requires something that is provided by pkg-xyz, but does not explicitly require pky-xyz itself. You can see the list of what pkg-xyz provides by running "rpm -q --provides pkg-xyz" and match that against what pkg-abc requires ("rpm -q --requires pkg-abc").

blueh2o 10-19-2016 01:41 PM

I thought of that too, but the package in question requires "ImageMagick >= 6.7.7" and ImageMagick provides "ImageMagick = 6.7.7-7.2"

rknichols 10-19-2016 01:56 PM

Quote:

Originally Posted by blueh2o (Post 5620138)
I thought of that too, but the package in question requires "ImageMagick >= 6.7.7"

That is different from requiring "ImageMagick". Yes, it is quite unlikely that a package other than ImageMagick would provide capability "ImageMagick >= 6.7.7", but the syntax doesn't make that distinction.

blueh2o 10-19-2016 01:58 PM

No other package provides the capability yet YUM will allow me to remove it anyway.

rknichols 10-19-2016 02:05 PM

Quote:

Originally Posted by blueh2o (Post 5620146)
No other package provides the capability yet YUM will allow me to remove it anyway.

Are you saying that yum allows you to remove ImageMagick without also taking out your "pkg-abc" due to the dependency?

blueh2o 10-19-2016 02:10 PM

Quote:

Originally Posted by rknichols (Post 5620155)
Are you saying that yum allows you to remove ImageMagick without also taking out your "pkg-abc" due to the dependency?

Exactly.

rknichols 10-19-2016 02:27 PM

What Linux release are you running? I wonder if this is a case of a "soft dependency", i.e. a package that is recommended to provide additiional features but is not a hard requirement. Since AFAIK RHEL is not using that yet, I'm guessing you are running into this in a recent Fedora.

blueh2o 10-19-2016 02:29 PM

I'm testing on CentOS 6.8. The software is designed for CentOS 6.x and RHEL 6.x

rknichols 10-19-2016 02:34 PM

There is nothing more I can suggest, then, at least not without looking at "pkg-abc" (and I'm not particularly interested in doing that).

blueh2o 10-19-2016 02:46 PM

Nor indeed could I allow it. I was just hoping there was a somewhat simple reason for the behavior.

John VV 10-19-2016 03:30 PM

if you have been using rpm to install odd things that are not in the cent repos
then it is likely you have a mess on your hands

not quite a "Frankenstein" install but a mess

imagemagick can be a royal pain sometimes
there is the Q8 ,the Q16 and the custom Q32 ( i use the q16 and q32 with a custom install )
matlab/octave needs the q32 and nip needs the q16 and other things need the q8

if these rpm's are from your developers then have them AGREE on using one version or at least the SAME version that is in the cent repos

imagemagick is NOTORIOUS!!!!! for having an EVEN MORE BUGGY NEW VERSION!!@!!!!!

have your developers use the default IM if at all possible

blueh2o 10-19-2016 03:32 PM

It's not just ImageMagick it's the entire dep list of the package. Something is fishy about how it's built perhaps.
FWIW, I agree with you on using the released versions. It's just not my decision.

Thanks all for your thoughts on this.


All times are GMT -5. The time now is 01:40 AM.