LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-20-2006, 12:14 PM   #1
nessic
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
a lot of files "broken"???!!!


I use rh 9.0.
today,when I run hardware browser,it show "no such file or dir..."
and I chech "/usr/bin/"
I found that a lot of files are broken.
such as reahat-config-packages. .etc
and I find rpm from rh disk 2.
and install it
but it says the rpm are already installed
but when i #rpm -e *.rpm
it says the rpm isn't installed

what can I do??
 
Old 08-20-2006, 12:55 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
" #rpm -e *.rpm "

don't use the .rpm extension when removing, just the packagename

rpm -e packagename
 
Old 08-21-2006, 12:11 AM   #3
nessic
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rshaw
" #rpm -e *.rpm "

don't use the .rpm extension when removing, just the packagename

rpm -e packagename
I removed the package by
rpm -e --nodeps redhad-config*

but I can intall it again
It seems that there is no applications to open the rpm.
what can I do
 
Old 08-21-2006, 12:27 AM   #4
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
how about
Code:
rm -U --force *.rpm
Or are you saying that "rpm" isn't working any more? I'd check the HDD for failure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"clear" and "reset" bash commands broken AviJacobson Linux - General 6 07-03-2006 06:28 AM
"clear" and "reset" bash commands broken AviJacobson Linux - Software 1 06-29-2006 02:31 PM
"X-MS" cant open because "x-Multimedia System" cant access files at "smb&qu ponchy5 Linux - Networking 0 03-29-2004 11:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration