LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-15-2003, 02:25 AM   #1
Cecil
LQ Newbie
 
Registered: Jun 2003
Location: Long Island, NY
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
A (couple) of questions reguarding libc


I've latly been trying to run the linux binaries for Quake 1, and i've encountered a problem: it dosen't recognize the file as being present, or tells me 'cannot execute binary' when i try to SH a file. (Example: sh quake.x11)

I've checked the readmes and it tells me how "libc 5.2.18 or later" is required. I was pretty assured libc are mostly compiliation binaries of the sort, but never delved too deeply into them. I checked my /lib directory and I have libc.so.6. When I /lib/libc.so.6 ...

cecil@darkstar:~$ /lib/libc.so.6
GNU C Library stable release version 2.3.1, by Roland McGrath et al.
Copyright (C) 1992-2001, 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 3.2.2.
Compiled on a Linux 2.4.20 system on 2003-03-04.
Available extensions:
GNU libio by Per Bothner
crypt add-on version 2.1 by Michael Glad and others
linuxthreads-0.10 by Xavier Leroy
BIND-8.2.3-T5B
libthread_db work sponsored by Alpha Processor Inc
NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
Report bugs using the `glibcbug' script to <bugs@gnu.org>.

This should mean i'm running libc6 - more than meets the mark, I've read in terms of backwards compatability..


Now, I noticed something about glibc before across the internet.. after researching, I discovered some more information about it. I am running Slackware 9.0 - and i'm defintly running libc, I gather from all the information between distrubtions and glibc/libc in general.

However, just to check.. whenever I try downloading and running the glibc versions of any quake linux executables, they are immeditatly recognized and try to run. Am I going crazy? However, i've also read some weird issues between everything with the Quake linux binaries and libc and all else.

I've also read something about /etc/ld.so.conf - apparently, this links it to some direction.. i'm not too sure, i'm kind of clouded on it from what i've read. However, this is what I have, after adding /lib/

/usr/local/lib
/usr/X11R6/lib
/usr/i386-slackware-linux/lib
/opt/kde/lib
/usr/lib/qt/lib
/lib/




I was just wondering if anyone could point out anything to me reguarding this whole matter of libc and why 'glibc' binaries execute. Are they backwards compatabile with each other? I never found out anything about that..

Sorry for the long message.

PS: yes i've cd'd to the directory and tried ./filename, all in the correct case.

Last edited by Cecil; 07-15-2003 at 02:45 AM.
 
Old 07-15-2003, 02:57 AM   #2
Cecil
LQ Newbie
 
Registered: Jun 2003
Location: Long Island, NY
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
okay.. a quick update..

I've read this on the following message post located at

http://krom.meiring.org.uk/sheflug/m.../msg00069.html

"If the squake binaries you have are the same as what I have, then they need
(now obsolete and defunct) libc 5... :-/ can you do a "strings squake | head
-15" and tell me if there's a line that reads /lib/ld-linux.so.1 ... if not,
is there a /lib/ld-linux.so.2 ?"

(note: that command returns:

strings squake | head -15
/lib/ld-linux.so.1
libm.so.5
sqrt
_DYNAMIC
ceil
errno
floor
__environ
_init
atan2
_fini
atan
atexit
_GLOBAL_OFFSET_TABLE_
libvga.so.1)



Okay.. is it a possability that it needs 'obsolete' libc5; meaning I need to get an older version of libc installed for backwards compatability(along with /lib/ld-liunx.so.1? I only see ld-linux.so.2 in my /lib/ dir.)? I usually live by a trial and error method to really learn, but i'd like to take it caution and ask first. Would installing libc5 binaries affect my system negativly? Would it downgrade my libc and make things, well, complete hell? I have confidence it woulden't, and in fact would work just fine, but i'd like to check quick before I do anything.

Last edited by Cecil; 07-15-2003 at 03:08 AM.
 
Old 07-15-2003, 06:19 AM   #3
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
I had the same problem, but I finnaly gave up when I found out it only runs with glibc5. I kept searching for other executables (newer), but I couldn't find any.
Now I play Quake 1 in linux by using VMWare, MS-DOS 6.22 and the original Quake 1. It runs ok, but its not native!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libc.so.6 dependency questions giovannym Linux - Newbie 5 07-10-2004 03:12 AM
a couple questions maybbach Linux - Newbie 7 04-15-2004 12:30 AM
Just a couple of questions Renmasta Linux - Newbie 5 11-09-2003 04:58 PM
libc and NIS basic questions moger Linux - General 1 02-14-2003 10:40 AM
Couple of Questions zsaddened Linux - General 7 06-07-2002 02:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration