-   Linux - Software (
-   -   4850 ati driver problem, Debian testing, no adapters found,"XAANoOffscreenPixmaps" (

qrange 08-16-2010 01:57 AM

4850 ati driver problem, Debian testing, no adapters found,"XAANoOffscreenPixmaps"
I've tried these drivers: ati, radeon, radeonhd and fglrx.

fglrx seems to work fine, but Firefox is unusable with it. there are some strange stripes all over the page, they occur randomly when scrolling.
"XAANoOffscreenPixmaps" did NOT help at all.

so, i tried reverting to "ati", "radeonhd". but now i get "no adapters found" in xvinfo, so mplayer does not play movies like it should.

also, 'sudo dpkg-reconfigure xserver-xorg' does not work, it just exits.

how to solve this?

adamk75 08-16-2010 05:18 AM

First, don't use 'radeonhd'. It's undeveloped and unsupported. Use the 'ati' driver and attach the /var/log/Xorg.0.log file that is generated so that we can see what the problem is.


qrange 08-16-2010 02:34 PM

well here is the damn thing:

please help me not fetch the hammer and deal with the annoying problem on 'hardware level'

adamk75 08-16-2010 03:13 PM

What's the output of 'dmesg | grep drm'?


qrange 08-16-2010 03:57 PM

here it is:

[ 44.427687] [drm] Initialized drm 1.1.0 20060810
[ 44.868904] [drm] radeon kernel modesetting enabled.

adamk75 08-16-2010 04:04 PM

Your kernel reports that KMS is enabled, and your X server says it isn't. This is *often* a sign that the kernel DRM isn't getting loaded to the last minute, when X starts, and KMS doesn't have enough time to activate. Can you boot into run level 3 (or whatever runlevel Debian uses that has X disabled), log in, run 'modprobe radeon' (as root or with sudo) and then try to start X with 'startx'?


qrange 08-16-2010 04:53 PM

screen turned black and a message like 'no protocol supported' kept repeating in the console with some other messages from time to time, IIRC.

adamk75 08-16-2010 04:54 PM

That link doesn't go anywhere :-)


qrange 08-16-2010 04:54 PM

yeah sorry, fixed the link

adamk75 08-16-2010 05:24 PM

I'm really not sure what's going on there. I use the exact same card without any problems.

What's the full output of 'dmesg'?


qrange 08-17-2010 12:20 PM

i forgot one probably important thing, i upgraded the whole computer: motherboard, cpu, gfx card.. without reinstalling debian.
but that was long time ago.

adamk75 08-17-2010 12:46 PM


[  20.568567] [fglrx] Maximum main memory to use for locked dma buffers: 3390 MBytes.
[  20.568704] [fglrx]  vendor: 1002 device: 9442 count: 1
[  20.568974] [fglrx] ioport: bar 4, base 0xbe00, size: 0x100
[  20.568985] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  20.568989] pci 0000:01:00.0: setting latency timer to 64
[  20.569143] [fglrx] Kernel PAT support is enabled
[  20.569153] [fglrx] module loaded - fglrx 8.74.4 [May 27 2010] with 1 minors

You can not have fglrx installed, at all, if you are using the open source drivers. Completely remove fglrx from your system, reboot, and try again.


qrange 08-17-2010 01:59 PM

the problem is that everything about fglrx is already uninstalled in aptitude. I made a mistake by installing it from ati installer instead of aptitude.
they didn't provide uninstaller, except some pathetic sh script that didn't seem to work.
(I also had installed fglrx in aptitude, that might have increased the confusion :/ )

anyway, I'll keep trying to remove it completely.
thanks for the help.

adamk75 08-17-2010 02:13 PM

You may just have the kernel module left. Try this:


find /lib/modules/`uname -r`/ -iname "fglrx.ko"

qrange 08-17-2010 02:58 PM

i removed the module and everything is ok now. thanks again.

All times are GMT -5. The time now is 07:04 AM.