-   Linux - Software (
-   -   32 bit mplayer on x86_64 (

ciopi 11-13-2005 03:36 AM

compiling 32 bit mplayer on x86_64

I am trying to compile 32 bit mplayer(source files from CVS) on Mandriva 2006 x86_64(upgraded from 2005 LE). For that I'm doing:


export CC="gcc -m32"   
export LDFLAGS='-L/usr/X11R6/lib' 
./configure --enable-gui

Everything goes fine till here. Running make fails however at some point:


gcc -m32 -c -I../libvo -I../../libvo -I/usr/X11R6/include -O4 -march=k8 -mtune=k8 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I.      -I/usr/include/freetype2  -I/usr/X11R6/include  -I./libavutil -I./libavcodec  -o cpudetect.o cpudetect.c
{standard input}: Assembler messages:
{standard input}:2524: Error: bad register name `%rbx'
{standard input}:2526: Error: bad register name `%rbx'
{standard input}:2550: Error: bad register name `%rbx'
{standard input}:2552: Error: bad register name `%rbx'
{standard input}:2611: Error: bad register name `%rbx'
{standard input}:2613: Error: bad register name `%rbx'
{standard input}:2658: Error: bad register name `%rbx'
{standard input}:2660: Error: bad register name `%rbx'
{standard input}:2686: Error: bad register name `%rbx'
{standard input}:2688: Error: bad register name `%rbx'
make: *** [cpudetect.o] Error 1

Compiling 64 bit mplayer works. However, the 32 bit(rpm) plays certain formats better. If I compile from source, I hope to get for instance faad support(and thus have audio when playing Apple trailers). Please tell me if there is a way of getting this compilation done.

Thank's very much.

karpi 11-14-2005 04:24 AM


I think the compiler try's to compile with 32bit for the 64bit architecture.
There is an option for configure to set the target architecture.
Another option is to disable CPU-detecttion.


ciopi 11-14-2005 10:10 AM

Thank's karpi. You solved this problem. I'm getting a new error unfortunately:


/usr/bin/ld: skipping incompatible /usr/lib64/ when searching for -lgtk-x11-2.0
/usr/bin/ld: cannot find -lgtk-x11-2.0
collect2: ld returned 1 exit status
make: *** [mplayer] Error 1

I ran configure the following way:

./configure --enable-gui --disable-runtime-cpudetection --target=i386-linux --with-extralibdir=/usr/lib
In /usr/lib I found:

What am I doing wrong again ? Thank's for any help.

Problem solved: had to install the libgtk-2.0_0 rpm

All times are GMT -5. The time now is 09:17 PM.