LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-20-2006, 02:49 AM   #1
generalachoo
Member
 
Registered: Jul 2006
Posts: 56

Rep: Reputation: 15
2 Problems with Xserver


Problem A:

I screwed up something with xserver--I switched the x server to some weird one (not xgl/standard) and now x server wont start. Thus, how do I switch the xserver to standard from teh command line? in the GUI i just went

su -
#gdmsetup

Then I clicked on the Security tab, and clicked the X server button, and then selected some random one (quite stupidly). I want to switch back to standard, but I dont have the GUI

Problem B:

I can run Xgl fine--In that I get to see how it looks. It looks a lot better than the standard. However, it simply crawls for me. How do I get Xgl to run as fast or nearly as fast as the stanard x server that comes with the FC5 release.

I have a T43 with a Intel 915 GM display adaptor. Im running Fedora Core 5 with GNOME desktop.

I really need help with this, as I cannot boot into linux.
 
Old 07-20-2006, 03:12 AM   #2
lockpicker
Member
 
Registered: Feb 2006
Location: Sikkim Manipal Institute of Technology, Sikkim
Distribution: Slackware 10.2
Posts: 80

Rep: Reputation: 15
look it up in the xorg.conf!
 
Old 07-20-2006, 04:00 AM   #3
zzyborg
Registered User
 
Registered: May 2006
Location: bangalore, india
Distribution: debian sarge, fedora 6
Posts: 7

Rep: Reputation: 0
boot with "init 1" kernel parameter and check your xorg.conf . i think xorgcfg command may help u in ergenerating the xorg configuration . correct me if i am wrong .

Quote:
Originally Posted by generalachoo
Problem A:

I screwed up something with xserver--I switched the x server to some weird one (not xgl/standard) and now x server wont start. Thus, how do I switch the xserver to standard from teh command line? in the GUI i just went

su -
#gdmsetup

Then I clicked on the Security tab, and clicked the X server button, and then selected some random one (quite stupidly). I want to switch back to standard, but I dont have the GUI

Problem B:

I can run Xgl fine--In that I get to see how it looks. It looks a lot better than the standard. However, it simply crawls for me. How do I get Xgl to run as fast or nearly as fast as the stanard x server that comes with the FC5 release.

I have a T43 with a Intel 915 GM display adaptor. Im running Fedora Core 5 with GNOME desktop.

I really need help with this, as I cannot boot into linux.
 
Old 07-20-2006, 10:53 AM   #4
lockpicker
Member
 
Registered: Feb 2006
Location: Sikkim Manipal Institute of Technology, Sikkim
Distribution: Slackware 10.2
Posts: 80

Rep: Reputation: 15
well zzyborg, you would probably not need to use the init 1 parameter because X is loaded bash
so incase the X is not workin, your terminals would still be workin! so you can check the configs anyway and also the init 1 option is for single user mode so even if you were trying to get the console only, you should be using init 3 and not 1
 
Old 07-20-2006, 02:22 PM   #5
generalachoo
Member
 
Registered: Jul 2006
Posts: 56

Original Poster
Rep: Reputation: 15
Umm? Im a complete n00b with xserver and the xorg.conf file. What exactly do I do? Il l try the xorgcfg command though.

Thanks a lot.
 
Old 07-20-2006, 09:28 PM   #6
generalachoo
Member
 
Registered: Jul 2006
Posts: 56

Original Poster
Rep: Reputation: 15
Forget about Problem A: I got that working.

As for Problem B: How do I make Xgl work faster on my comp?
 
Old 07-20-2006, 11:21 PM   #7
zzyborg
Registered User
 
Registered: May 2006
Location: bangalore, india
Distribution: debian sarge, fedora 6
Posts: 7

Rep: Reputation: 0
you are right ... i interpreted the problem of unable to boot into linux as not even getting the console . thts y i opted for single user mode , thanks for the suggestion anyway

Quote:
Originally Posted by lockpicker
well zzyborg, you would probably not need to use the init 1 parameter because X is loaded bash
so incase the X is not workin, your terminals would still be workin! so you can check the configs anyway and also the init 1 option is for single user mode so even if you were trying to get the console only, you should be using init 3 and not 1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver-xfree86: Xserver could not start on my ATI-radeon video card Shankarrajus Debian 2 07-17-2006 07:00 AM
Xserver problems furcatus Linux - Newbie 2 12-09-2005 01:46 AM
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 07:24 PM
xserver problems quentusrex Debian 29 08-13-2004 09:19 PM
problems with xserver CMDR_PAIN Linux - Newbie 4 08-25-2003 07:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration