LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-17-2004, 12:01 AM   #1
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Rep: Reputation: 15
2.6.7 doesn't obey its configuration (!?)


i just went for 2.6.7 from 2.6.0, and lost my usb mouse.

I made sure I had compiled the kernel w/ modules for `usbhid´ as it's now called ( i think it used to be called ´hid´ before). What's interesting is that it's not loaded by default on boot time, i have to 'modprobe hidusb'... Do i really have to put that on the modprobe.preload / modprobe.conf ?

Another question:
when i type lsmod, i get minus signs '-' in the used by column instead of the usual use count and the modules that are using it.. anyone knows why that is?

third question:
I get a msg during boot saying something like:
********
PCI Bus master DMA unavailable, blabla
********

but I made sure I checked the following during configure of the kernel:

Generic PCI bus-master DMA support (BLK_DEV_IDEDMA_PCI)
Use PCI DMA by default when available (IDEDMA_PCI_AUTO)
SiS5513 chipset support (BLK_DEV_SIS5513) <== AS MODULE

That sis one is for my chipset (sis 735) which is covered by that module. Maybe the reason for this problem is that i have it as a module and not compiled in? Do I need to compile it in the kernel ? would initrd solve this?
 
Old 06-17-2004, 08:31 AM   #2
Kroppus
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Debian UNSTABLE + latest 2.6.kernel
Posts: 391

Rep: Reputation: 30
Have you tried resetting your BIOS? Or forcing it to update the ECS (or something like that..)
Usualy on the same place as "Are you using a Plug & Pray OS"

I had a strange one here the other day.

Working on my 3xsize bedup under the roof, i dropped a box of nails on my pc and it reboted..
But stopped on
"uhci_hcd 0000:00:07.2: Unlink after no-IRQ? Different ACPI or APIC settings may help."
So after pondering around i just reset the BIOS and it worked as a dream..
 
Old 06-17-2004, 07:27 PM   #3
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Original Poster
Rep: Reputation: 15
i fixed the mouse, fixed the minus signs on the lsmod and fixed the Bus master DMA by compiling that into the kernel.

Now the only problem that's left is that my windows partition wont mount..

here's my fstab:

/dev/hda5 / reiserfs notail 1 1
none /dev/pts devpts mode=0620 0 0
/dev/cdrom /mnt/cdrom iso9660 ro,user,iocharset=iso8859-1 0 0
/dev/fd0 /mnt/floppy auto sync,codepage=850,user,noauto 0 0
/dev/hda1 /mnt/windows vfat noexec,codepage=850,iocharset=iso8859-1,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0

if i do a 'mount /mnt/windows' I get:

mount: tipo de sistema de arquivos incorreto, opção inválida, superbloco inválido em /dev/hda1,
ou número excessivo de sistemas de arquivos montados

which into english means that incorrect filesystem type, invalid superblock in /dev/hda1 or excessive number of mounted filesystems.

I know that the correct filesystem is vfat for my windows partition obviously. And it was working before w/ 2.6.0 without any "invalid superblocks"... so what could be the prolem?

Thanks
 
Old 06-17-2004, 07:31 PM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
I know that the correct filesystem is vfat for my windows partition obviously.
Not if the Windows version is XP or 2000, which use the ntfs filesystem by default.

Possible?
 
Old 06-17-2004, 07:39 PM   #5
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Original Poster
Rep: Reputation: 15
problem fixed

believe it or not, the problem was the codepage=850 on that windows line...

what the hell does that thing do anyway? I removed it and now I'm able to mount it without any problems...! That was the "invalid option" apparently, even though its a valid option for vfat filesystems according to the man page.
 
Old 06-18-2004, 06:39 AM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Codepage specifies the character set used to display the filesystem's files. This is useful if you have files that have filenames in languages other than English, which may use characters not available in the English character set (umlauts, accents, etc). Specifiying a codepage enables these files to be displayed because the system has access to the characters of these filenames.

Microsoft explains this here.

Anyway, codepage 850 is Multiligual Latin (English and other latin-based languages, with included accents etc), and apparently your system is not set up for this so it is unrecognized. Presumably you don't have any non-English filenames on the partition anyway, so it should be un-noticeable that the setting is removed.

Glad you got it fixed.
 
Old 06-18-2004, 10:08 AM   #7
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Original Poster
Rep: Reputation: 15
the description of codepage is:
Sets the codepage for converting to shortname characters on FAT
and VFAT filesystems. By default, codepage 437 is used.

which makes no sense to me. I think what you were referring to is the iocharset option whose description is:

Character set to use for converting between 8 bit characters and
16 bit Unicode characters. The default is iso8859-1. Long file-
names are stored on disk in Unicode format.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thunderbird does not obey Font setup polemon Linux - Newbie 1 09-20-2005 10:05 AM
Your system configuration does not match your Evolution configuration ohoh Linux - Software 0 08-19-2004 03:06 PM
X configuration problem - OR - Where did the configuration tool go??? t3kn0lu5t Debian 3 09-25-2003 08:19 PM
making shutdown obey all users ssallen Programming 7 06-18-2003 07:21 AM
C++/C configuration Rex_chaos Programming 1 10-19-2001 04:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration