-   Linux - Software (
-   -   2.4.17-rc2 and NO SOUND (

LardOfTheFries 01-31-2002 10:00 PM

2.4.17-rc2 and NO SOUND
I'm installing 2.4.17-rc2 on my new Athlon system.
The motherboard is an "ecs k7s5a". I've finally got
the on-board ethernet talking through my LAN. My
problem is that I can't get the onboard sound to work.

I went to and found a link
forwarding me onto
At that location I found a statement that talked about the
SiS730/630/540 Audio driver for Linux, and that I could find
what I needed at

Since I already had 2.4.17 and had already obtained the
RedHat kernel headers, I also obtained the rc2 patch from I note that the rc2 diff patch contained
the following information:

"SIS 630/540/730 support
This is the frame buffer device driver for the SiS 630
and related Super Socket 7 UMA cards. Specs available
at <>."

Prior to patching rc2 into 2.4.17, I attempted a recursive grep
for CONFIG_FB_SIS_300, and found nothing. I considered this
a very good sign. After I patched rc2 into 2.4.17, I again
performed the same grep and got _many_ hits. I them performed
"make xconfig", selected "Console drivers", and then selected "Frame-buffer support". In order to obtain "SIS 630/540/730 support", I had to choose "SIS acceleration (EXPERIMENTAL)" and do all that is required to obtain that "EXPERIMENTAL" choice.

Subsequent to the kernel build and reboot, I still don't have audio. I don't know if this is a kernel config problem or system config problem. I should also note that I have also tried to use a well-supported Yamaha sound card and previously configured module support for that, too, without success. And yes, I used the BIOS setup to support the appropriate hardware configuration in both cases.

Can you give me a clue as to what I should do to further troubleshoot this problem, or where I might obtain more detailed information? I've been using Linux/Unix for many years, but I'm not a kernel hacker. Any and all help would be most greatly appreciated.


isajera 01-31-2002 11:12 PM

i've seen problems sometimes where an experimental module won't get loaded properly with the autoprobe. find out which module your soundcard needs and run a

modprobe modulename

and see if it works after that. the framebuffer support has to do with video - so that would be completely unrelated. most sis cards are video.

LardOfTheFries 02-01-2002 09:42 AM

Thanks for your very rapid response.

You state that "framebuffer support has to do with video - so that would be completely unrelated. most sis cards are video." I suppose it's also possible that the software driver developer and/or the configuration manager didn't do an excellent job at segregation/separation/compartmentalization of the driver modules. I hope to prove myself wrong.

If you go to and read down the page you come to the following statement:

===begin excerpt===

SiS730 family / SiS630 family / SiS540 Audio driver for Linux
You can install Linux system with Linux kernek 2.3.40 or later version. Or, you can contact with your Linux distributor for kernel update. For Linux expert, you can download the lastest Linux kernel and rebuild your Linux system with SiS7018 support enabled. The lastes Linux kernel is available on the following site to download.

===end excerpt===

I will perform a "grep -i -r" for "SiS" and "7018" or "540" from the linux source base. I'll also use your "modprobe modulename" suggestion once I find out the true module name. If all else fails, I'll also look at /var/log/messages and the dmesg output for additional clues.

Again, thanks very much for your help! I don't want to wait until the next stable kernel revision to have audio on my system, but if I must wait, I guess I will.

Aussie 02-02-2002 05:20 PM

Kernel 2.4.17 is newer than 2.4.17-rc2.

LardOfTheFries 02-02-2002 07:18 PM

Aussie, let's assume that 2.4.17 is indeed more recent than 2.4.17-rc2 . Quite frankly, I don't know. I don't even know what "rc2" stands for. What I can tell you is that a "grep SIS .config" returns the following in the "rc2" src directory,
and returns differently in the 2.4.17 src directory.

# CONFIG_FB_SIS_315 is not set

# CONFIG_DRM_SIS is not set
# CONFIG_FB_SIS is not set

Got any idea why they'd reduce the CONFIG selection from "rc2" to 2.4.17? Particularly since the ecs k7s5a sound driver writer apparently indirectly calls for CONFIG_SB_SIS_300 because of SIS 540 Audio driver support?

And in case anybody wonders about the "y", "m" and "not set" selections in the above, believe me, I've tried just about every combo imaginable without success in both source trees.

I'll report more later about "modprobe" and "lspci" results. I feel that this is both an exercise in my ignorance and frustration.

LardOfTheFries 02-02-2002 07:33 PM

Earlier I submitted a post wherein I quoted where it was stated "rebuild your Linux system with SIS7018 enabled". With that in mind, I dove into the src tree to find the following:

==begin excerpt==

Trident 4DWave DX/NX, SiS 7018 or ALi 5451 PCI Audio Core
Say Y or M if you have a PCI sound card utilizing the Trident 4DWave-DX/NX chipset or your mother board chipset has SiS 7018 or ALi 5451 built-in. The SiS 7018 PCI Audio Core is embedded in SiS960 Super South Bridge and SiS540/630 Single Chipset. The ALi 5451 PCI Audio Core is embedded in ALi M1535, M1535D, M1535+ or M1535D+ South Bridge.

Use lspci -n to find out if your sound card or chipset uses Trident 4DWave or SiS 7018. PCI ID 1023:2000 or 1023:2001 stands for Trident 4Dwave. PCI ID 1039:7018 stands for SiS7018. PCI ID 10B9:5451 stands for ALi5451.

==end excerpt==

lspci -n output follows:

00:00.0 Class 0600: 1039:0735 (rev 01)
00:01.0 Class 0604: 1039:0001
00:02.0 Class 0601: 1039:0008
00:02.2 Class 0c03: 1039:7001 (rev 07)
00:02.3 Class 0c03: 1039:7001 (rev 07)
00:02.5 Class 0101: 1039:5513 (rev d0)
00:02.7 Class 0401: 1039:7012 (rev a0)
00:03.0 Class 0200: 1039:0900 (rev 90)
00:0b.0 Class 0200: 10b7:9050
00:0d.0 Class 0780: 1813:4000 (rev 02)
00:0f.0 Class 0401: 1073:000d (rev 03)
01:00.0 Class 0300: 10de:0111 (rev b2)

It doesn't look like my motherboard matches the discription above concerning the SIS 7018 chipset. This is not good. If you want, I can provide the lspci -vv output, but it's quite verbose.

Furthermore, the following modprobes were performed under both the "rc2" and the 2.4.17 kernels:

"modprobe sound" apprently worked, since it returned without comment and the module is installed (according to /proc/modules).

Ditto for "modprobe soundcore".

"modprobe trident" returns the following:
/lib/modules/2.4.17-rc2/kernel/drivers/sound/trident.o: create_module: Operation not permitted
/lib/modules/2.4.17-rc2/kernel/drivers/sound/trident.o: insmod /lib/modules/2.4.17-rc2/kernel/drivers/sound/trident.o failed
/lib/modules/2.4.17-rc2/kernel/drivers/sound/trident.o: insmod trident failed

Note that the module trident.o exists in the /lib/modules/2.4.17* subdirs.

I'm beginning to believe that I don't have the same board used by the driver developer. Either that, or I continue to be incredibly clueless, which wouldn't surprise me. By the way, the sound works under XP. Is there some way I could get some useful information from the XP side?

Again, thanks for your assistance and patience with me!

Aussie 02-02-2002 07:59 PM

The file .config is simply the output of "make config, menuconfig or xconfig" what it says about SiS depends on what you selected when you ran "make *whatever*config" I use 2.4.17 (which is the final release, -rc2 is release cantidate two) and I only have one line about SiS and that is,
# CONFIG_FB_SIS is not set
Because I don't use it.

All times are GMT -5. The time now is 03:57 AM.