LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-13-2017, 09:54 PM   #1
MagicHands
LQ Newbie
 
Registered: Jan 2017
Location: Australia
Posts: 11

Rep: Reputation: Disabled
Unhappy {KDE NEON DEV STABLE} - Plasma Discover crashes with errors realting to appstream??


Hi all. I'm having an issue with the KDE Discover applicaiton in KDE Neon Dev Stable release.

The application opens with the message "Please make sure that AppStream is properly configured on your system"... I'm guessing this is related to the crashes.

When launching the application, this is the startup log:

Code:
nathan@Nathan-Desktop:~$ plasma-discover 
qrc:/qml/DiscoverWindow.qml:156:19: QML DiscoverDrawer: cannot find any window to open popup in.
invalid kns backend! "/etc/xdg/servicemenu.knsrc" because: "Config group not found! Check your KNS3 installation."
invalid kns backend! "/etc/xdg/ksysguard.knsrc" because: "Config group not found! Check your KNS3 installation."
Could not open the AppStream metadata pool
no packages for "VL812 B2 Firmware"
no packages for "VL811 Firmware"
no packages for "Rival SteelSeries"
no packages for "VL812 Firmware"
no packages for "VL811+ Firmware"
no packages for "UEFI Updates"
Discarding invalid backend "servicemenu.knsrc"
Discarding invalid backend "ksysguard.knsrc"
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Could not find category "Xfce Icon Theme"
kns error "/etc/xdg/cgcicon.knsrc" "All categories are missing"
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = plasma-discover path = /usr/bin pid = 32301
KCrash: Arguments: /usr/bin/plasma-discover 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

[1]+  Stopped                 plasma-discover
I've tried reinstalling plasma-discover, muon, appstream, etc. No luck. I've also followed some advice on another forum to run a a forced refresh of appstream with

Code:
sudo appstreamcli refresh --force
..but this also hasn't changed anything.

Some people mentioned these types of errors existed in appstrem 9.x but were fixed with the update to v10, I'm running v10.x and still getting issues.

I've tried to find logs etc to determine what is happening and I'm lost. Any suggestions?
 
Old 01-14-2017, 08:49 PM   #2
MagicHands
LQ Newbie
 
Registered: Jan 2017
Location: Australia
Posts: 11

Original Poster
Rep: Reputation: Disabled
Looks like it's a bug and already reported

Bug 374279 - https://www.mail-archive.com/kde-bugs-dist@kde.org/msg104767.html

A couple of teams pointing fingers at each other so it will be a while before this is resolved. Unless the community has any suggestions?
 
Old 01-15-2017, 04:30 AM   #3
MagicHands
LQ Newbie
 
Registered: Jan 2017
Location: Australia
Posts: 11

Original Poster
Rep: Reputation: Disabled
Updating today has fixed the instant crashes. But still breaks when clicking back. Thanks to the devs for working on this!
 
Old 01-16-2017, 02:34 PM   #4
MagicHands
LQ Newbie
 
Registered: Jan 2017
Location: Australia
Posts: 11

Original Poster
Rep: Reputation: Disabled
Crashes are back again. Anybody have any suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: KDE Neon 5.8 User Edition Linux OS Offers the Latest KDE Plasma 5.8 LTS Desktop LXer Syndicated Linux News 0 10-05-2016 11:51 AM
LXer: KDE Neon Linux Developer Edition to Use Wayland by Default for KDE Plasma 5.8 LXer Syndicated Linux News 0 09-07-2016 05:03 AM
LXer: KDE Plasma Wayland Image Now Built on KDE Neon Infrastructure, Qt 5.7 Is Coming LXer Syndicated Linux News 0 07-05-2016 12:36 AM
LXer: KDE Plasma 5.6.4 Desktop Environment Launches with Plasma Discover Improvements LXer Syndicated Linux News 0 05-10-2016 07:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration