LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   {KDE NEON DEV STABLE} - Plasma Discover crashes with errors realting to appstream?? (https://www.linuxquestions.org/questions/linux-software-2/%7Bkde-neon-dev-stable%7D-plasma-discover-crashes-with-errors-realting-to-appstream-4175597418/)

MagicHands 01-13-2017 09:54 PM

{KDE NEON DEV STABLE} - Plasma Discover crashes with errors realting to appstream??
 
Hi all. I'm having an issue with the KDE Discover applicaiton in KDE Neon Dev Stable release.

The application opens with the message "Please make sure that AppStream is properly configured on your system"... I'm guessing this is related to the crashes.

When launching the application, this is the startup log:

Code:

nathan@Nathan-Desktop:~$ plasma-discover
qrc:/qml/DiscoverWindow.qml:156:19: QML DiscoverDrawer: cannot find any window to open popup in.
invalid kns backend! "/etc/xdg/servicemenu.knsrc" because: "Config group not found! Check your KNS3 installation."
invalid kns backend! "/etc/xdg/ksysguard.knsrc" because: "Config group not found! Check your KNS3 installation."
Could not open the AppStream metadata pool
no packages for "VL812 B2 Firmware"
no packages for "VL811 Firmware"
no packages for "Rival SteelSeries"
no packages for "VL812 Firmware"
no packages for "VL811+ Firmware"
no packages for "UEFI Updates"
Discarding invalid backend "servicemenu.knsrc"
Discarding invalid backend "ksysguard.knsrc"
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Redirected to  "https://autoconfig.kde.org/ocs/providers.xml" ...
org.kde.knewstuff.core: Could not find category "Xfce Icon Theme"
kns error "/etc/xdg/cgcicon.knsrc" "All categories are missing"
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = plasma-discover path = /usr/bin pid = 32301
KCrash: Arguments: /usr/bin/plasma-discover
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

[1]+  Stopped                plasma-discover

I've tried reinstalling plasma-discover, muon, appstream, etc. No luck. I've also followed some advice on another forum to run a a forced refresh of appstream with

Code:

sudo appstreamcli refresh --force
..but this also hasn't changed anything.

Some people mentioned these types of errors existed in appstrem 9.x but were fixed with the update to v10, I'm running v10.x and still getting issues.

I've tried to find logs etc to determine what is happening and I'm lost. Any suggestions?

MagicHands 01-14-2017 08:49 PM

Looks like it's a bug and already reported

Bug 374279 - https://www.mail-archive.com/kde-bugs-dist@kde.org/msg104767.html

A couple of teams pointing fingers at each other so it will be a while before this is resolved. Unless the community has any suggestions?

MagicHands 01-15-2017 04:30 AM

Updating today has fixed the instant crashes. But still breaks when clicking back. Thanks to the devs for working on this!

MagicHands 01-16-2017 02:34 PM

Crashes are back again. Anybody have any suggestions?


All times are GMT -5. The time now is 11:32 AM.