LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-02-2010, 05:56 AM   #1
infcem
LQ Newbie
 
Registered: May 2010
Posts: 2

Rep: Reputation: 0
Question `GLIBCXX_3.4.9' not found


I installed arb software

Please wait while the program ARB is starting .....
arb_ntree: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by arb_ntree)

la version de l'os:
# cat /proc/version
Linux version 2.6.18-194.3.1.el5 (mockbuild@x86-004.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Sun May 2 04:17:42 EDT 2010

# rpm -qv glibc
glibc-2.5-49
glibc-2.5-49

# rpm -q --provides libstdc++
libstdc++ = 4.1.1-52.el5
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(CXXABI_1.3.1)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.1)(64bit)
libstdc++.so.6(GLIBCXX_3.4.2)(64bit)
libstdc++.so.6(GLIBCXX_3.4.3)(64bit)
libstdc++.so.6(GLIBCXX_3.4.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.5)(64bit)
libstdc++.so.6(GLIBCXX_3.4.6)(64bit)
libstdc++.so.6(GLIBCXX_3.4.7)(64bit)
libstdc++.so.6(GLIBCXX_3.4.8)(64bit)
libstdc++ = 4.1.2-48.el5
libstdc++ = 4.1.1-52.el5
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++.so.6(GLIBCXX_3.4.4)
libstdc++.so.6(GLIBCXX_3.4.5)
libstdc++.so.6(GLIBCXX_3.4.6)
libstdc++.so.6(GLIBCXX_3.4.7)
libstdc++.so.6(GLIBCXX_3.4.8)
libstdc++ = 4.1.2-48.el5

thank you
 
Old 06-02-2010, 06:51 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, Pi OS & Android
Posts: 12,043

Rep: Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420Reputation: 1420
The Problem was
Quote:
arb_ntree: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by arb_ntree)
You have installed
Quote:
libstdc++.so.6(GLIBCXX_3.4.1)(64bit)
libstdc++.so.6(GLIBCXX_3.4.2)(64bit)
libstdc++.so.6(GLIBCXX_3.4.3)(64bit)
libstdc++.so.6(GLIBCXX_3.4.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.5)(64bit)
libstdc++.so.6(GLIBCXX_3.4.6)(64bit)
libstdc++.so.6(GLIBCXX_3.4.7)(64bit)
libstdc++.so.6(GLIBCXX_3.4.8)(64bit)
Do you see GLIBCXX_3.4.9 there? I don't. I see 3.4.1 to 3.4.8. Try for a later rpm.
 
Old 06-02-2010, 09:24 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,394

Rep: Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607
GLIBCXX_3.4.9 : Can be searched with :
readelf -s /usr/lib/libstdc++.so.6 | grep GLIBCXX_3.4.9


G__LIB_CXX_3.4.9, this object is in ...
libstdc++.so.6 -> libstdc++.so.6.0.9 : from gcc-4.2 (or later)
No package for EL5, AFAIK.

This Slackware version seems usable, tested with ldd in EL5 / SL5
ftp://ftp.slackware.org.uk/slackware...2.3-i486-1.tgz
>>> gcc-g++-4.2.3-i486-1.tgz : Extract and cp libstdc++.so.6.0.9
to a new folder, e.g. /usr/lib_cxx/ , and : cd /usr/lib_cxx/
&& ln -s libstdc++.so.6.0.9 libstdc++.so.6


export LD_LIBRARY_PATH=/usr/lib_cxx:/usr/lib:/lib
... to have /usr/lib_cxx/ first in the library search path.
... And start your application in the same terminal sesion.
( The export command is temporary, will reset at exit.)
...
EDIT : Sorry, should have been 64 Bits,
I will find the "Slamd-12.1 - 64" package later.
(found): http://www.lividpenguin.lkams.kernel..._slamd64-1.tgz
→ gcc-g++-4.2.3-x86_64_slamd64-1.tgz
EDIT EDIT : tested libstdc++.so.6.0.9, Scientific SL55 = works perfect.
..

Last edited by knudfl; 06-02-2010 at 12:00 PM.
 
Old 06-02-2010, 11:20 AM   #4
infcem
LQ Newbie
 
Registered: May 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Smile

It's ok with gcc-g++-4.2.3-x86_64_slamd64-1 thank you very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1) babu198649 Linux - Newbie 24 12-02-2010 05:09 AM
GLIBCXX_3.4.9 for CentOS? Fnatte Linux - Newbie 0 06-22-2009 11:14 AM
FC4 - /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found TBennettcc Fedora 0 11-01-2008 10:39 PM
"/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found" worked but stil confused babu198649 Linux - Newbie 2 03-24-2008 02:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration