-   Linux - Software (
-   -   [SOLVED] VLC shows no image after upgrade (

wongdg 07-07-2009 12:39 AM

[SOLVED] VLC shows no image after upgrade
distro: Debian amd64
upgrade from lenny to testing

VLC is obviously a new version as its interface looks different and by default it opens the image in a separate window.

The newly upgraded VLC shows no image but sound regardless what video files I throw at it. It used to be working perfectly before the upgrade.

Several recommendations did not work for me, including setting the video output to x11 or openGL.

The error message:
Under "Tools" -> "Messages" it gave

main error: no video filter module matched "adjust"
main error: no suitable vout module
main error: failed to create video output

My solution:
delete away "vlc" directory
home$ .local/share/vlc

set your VLC preferences to default

and voila! It worked for me after several days effort of finding the net.
Do remember to share your experience, solutions with us all of the open source community. That is what Linux/GNU community is about.


rylan76 07-08-2009 02:58 AM

Fanx for posting that fix.

Have you tried MPlayer as a general movie player?

I've found it much easier to compile and install than VLC, it seems to play many more formats and comes with a powerful associated encoding utility.

XINE is good for playing DVDs with good DVD menu support as well.

tux_addict 09-01-2011 11:57 PM

I definitely second the suggestion to use Mplayer! I ended up on this thread while struggling to get VLC to play video. I think I'll just settle with Smplayer/Mplayer.

All times are GMT -5. The time now is 03:37 AM.