LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-09-2009, 07:18 AM   #1
wongdg
Member
 
Registered: May 2006
Location: Kuching, Malaysia
Distribution: Debian 2.4 & 2.6
Posts: 44

Rep: Reputation: 16
[SOLVED]: hylafax not sending "waiting for modem to become ready"


My problem is gfax doesn't send out fax. In its status window always give "waiting for modem to become ready"

I referred to the installation notes when I first installed and setup hylafax:

Do note that you had this message when you setup hylafax initially:

"You do not appear to be using faxgetty to notify the HylaFAX scheduler about new modems and/or their status. This means that you must use the faxmodem program to inform the new faxq process about the modems you want to have scheduled by HylaFAX. Beware that if you have modems that require non-default capabilities specified to faxmodem then you should read faxmodem(8C) manual page and do this work yourself (since this script is not intelligent enough to automatically figure out the modem capabilities and supply the appropriate arguments)."

Do read the hylafax handbook on its website, but here is the gist of it.

edit /etc/inittab
my modem is at /dev/ttyACM0
so add this line to /etc/inittab
t2:23:respawn:/usr/local/sbin/faxgetty /dev/ttyACM0

you have to reboot for this to take effect.

For me, before I need to reboot, I just run "faxgetty /dev/ttyACM0" in terminal (command line) then restart hylafax server (on debian) by
$ sudo /etc/init.d/hylafax restart
then start your fax client, my case its gfax
 
Old 10-20-2009, 08:06 PM   #2
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
This post is just to remove thread from "Zero Replies".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Proposed solution for "status" (aka "problem solved") indicator demerson3 LQ Suggestions & Feedback 12 04-08-2006 02:15 PM
suse 10.0 => processes "sending kill signal": "done, done, missing"...!? ungua Linux - Newbie 2 01-18-2006 10:52 AM
ALSA + slmodemd + "semaphore not ready" + no modem noise cyberjun Linux - Laptop and Netbook 21 04-06-2005 01:39 PM
Slackware 10.1 and USR5610 modem ("modem not ready") whitshade Slackware 2 03-15-2005 07:00 PM
"Modem Ready." "Sorry, Modem is busy." mkzmonkeylagger Linux - Hardware 1 04-16-2002 08:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration