-   Linux - Software (
-   -   [root@localhost Desktop]# vncviewer vncviewer not viewing kde display (

nickleus 11-02-2005 01:25 AM

vncviewer not viewing kde display
Hi folks, on my red hat 7.2 ( i have vncserver running on display 8 (not sure if this is right, but i assumed so because when i do ctrl+F8 i come to my kde graphical display). on my fedora core 4 ( i didn't have vncviewer so i installed the newest version from, tightvnc-1.2.9-1.i386.rpm.
i don't know what kind of vncserver is running on the red hat machine.
when i run from fedora:

i come to this wierd display that is not the grahpical kde display on the red hat machine, i only get up a gray screen with one black console window. why can't i see my graphical desktop on the red hat machine?

Tinkster 11-02-2005 01:32 AM

Tight(Real)VNC != x11vnc ... they actually both don't give
you your actual desktop but that other "thing" that you did
describe. If you want your REAL Desktop you need to install


nickleus 11-02-2005 01:36 AM

thanks tinkster, i'll try installing x11vnc on my fedora to see if that works. super quick reply, thank you very much!

nickleus 11-03-2005 04:37 AM

i installed x11vnc on the client (FC4) and it didn't help. i still get the same wierd window with one black floating console window. how do i check the server to see if the vncserver is indeed x11vnc?

shankscomp 11-03-2005 06:57 PM

I too have the same situation. I have Fedora Core 4 installed. I installed the VNC Server that's on the install CD. When I run vncviewer on any remove machine, all I get is the console also. I, however, run GNOME instead of KDE. After reading the above, I too would need to know how to check for x11vnc.


Tinkster 11-04-2005 12:57 AM


Originally posted by nickleus
i installed x11vnc on the client (FC4) and it didn't help. i still get the same wierd window with one black floating console window. how do i check the server to see if the vncserver is indeed x11vnc?
Checking the names of the running processes?
ps -A aux | grep -i vnc

Plus you'll have to start the x11vncserver from the running
X11 session....


nickleus 11-04-2005 04:10 AM

Please excuse my ignorance but what do you mean by running it from the X11 session?
Do i log into kde then start some kind of X11 window (which one?) and then in that window start x11vncserver <-- and is the script name x11vncserver or is it just vncserver? Thanks so much for helping me on this, i really want to get it to work :)

btw, i ran that ps command and i saw that it said Xvnc, so i'm guessing then that x11vncserver is running...?

bathory 11-04-2005 04:33 AM

Here is what I've done to be able to see the CDE session of my Solaris box.
I edit the ~/.vnc/xstartup and add a "Xsession&".
So I guess to be able to use KDE you have to edit that file and add "startkde" or something like that.

nickleus 11-04-2005 06:02 AM

bathory, so let me start from the beginning. i start up my server, i'm in console 1, i log in, i edit the ~/.vnc/xstartup by putting in the following:

save the file. and then run xstartup instead of the normal startx? and then when i get into kde i run vncserver? then go to my client and run vncviewer?
does that sound right? thanks again for everybody's patience and help :)

bathory 11-04-2005 06:19 AM

You don't need Xsession since it's for CDE. Also you start your xserver as you always do (i.e. through startx). This will make things more clear for you.

nickleus 11-04-2005 06:48 AM

thank you very much bathory! i can see the kde desktop, but it is a completely new session so the windows i have open on my server don't show. how do i actually see through vnc what i can physically see on my server as if i was standing right there?

bathory 11-04-2005 07:10 AM

To do this you must run x11vnc on the server. Read carefully the instructions to set it up the way you want.

nickleus 11-04-2005 09:11 AM

thanks so much bathory! you rule =) apparently i hadn't installed x11vnc so i went to that page you gave me, followed the download link, clicked on the recommended link, was redirected to, i downloaded x11vnc-0.7.2.tar.gz, "./configure"-ed it, "make"-ed it, "make install"-ed it, then ran:

x11vnc -forever
(you have to use -forever if you don't want x11vnc to close after a viewer closes its connection)

it set the display to 0 as default. on my client i ran the following on the command line:

and i came right in!!


nickleus 10-27-2006 03:58 AM


Originally Posted by nickleus
i downloaded x11vnc-0.7.2.tar.gz, "./configure"-ed it, "make"-ed it, "make install"-ed it

or just install this rpm:

All times are GMT -5. The time now is 07:56 PM.