LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-14-2003, 03:55 AM   #1
666Snake666
LQ Newbie
 
Registered: Sep 2003
Location: Amsterdam, The Netherlands
Distribution: Mandrake 9.1
Posts: 12

Rep: Reputation: 0
[Mandrake 9.1] Login problems with OpenSSH


Hello,

I am running a Mandrake 9.1 server with OpenSSH 3.6.1. I can login on the localhost but when I try to login from the internal network or from outside the internet it gives this error:

ssh_identification_exchange: Connection closed by remote host

My log files give this error:

sshd[4823]: refused connect from 193.172.*.* (193.172.*.*)

(I have replaced the last two bits of the IP with astrics so my IP-adress is not fully revealed)

I am running a firewall (shorewall) but it has port 22 open, so I don't think that that is the problem, since the problem remains when I shutdown the firewall. I can't really think of any more info at the moment which is relevant. I hope anybody can help me out with this.

Thanks in advantage.
 
Old 10-14-2003, 04:24 AM   #2
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Hi,

Can you run ssh with debug and post the output.

ssh -vvv 193.172.*.*

Iain.
 
Old 10-14-2003, 04:38 AM   #3
666Snake666
LQ Newbie
 
Registered: Sep 2003
Location: Amsterdam, The Netherlands
Distribution: Mandrake 9.1
Posts: 12

Original Poster
Rep: Reputation: 0
[adminja@nlzei-ws-Jorn adminja]$ ssh -vvv jorn@62.194.*.* (This is the IP adress of my server)

OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090701f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug2: ssh_connect: needpriv 0
debug1: Connecting to 62.194.*.* [62.194.*.* port 22.
debug1: Connection established.
debug1: identity file /home/adminja/.ssh/identity type -1
debug1: identity file /home/adminja/.ssh/id_rsa type -1
debug1: identity file /home/adminja/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host
debug1: Calling cleanup 0x8062180(0x0)
[adminja@nlzei-ws-Jorn adminja]$
 
Old 10-14-2003, 06:21 AM   #4
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Rep: Reputation: 30
Hi,
Can you post your sshd_config file?
 
Old 10-14-2003, 06:25 AM   #5
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Try renaming your ~/.ssh directory to another name (i.e. move it) and see if that makes a difference.
 
Old 10-14-2003, 07:08 AM   #6
666Snake666
LQ Newbie
 
Registered: Sep 2003
Location: Amsterdam, The Netherlands
Distribution: Mandrake 9.1
Posts: 12

Original Poster
Rep: Reputation: 0
Here is my sshd.conf: (On my server, of course)

Quote:
#$OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

#Port 22
Protocol 1,2
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 3600
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 120
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# rhosts authentication should not be used
#RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

#AFSTokenPassing no

# Kerberos TGT Passing only works with the AFS kaserver
#KerberosTgtPassing no

# Set this to 'yes' to enable PAM keyboard-interactive authentication
# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
#PAMAuthenticationViaKbdInt no

X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no
UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes

#MaxStartups 10
# no default banner path
#Banner /some/path
#VerifyReverseMapping no

# override default of no subsystems
Subsystem sftp /usr/lib/ssh/sftp-server
PermitRootLogin without-password
IgnoreRhosts yes
RhostsRSAAuthentication no
RhostsAuthentication yes
IgnoreUserKnownHosts yes
PrintMotd yes
StrictModes no
RSAAuthentication yes
PermitEmptyPasswords no
PasswordAuthentication yes
ReverseMappingCheck no
GatewayPorts yes
AllowTcpForwarding yes
KeepAlive yes
@ianr

Unfortunately that did not made a difference.
 
Old 10-15-2003, 07:13 AM   #7
666Snake666
LQ Newbie
 
Registered: Sep 2003
Location: Amsterdam, The Netherlands
Distribution: Mandrake 9.1
Posts: 12

Original Poster
Rep: Reputation: 0
Can anybody help me out with this? If not it is all right, but I would definitely would like to have my SSH server running.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with openssh server (ssh) shodekiagari Linux - Networking 10 10-16-2005 06:37 AM
OpenSSH, root login Duudson Linux - Security 7 01-30-2005 08:25 AM
login problems with mandrake 10 on vmware den myos Mandriva 4 11-09-2004 09:55 AM
Problems with sshd in openssh-3.9p1 Solaris.M.K.A Linux - Newbie 2 09-06-2004 01:43 AM
OpenSSH ssh-agent problems. Bug? darklogik_org Slackware 2 02-10-2004 06:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration