-   Linux - Software (
-   -   [F14] VirtualBox-OSE 4.0.2 "VERR_SUPLIB_OWNER_NOT_ROOT" error? (

Raveolution 06-08-2011 07:59 PM

[F14] VirtualBox-OSE 4.0.2 "VERR_SUPLIB_OWNER_NOT_ROOT" error?
When I try to run the 4.0.2 version of VirtualBox OSE on Fedora 14, I get the following error:


Failed to open a session for the virtual machine aiur2b.
Unknown error creating VM (VERR_SUPLIB_OWNER_NOT_ROOT).

Result Code:
NS_ERROR_FAILURE (0x80004005)
IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}

I've been running VirtualBox-OSE for over a year now on this system without any problems. No settings have changed. Yet suddenly OSE 4.0.2 doesn't want to open a VM anymore. I've tried it on my Fedora VMs, my Slackware VMs, Windows XP, ubuntu and Windows 95 VMs, none of them work now.

Is there any way possible to downgrade VirtualBox-OSE back to a version that doesn't come up with these errors? Thanks!

T3RM1NVT0R 06-09-2011 01:32 PM

@ Reply
Hi there,

Have a look at the following links:

Raveolution 06-09-2011 02:47 PM


Originally Posted by T3RM1NVT0R (Post 4381213)

If I read these solutions right it means I cannot run VirtualBox as a non-root user anymore. Is this true?

Edited: no, wait, nut-uh. /usr/lib was somehow chown'd to my primary non-root user. WTF. Solved, but there's a bigger problem lurking than that. How did any program chown that directory... I never sudo to root except to do yum updates.

T3RM1NVT0R 06-09-2011 03:05 PM

@ Reply
Not sure how that might have happened but it might be possible that you installed this application using sudo from that primary sudo account and that might have done that. But can't say for sure unless we are sure about the permissions before and after upgrade.

All times are GMT -5. The time now is 11:15 PM.