LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-19-2006, 04:32 PM   #1
brixton
LQ Newbie
 
Registered: Mar 2006
Location: czech republic
Distribution: Debian
Posts: 12

Rep: Reputation: 0
Unhappy :'-( proFTP problem


hi, i have a really weird problem ...
i am using proFTPd and i still cant get rid off this message:

Code:
speedking:/home/koubel# /etc/init.d/proftpd restart
Stopping ftp server: proftpd.
Starting ftp server: proftpd - IPv6 getaddrinfo 'speedking' error: Name or service not known
.
speedking:/home/koubel#
i googled a lot of time but the only solution i found was to edit /etc/hosts file. so i put my lnxbox-name into this file but is strange again ... have look at this:

my /etc/hosts file looks like this>

Code:
127.0.0.1       localhost
158.196.44.90 speedking
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
and when i try to restart the proftpd server, this message came up:

Code:
speedking:/home/koubel# /etc/init.d/proftpd restart
Stopping ftp server: proftpd.
Starting ftp server: proftpd - IPv6 getaddrinfo 'speedking' error: Name or service not known
.
speedking:/home/koubel#

so i tried to remove the 'speedking' line from the /etc/hosts file and this appeared>

Code:
speedking:/home/koubel# /etc/init.d/proftpd restart
Stopping ftp server: proftpd.
Starting ftp server: proftpd - IPv4 getaddrinfo 'speedking' error: Name or service not known
 - warning: unable to determine IP address of 'speedking'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/etc/proftpd/proftpd.conf'
 failed!
speedking:/home/koubel#

so what the bleep is going on? what i am doing wrong?

could anybody help?

thank you a lot for any suggestions!

---

Debian/GNU Linux
kernel 2.6.16-1-k7
proftpd 1.3.1-0
 
Old 04-19-2006, 05:00 PM   #2
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Quote:
Fatal: error processing configuration file '/etc/proftpd/proftpd.conf'
Have you looked in your proftpd.conf file to see where speedking is referenced?

Peace...
 
Old 04-19-2006, 05:15 PM   #3
brixton
LQ Newbie
 
Registered: Mar 2006
Location: czech republic
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: 0
yes i have ... the only refence to name 'speedking' is in this line>

Code:
ServerIdent on "speedking"
changing or deleting line mentioned above has no effect
...
 
Old 04-19-2006, 05:25 PM   #4
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Ok, I think I see what's going on now. Take a look at your /etc/hosts file. You've got speedking defined with an IPv4 address but not with an IPv6 address. If you're not interested in IPv6 support from ProFTPd, I would recompile it and disable any IPv6 support it might provide. I would run:

$ ./configure --help | more

and look for a "disable-ipv6" or similar option. Either that or define an IPv6 address for speedking and all should be well.

Peace...
 
Old 04-19-2006, 05:33 PM   #5
brixton
LQ Newbie
 
Registered: Mar 2006
Location: czech republic
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: 0
thank you.
first step ill try will be defining IP by the IPv6 rules... i dont like comlpiling a soft, so it will be the last option
 
Old 04-19-2006, 05:37 PM   #6
brixton
LQ Newbie
 
Registered: Mar 2006
Location: czech republic
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: 0
YES!!!!it worked! thank you very much!

the code i had to add to /etc/hosts was>

Code:
::ffff:158.196.44.90 speedking
in IPv6 section ...

great!

now the result is>

Code:
speedking:/home/koubel# /etc/init.d/proftpd restart
Stopping ftp server: proftpd.
Starting ftp server: proftpd.
speedking:/home/koubel#

thank you again!
 
Old 04-19-2006, 05:44 PM   #7
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Great! Where do I send my bill?

Peace...
 
Old 04-19-2006, 05:48 PM   #8
brixton
LQ Newbie
 
Registered: Mar 2006
Location: czech republic
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: 0


well my(or our?) good-uncle Bill G will pay for this

just kiddin'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftp upload problem jelgavchik Linux - Networking 2 03-23-2005 04:04 PM
proftp copying problem zatka Linux - Networking 2 01-11-2005 10:27 PM
ProFTP Problem KeithKessler Linux - Software 3 12-04-2004 09:28 AM
Another ProFTP Problem question... gwdragon Slackware 15 10-29-2004 03:14 AM
proftp chroot problem dazk Linux - Networking 1 12-19-2002 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration