LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-12-2015, 04:53 AM   #1
catchmeon
LQ Newbie
 
Registered: Mar 2015
Posts: 1

Rep: Reputation: Disabled
Unhappy Zimbra Installation: /usr/bin/perl: symbol lookup error: Perl_Istack_sp_ptr


I am facing problem installating Zimbra Open source edition version 8.6.0 GA on CentOS 6 (x86_64 bit)

but installation failed with error:

/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr


Any help or suggestion is highly appreciated


#################################
the stages i have gone through: #
#################################

[root@localmail zcs-8.6.0_GA_1153.RHEL6_64.20141215151155]# ./install.sh --platform-override

Operations logged to /tmp/install.log.29799
Checking for existing installation...
zimbra-ldap...NOT FOUND
zimbra-logger...NOT FOUND
zimbra-mta...NOT FOUND
zimbra-dnscache...NOT FOUND
zimbra-snmp...NOT FOUND
zimbra-store...NOT FOUND
zimbra-apache...NOT FOUND
zimbra-spell...NOT FOUND
zimbra-convertd...NOT FOUND
zimbra-memcached...NOT FOUND
zimbra-proxy...NOT FOUND
zimbra-archiving...NOT FOUND
zimbra-core...NOT FOUND


PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for the Zimbra Collaboration Suite:
http://www.zimbra.com/license/zimbra...-eula-2-5.html



Do you agree with the terms of the software license agreement? [N] y



Checking for prerequisites...
FOUND: NPTL
FOUND: nmap-ncat-6.40-4
FOUND: sudo-1.8.6p7-11
FOUND: libidn-1.28-3
FOUND: gmp-5.1.1-5
FOUND: libaio-0.3.109-12
FOUND: libstdc++-4.8.2-16.2
FOUND: unzip-6.0-13
FOUND: perl-core-5.16.3-283

Checking for suggested prerequisites...
FOUND: perl-5.16.3
FOUND: sysstat
FOUND: sqlite
Prerequisite check complete.

Checking for installable packages

Found zimbra-core
Found zimbra-ldap
Found zimbra-logger
Found zimbra-mta
Found zimbra-dnscache
Found zimbra-snmp
Found zimbra-store
Found zimbra-apache
Found zimbra-spell
Found zimbra-memcached
Found zimbra-proxy


Select the packages to install

Install zimbra-ldap [Y]

Install zimbra-logger [Y]

Install zimbra-mta [Y]

Install zimbra-dnscache [Y]

Install zimbra-snmp [Y]

Install zimbra-store [Y]

Install zimbra-apache [Y]

Install zimbra-spell [Y]

Install zimbra-memcached [Y]

Install zimbra-proxy [Y]
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-dnscache
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell
zimbra-memcached
zimbra-proxy

You appear to be installing packages on a platform different
than the platform for which they were built.

This platform is RHEL7_64
Packages found: RHEL6_64
This may or may not work.

Using packages for a platform in which they were not designed for
may result in an installation that is NOT usable. Your support
options may be limited if you choose to continue.


Install anyway? [N] y

The system will be modified. Continue? [N] y

Removing /opt/zimbra
Removing zimbra crontab entry...done.
Cleaning up zimbra init scripts...done.
Cleaning up /etc/ld.so.conf...done.
Cleaning up /etc/security/limits.conf...done.

Finished removing Zimbra Collaboration Server.

Installing packages

zimbra-core......zimbra-core-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-ldap......zimbra-ldap-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-logger......zimbra-logger-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-mta......zimbra-mta-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-dnscache......zimbra-dnscache-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-snmp......zimbra-snmp-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-store......zimbra-store-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-apache......zimbra-apache-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-spell......zimbra-spell-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-memcached......zimbra-memcached-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
zimbra-proxy......zimbra-proxy-8.6.0_GA_1153.RHEL6_64-20141215151155.x86_64.rpm...done
/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr
[root@localmail zcs-8.6.0_GA_1153.RHEL6_64.20141215151155]#

Last edited by catchmeon; 03-12-2015 at 04:55 AM.
 
Old 03-12-2015, 05:31 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
You appear to be installing packages on a platform different
than the platform for which they were built.

This platform is RHEL7_64
Packages found: RHEL6_64
This may or may not work.

Using packages for a platform in which they were not designed for
may result in an installation that is NOT usable. Your support
options may be limited if you choose to continue.
Most likely, you're using the wrong package for your OS
If you're running Centos7, you'll need this release
 
1 members found this post helpful.
Old 02-27-2016, 01:11 PM   #3
shubhankar
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Rep: Reputation: Disabled
Unhappy /usr/bin/perl: symbol lookup error

Please help me

I am installing zimbra in aws ec2 ami (centos 6), I got this error. please help me

/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr

Last edited by shubhankar; 02-27-2016 at 01:12 PM.
 
Old 02-28-2016, 02:49 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
@shubhankar

You give no details, but the same goes for you. The error means that the perl module was compiled against a different version of perl.
So make sure you're using the correct zimbra s/w for your platform
You could also post your question in zimbra forums.
 
Old 03-12-2016, 11:11 AM   #5
shubhankar
LQ Newbie
 
Registered: Feb 2016
Posts: 2

Rep: Reputation: Disabled
Thanks @bathory

I have changed my operating system , now it's working properly
 
1 members found this post helpful.
Old 12-09-2016, 11:20 PM   #6
shifislam
LQ Newbie
 
Registered: Dec 2016
Posts: 2

Rep: Reputation: Disabled
Facing the same Problem

I am facing the same problem. And now I get the initial solution. I need to know, do I have to remove my previous installation process of zimbra to start the suitable installation for my CentOS7 server? Thank you.

Last edited by shifislam; 12-09-2016 at 11:26 PM.
 
Old 12-10-2016, 03:28 AM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Hi and welcome to LQ,
Quote:
Originally Posted by shifislam View Post
I am facing the same problem. And now I get the initial solution. I need to know, do I have to remove my previous installation process of zimbra to start the suitable installation for my CentOS7 server? Thank you.
If there is something already installed under /opt/zimbra, then you can safely remove that directory and start over.

Regards
 
Old 12-10-2016, 04:42 AM   #8
shifislam
LQ Newbie
 
Registered: Dec 2016
Posts: 2

Rep: Reputation: Disabled
Quote:
Originally Posted by bathory View Post
Hi and welcome to LQ,

If there is something already installed under /opt/zimbra, then you can safely remove that directory and start over.

Regards
Thank you so much. I have removed those things along with zimbra folder and install again and now its working. But now I am facing admin log in problem. My mail server is mail.test.com, in adminlogin when I try to login with admin and [password] it shows authentication failed. Would you please suggest me the necessary checking and configurations for this. If I want to change my admin password (as my known password is not working) what should I do now?

Thank you....
 
Old 12-10-2016, 08:23 AM   #9
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Originally Posted by shifislam View Post
Thank you so much. I have removed those things along with zimbra folder and install again and now its working. But now I am facing admin log in problem. My mail server is mail.test.com, in adminlogin when I try to login with admin and [password] it shows authentication failed. Would you please suggest me the necessary checking and configurations for this. If I want to change my admin password (as my known password is not working) what should I do now?

Thank you....
You could use your favorite search engine to find out "how to reset zimbra admin password".
This is the 1st result I got by doing so

And since you're new here, please next time start your own thread describing you problem and not hijack others threads.

Regards
 
Old 12-10-2016, 09:36 AM   #10
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by shifislam View Post
I am facing the same problem. And now I get the initial solution. I need to know, do I have to remove my previous installation process of zimbra to start the suitable installation for my CentOS7 server? Thank you.
Code:
./install.sh --help
Doh.

Last edited by Habitual; 12-10-2016 at 09:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] symbol lookup error: /usr/sbin/httpd: undefined symbol: apr_file_link bagi Slackware 3 05-17-2011 07:49 AM
symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: av_crc04C11DB7 priceey Linux - Software 0 05-06-2009 08:14 AM
symbol lookup error: /usr/lib/libgtk-x11.2.0.so.0: undefined symbol:... IamI Slackware 17 02-29-2008 11:10 AM
./firefox-bin: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_s cb8100 Slackware 3 10-05-2006 10:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration