LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-23-2015, 08:20 PM   #1
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Rep: Reputation: Disabled
Smile Yum Update Errors


I have a Linux VPS running Centos 6.6

When I went to perform a "Yum Update" I received the following errors:

Error: Package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
Requires: bind = 32:9.8.2-0.23.rc1.el6_5.1
Removing: 32:bind-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
bind = 32:9.8.2-0.23.rc1.el6_5.1
Updated By: 32:bind-9.8.2-0.30.rc1.el6_6.1.x86_64 (updates)
bind = 32:9.8.2-0.30.rc1.el6_6.1
Available: 32:bind-9.8.2-0.30.rc1.el6.x86_64 (base)
bind = 32:9.8.2-0.30.rc1.el6
You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
3:mailman-2.1.12-18.el6.x86_64 has missing requires of httpd
mod_fcgid-2.3.7-1.el6.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd = ('1', '2.2.15', '30.el6.vm')
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
webalizer-2.21_02-3.3.el6.x86_64 has missing requires of httpd


Is there anything that I can do to fix these issues?

Any input/help would be greatly appreciated.

Thank you.
 
Old 02-23-2015, 09:40 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,400

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
it sounds like you manually installed some rpm's that were not from the updates or base repo

or
enabled a third party repo and DID NOT install and configure the needed yum plugin " yum-priorites"

the first thing i would do is to check the database
Code:
su -
yum clean all
rpm --rebuilddb
yum update
if that has the SAME error then have a look at the repos installed
--- you might want to post the out put ! ---

Code:
su -
yum repolist all
rhel/cent/sl 6 is not as bad as 5 was with third party repos BUT there are some incompatible rpm's in them

if there ARE no third party repos
then likely some random rpm's from random sites got installed

check WHERE bind-chroot-9.8.2-0.23 is from ( should be the cent update repo
Code:
su -
yum info bind-chroot-9.8.2-0.23
 
Old 02-23-2015, 09:53 PM   #3
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi John,

Thank you and I will give this a shot and see what happens. I will let you know.

Thanks again, Joan
 
Old 02-23-2015, 09:57 PM   #4
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi John,

I did the first suggestion and here is what I got:


root@vps25401 [~]# su -
root@vps25401 [~]# yum clean all
Loaded plugins: fastestmirror
Cleaning repos: base extras updates virtualmin virtualmin-universal
Cleaning up Everything
Cleaning up list of fastest mirrors
root@vps25401 [~]# rpm --rebuilddb
root@vps25401 [~]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Determining fastest mirrors
base | 3.7 kB 00:00
base/primary_db | 4.6 MB 00:00
extras | 3.4 kB 00:00
extras/primary_db | 30 kB 00:00
updates | 3.4 kB 00:00
updates/primary_db | 2.1 MB 00:00
virtualmin | 1.2 kB 00:00
virtualmin/primary | 35 kB 00:00
virtualmin-universal | 1.2 kB 00:00
virtualmin-universal/primary | 24 kB 00:00
virtualmin-universal: [########################################### ] 203/217Resolving Dependencies
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.23.rc1.el6_5.1 for package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64
---> Package bind.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
--> Finished Dependency Resolution
Error: Package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
Requires: bind = 32:9.8.2-0.23.rc1.el6_5.1
Removing: 32:bind-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
bind = 32:9.8.2-0.23.rc1.el6_5.1
Updated By: 32:bind-9.8.2-0.30.rc1.el6_6.1.x86_64 (updates)
bind = 32:9.8.2-0.30.rc1.el6_6.1
Available: 32:bind-9.8.2-0.30.rc1.el6.x86_64 (base)
bind = 32:9.8.2-0.30.rc1.el6
You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
3:mailman-2.1.12-18.el6.x86_64 has missing requires of httpd
mod_fcgid-2.3.7-1.el6.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd = ('1', '2.2.15', '30.el6.vm')
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
webalizer-2.21_02-3.3.el6.x86_64 has missing requires of httpd
 
Old 02-23-2015, 10:00 PM   #5
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi John,

I did the second suggestion:
su -
yum repolist all

Here are the results:

root@vps25401 [~]# su -
root@vps25401 [~]# yum repolist all
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
repo id repo name status
C6.0-base CentOS-6.0 - Base disabled
C6.0-centosplus CentOS-6.0 - CentOSPlus disabled
C6.0-contrib CentOS-6.0 - Contrib disabled
C6.0-extras CentOS-6.0 - Extras disabled
C6.0-updates CentOS-6.0 - Updates disabled
C6.1-base CentOS-6.1 - Base disabled
C6.1-centosplus CentOS-6.1 - CentOSPlus disabled
C6.1-contrib CentOS-6.1 - Contrib disabled
C6.1-extras CentOS-6.1 - Extras disabled
C6.1-updates CentOS-6.1 - Updates disabled
C6.2-base CentOS-6.2 - Base disabled
C6.2-centosplus CentOS-6.2 - CentOSPlus disabled
C6.2-contrib CentOS-6.2 - Contrib disabled
C6.2-extras CentOS-6.2 - Extras disabled
C6.2-updates CentOS-6.2 - Updates disabled
C6.3-base CentOS-6.3 - Base disabled
C6.3-centosplus CentOS-6.3 - CentOSPlus disabled
C6.3-contrib CentOS-6.3 - Contrib disabled
C6.3-extras CentOS-6.3 - Extras disabled
C6.3-updates CentOS-6.3 - Updates disabled
C6.4-base CentOS-6.4 - Base disabled
C6.4-centosplus CentOS-6.4 - CentOSPlus disabled
C6.4-contrib CentOS-6.4 - Contrib disabled
C6.4-extras CentOS-6.4 - Extras disabled
C6.4-updates CentOS-6.4 - Updates disabled
C6.5-base CentOS-6.5 - Base disabled
C6.5-centosplus CentOS-6.5 - CentOSPlus disabled
C6.5-contrib CentOS-6.5 - Contrib disabled
C6.5-extras CentOS-6.5 - Extras disabled
C6.5-updates CentOS-6.5 - Updates disabled
base CentOS-6 - Base enabled: 6,456+62
base-debuginfo CentOS-6 - Debuginfo disabled
c6-media CentOS-6 - Media disabled
centosplus CentOS-6 - Plus disabled
contrib CentOS-6 - Contrib disabled
extras CentOS-6 - Extras enabled: 37
fasttrack CentOS-6 - fasttrack disabled
updates CentOS-6 - Updates enabled: 745+40
virtualmin RHEL/CentOS/Scientific 6 - x86_64 - Virtu enabled: 47+77
virtualmin-universal Virtualmin Distribution Neutral Packages enabled: 202+1
repolist: 7,487


Now what?

Thank you,
Joan
 
Old 02-23-2015, 10:03 PM   #6
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Here is number 3 suggestion results:

root@vps25401 [~]# su -
root@vps25401 [~]# yum info bind-chroot-9.8.2-0.23
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Error: No matching Packages to list



Please let me know the next step, if you have one for me.

Thank you again,
Joan
 
Old 02-26-2015, 09:58 AM   #7
newbiegirl
LQ Newbie
 
Registered: Feb 2015
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi There.......

I really could use some guidance and it would be greatly appreciated.

My yum update errors still exist. I forgot to mention that I use cPanel. I upgraded from Virtualmin/Webmin/Usermin

I had a file missing which has been added. It is: the following line in your /etc/yum.conf file if you have already installed cPanel:

Code:
exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* php* proftpd* pure-ftpd* spamassassin* squirrelmail*

So I ran this again:
su -
yum clean all
rpm --rebuilddb
yum update

root@vps25401 [~]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.23.rc1.el6_5.1 for package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64
---> Package bind.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
--> Finished Dependency Resolution
Error: Package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
Requires: bind = 32:9.8.2-0.23.rc1.el6_5.1
Removing: 32:bind-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
bind = 32:9.8.2-0.23.rc1.el6_5.1
Updated By: 32:bind-9.8.2-0.30.rc1.el6_6.1.x86_64 (updates)
bind = 32:9.8.2-0.30.rc1.el6_6.1
Available: 32:bind-9.8.2-0.30.rc1.el6.x86_64 (base)
bind = 32:9.8.2-0.30.rc1.el6
You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
3:mailman-2.1.12-18.el6.x86_64 has missing requires of httpd
mod_fcgid-2.3.7-1.el6.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd = ('1', '2.2.15', '30.el6.vm')
2:mod_ssl-2.2.15-30.el6.vm.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
webalizer-2.21_02-3.3.el6.x86_64 has missing requires of httpd
root@vps25401 [~]#

Then I did:
su -
yum repolist all

root@vps25401 [~]# su -
root@vps25401 [~]# yum repolist all
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
repo id repo name status
C6.0-base CentOS-6.0 - Base disabled
C6.0-centosplus CentOS-6.0 - CentOSPlus disabled
C6.0-contrib CentOS-6.0 - Contrib disabled
C6.0-extras CentOS-6.0 - Extras disabled
C6.0-updates CentOS-6.0 - Updates disabled
C6.1-base CentOS-6.1 - Base disabled
C6.1-centosplus CentOS-6.1 - CentOSPlus disabled
C6.1-contrib CentOS-6.1 - Contrib disabled
C6.1-extras CentOS-6.1 - Extras disabled
C6.1-updates CentOS-6.1 - Updates disabled
C6.2-base CentOS-6.2 - Base disabled
C6.2-centosplus CentOS-6.2 - CentOSPlus disabled
C6.2-contrib CentOS-6.2 - Contrib disabled
C6.2-extras CentOS-6.2 - Extras disabled
C6.2-updates CentOS-6.2 - Updates disabled
C6.3-base CentOS-6.3 - Base disabled
C6.3-centosplus CentOS-6.3 - CentOSPlus disabled
C6.3-contrib CentOS-6.3 - Contrib disabled
C6.3-extras CentOS-6.3 - Extras disabled
C6.3-updates CentOS-6.3 - Updates disabled
C6.4-base CentOS-6.4 - Base disabled
C6.4-centosplus CentOS-6.4 - CentOSPlus disabled
C6.4-contrib CentOS-6.4 - Contrib disabled
C6.4-extras CentOS-6.4 - Extras disabled
C6.4-updates CentOS-6.4 - Updates disabled
C6.5-base CentOS-6.5 - Base disabled
C6.5-centosplus CentOS-6.5 - CentOSPlus disabled
C6.5-contrib CentOS-6.5 - Contrib disabled
C6.5-extras CentOS-6.5 - Extras disabled
C6.5-updates CentOS-6.5 - Updates disabled
base CentOS-6 - Base enabled: 6,456+62
base-debuginfo CentOS-6 - Debuginfo disabled
c6-media CentOS-6 - Media disabled
centosplus CentOS-6 - Plus disabled
contrib CentOS-6 - Contrib disabled
extras CentOS-6 - Extras enabled: 37
fasttrack CentOS-6 - fasttrack disabled
updates CentOS-6 - Updates enabled: 748+40
virtualmin RHEL/CentOS/Scientific 6 - x86_64 - Virtu enabled: 47+77
virtualmin-universal Virtualmin Distribution Neutral Packages enabled: 202+1
repolist: 7,490
root@vps25401 [~]#

Is there anything that should be disabled that is enabled, that may help fix my problem?

Thank you so much, I appreciate any input & assistance that you can provide.


My Problem has been resolved!

I used the following based on someone's recommendation:

rpm -e --nodeps bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64

Last edited by newbiegirl; 02-26-2015 at 02:37 PM. Reason: Problem solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum errors after failed update through Software Update whitesleeve Fedora 1 07-24-2011 04:02 AM
[SOLVED] Yum update Errors Genocide_Hoax Linux - Newbie 4 06-30-2011 11:20 PM
yum update transaction check errors & mirror errors tonycunn Linux - Software 2 11-29-2010 09:16 AM
[SOLVED] yum update errors faizlo Fedora 10 10-26-2010 04:09 AM
Yum update errors gnjunior Fedora 4 01-17-2006 07:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration