-   Linux - Server (
-   -   yum update broken dependencies (

KuimFieg 04-23-2013 04:13 AM

yum update broken dependencies
Hi all,

I'm running a CentOS 6.4 server with iRedMail.

This is my first experience with CentOS. (I'm more Debian focused).

After a year of service, I now have a dependency problem when updating the system.

I did enable an extra repo long ago (EPEL) because I needed additional software.

Anyways here is the output of yum update


Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamav.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamav-db.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamav-db.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamd.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamd.x86_64 0:0.97.7-1.el6.rf will be an update
--> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noarch
--> Finished Dependency Resolution
Error: Package: amavisd-new-2.8.0-4.el6.noarch (@epel)
          Requires: /etc/clamd.d
          Removing: clamd-0.97.7-1.el6.x86_64 (@epel)
              Not found
          Updated By: clamd-0.97.7-1.el6.rf.x86_64 (iRedMail)
              Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

There's obviously a problem with 2 conflicting repos. I tried enabling yum priorities to no avail.

If anyone with experience with this matter and could point me in the right direction it'd be much appreciated.

eggshell 04-23-2013 06:42 AM

I would try simply disabling the repo not required for the install and re-enabling it there after. You can achieve this by editing the repo file it self:

vi /etc/yum.repo.d/someRepoName

## Change

## To

chrism01 04-23-2013 07:29 AM

This shows you've also enabled rpmforge

Updated By: clamd-0.97.7-1.el6.rf.x86_64 (iRedMail)
You really need to install/setup to control updates or you'll get a broken system.

KuimFieg 04-23-2013 07:58 AM

Thanks for the replies,

Disabling iRedMail repo gives me no update. Disabling Epel repo still gives me the same conflict messages.

The ".rf" packages are actually provided by iRedMail which gives a complete mail server setup from the start. I actually enable the Epel repo only later on to get rdiff-backup !


yum list installed | grep '@epel' | wc -l

So I have about 30 packages including clam* and amavisd-new which have been updated accidently from the wrong repo. Any advice on how to handle the issue ?

I've setup priorities but for the moment I still can't update my system properly.

chrism01 04-24-2013 01:23 AM

I think you'll have to 'yum remove ...' the pkgs and re-install, now you've got priorities setup.
Incidentally, watch out as yum can get carried away with removals.
It may be better to just try that and see what it wants to do, then manually remove the rpms instead of saying yes to yum.
See 'rpm -e ..'

Depending on how bad this is, it could be quite a job.

KuimFieg 04-24-2013 02:57 AM

Ok thanks for the tip.

As this is a live server, I might just try to let the next version bump resolve the conflict. I haven't messed up core packages so I hope that might do the trick.

Thanks again

chrism01 04-24-2013 03:43 AM

In that case I'd disable all but the official repos first and good luck :)

All times are GMT -5. The time now is 06:57 AM.