LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   yum install php-imap doesn't work on CentOS? (https://www.linuxquestions.org/questions/linux-server-73/yum-install-php-imap-doesnt-work-on-centos-722410/)

guest 04-29-2009 01:30 AM

yum install php-imap doesn't work on CentOS?
 
Resolving Dependencies
--> Running transaction check
---> Package php-imap.x86_64 0:5.1.6-23.2.el5_3 set to be updated
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-imap
--> Running transaction check
---> Package php-imap.x86_64 0:5.1.6-23.2.el5_3 set to be updated
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-imap
---> Package libc-client.x86_64 0:2004g-2.2.1 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: php-common = 5.1.6-23.2.el5_3 is needed by package php-imap


so it's telling me i'm missing depency php-common, but when i try to yum install php-common, it tells me: "Nothing to do"


anyone know why this is happening? i've installed php-imap on all servers fine except one.. so strange..

thanks in advance!

billymayday 04-29-2009 01:51 AM

Can you show

yum list php-common

guest 04-29-2009 01:54 AM

Sure:

[root@localhost ~]# yum list php-common
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading mirror speeds from cached hostfile
* utterramblings: www.jasonlitka.com
* rpmforge: apt.sw.be
* extras: updates.interworx.info
* updates: styx.biochem.wfubmc.edu
* base: updates.interworx.info
* addons: centos.aol.com
545 packages excluded due to repository priority protections
Installed Packages
php-common.x86_64 5.2.6-jason.1 installed
Available Packages
php-common.x86_64 5.1.6-23.2.el5_3 updates

billymayday 04-29-2009 01:57 AM

How did you install the package that's there? Clearly php-imap needs 5.1.6-23.2, but you already have a later version.

Do you know if you can remove the 5.2.6 version without damaging anything else?

chrism01 04-29-2009 01:59 AM

As you can see, you need to remove php-common.x86_64 5.2.6-jason.1
Are you sure want that as a repo?

guest 04-29-2009 02:00 AM

I'm not sure.. i did yum update.. it updated about 200+ items.. i would assume php-common comes with php when i installed php.. i've no idea how to remove an install w/o damaging the server...

guest 04-29-2009 02:02 AM

i forgot how to remove that repo.. how do i remove php-common?

billymayday 04-29-2009 02:04 AM

Start by posting

yum repolist

guest 04-29-2009 02:25 AM

I've just removed jasonlitka's

[root@localhost ~]# yum repolist
Loading "fastestmirror" plugin
Loading "priorities" plugin
repo id repo name status
addons CentOS-5 - Addons enabled
base CentOS-5 - Base enabled
extras CentOS-5 - Extras enabled
rpmforge Red Hat Enterprise 5 - RPMforge.net - da enabled
updates CentOS-5 - Updates enabled



Here's another one that maybe of use:
[root@localhost ~]# rpm -qa |grep php
php-5.2.6-jason.1
php-pdo-5.2.6-jason.1
php-cli-5.2.6-jason.1
php-mysql-5.2.6-jason.1
php-common-5.2.6-jason.1

guest 04-29-2009 02:36 AM

works now.. i did this:
rpm -ivh libc-client-2004g-2.2.1.x86_64.rpm (since it was just missing that)
and did yum install php-imap and worked fine :)


thanked for trying :)

billymayday 04-29-2009 02:39 AM

I'm not sure where you got those from. The versions in the repos you currently have enabled are all 5.1.26.

Without hitting "yes" (ie cancel rather than proceed) what happens if you try

yum remove php php-pdo php-cli php-mysql php-common

?

You may get a huge list of other packages it wants to remove which indicated trouble. The real question is whether or not you have any apps that rely on the later version of php and its associated packages.

edit - ignore that then


All times are GMT -5. The time now is 07:50 AM.