LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   yum configuration issue (https://www.linuxquestions.org/questions/linux-server-73/yum-configuration-issue-4175457864/)

thirstonlinux 04-12-2013 12:42 AM

yum configuration issue
 
Hi All,

I have configured YUM on the server machine but when i try to install a package via YUM, I am getting an error message.

I did the configuration like below.

1. created a directory in /var/ftp/pub/repos
2. dumped all the packages from the iso image to the repos directory.
3. Installed createrepo and ran it.
4. edited the config file server.repo
name=yumserver
baseurl=file:///var/ftp/pub/repos
enabled=1


After the above step, tried to install telnet using yum using the command "yum install telnet" and got an error message " telnet-...Failue:...from InstallMedia: [Error no 256] No more mirrors to try."

After this I realised to run "yum clean all" command and tried to install telnet again. But got an error message saying " Cannot retrieve repository metadata (repomd.xml) for repository: InstallMedia. Please verify its path and try again."

I checked for the repomd.xml file in /var/ftp/pub/repos/repodata and I was able to find it.


But still I am having the same problem. Pleas help

chrism01 04-12-2013 01:17 AM

Try this howto: https://code.google.com/p/iredmail/w...Yum_Repository and check you don't have any other repos defined
Code:

yum repolist
and check the contents of /etc/yum.repos.d


All times are GMT -5. The time now is 06:31 AM.