LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-26-2010, 07:43 AM   #1
mercxi
LQ Newbie
 
Registered: Feb 2008
Posts: 20

Rep: Reputation: 0
XP Clients can no longer login to Samba Domain


I use OpenSuse 11.3 and I successfully built a samba/openldap server. However the raoming profiles were not working so I removed the roaming profile part of the samba and the openldap using ldap account manager. I also rejoined a couple of the computers back to the domain successfully (it was not an instaneous join, it took a good minute or 2 to join each pc). Now I cannot cannot login to any of these computers with the domain credentials. I can share using the UNC path no problem and this was working find about 1 week ago.

On 1 of the computers Iw as able to finally get a log file saying this:



[2010/08/26 07:43:48.140270, 0] lib/util_sock.c:474(read_fd_with_timeout)
[2010/08/26 07:43:48.140334, 0] lib/util_sock.c:1432(get_peer_addr_internal)
getpeername failed. Error was Transport endpoint is not connected
read_fd_with_timeout: client 0.0.0.0 read error = No route to host.

also int he log.winbindd-idmap file
I get
ldap_initialize: Bad parameter to an ldap routine

any ideas?

Also here is the smb.conf file
# Primary Domain Controller smb.conf
# Global parameters
[global]
unix charset = utf8
workgroup = MERCDOMAIN
netbios name = mercserver
passdb backend = ldapsam:ldap://mercserver.mercdomain.com
username map = /etc/samba/smbusers
log level = 1
syslog = 0
log file = /var/log/samba/%m
max log size = 0
name resolve order = wins bcast hosts
time server = Yes
printcap name = CUPS
add user script = /usr/sbin/smbldap-useradd -m '%u'
delete user script = /usr/sbin/smbldap-userdel '%u'
add group script = /usr/sbin/smbldap-groupadd -p '%g'
delete group script = /usr/sbin/smbldap-groupdel '%g'
add user to group script = /usr/sbin/smbldap-groupmod -m '%g' '%u'
delete user from group script = /usr/sbin/smbldap-groupmod -x '%g' '%u'
set primary group script = /usr/sbin/smbldap-usermod -g '%g' '%u'
add machine script = /usr/sbin/smbldap-useradd -w '%u'
logon script = logon.bat
logon path = \\mercserver\profiles\%u
logon drive = H:
domain logons = Yes
domain master = Yes
wins support = Yes
# peformance optimization all users stored in ldap
ldapsam:trusted = yes
ldap suffix = dc=mercdomain,dc=com
ldap machine suffix = ou=Computers,ou=Users
ldap user suffix = ou=People,ou=Users
ldap group suffix = ou=Groups
ldap idmap suffix = ou=Idmap
ldap admin dn = cn=Manager,dc=mercdomain,dc=com
idmap backend = ldap:ldap:///127.0.0.1
idmap uid = 10000-20000
idmap gid = 10000-20000
printer admin = root
printing = cups
ldap ssl = off
usershare max shares = 100
# smb ports=139

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = /home/samba/profiles
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root

Last edited by mercxi; 08-26-2010 at 08:00 AM.
 
Old 08-26-2010, 08:17 AM   #2
mercxi
LQ Newbie
 
Registered: Feb 2008
Posts: 20

Original Poster
Rep: Reputation: 0
if anyone is looking for the answer I just found it.

I changed the following:
idmap backend = ldap:ldap:///127.0.0.1

to

idmap backend = ldap:ldap:///mercserver
 
Old 09-03-2010, 05:12 PM   #3
pnguyen
LQ Newbie
 
Registered: Feb 2010
Posts: 7

Rep: Reputation: 1
You mentioned that the LDAP already removed and rejoin the clients back to Samba domain, but in your smb.conf still has many ldap command lines.
If I understand correctly that you start samba server as PDC without LDAP enabled, then remove all LDAP lines in smb.conf. I am running the same server with XP clients login OK! Nothing to modify "smb.conf" after running YAST2 to configure samba server, the shares, and firewall services as well.
If you have tried win7 to join the same domain successfully, please let me know. Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba : New windows xp clients cant join samba domain lyschange Linux - Newbie 4 08-31-2010 02:38 AM
XP clients won't login to samba domain beaker15 Linux - Server 3 02-22-2008 10:48 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 01:21 AM
XP clients as the member of the samba domain. bally Linux - General 7 08-27-2003 01:46 AM
Samba: W2k clients cannot login after joining domain Ajentsmith Linux - Networking 2 09-04-2002 12:29 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration