LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-20-2008, 05:03 PM   #1
jmaron
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Rep: Reputation: 0
xorg - unable to change gamma


I am having trouble trying to change gamma. Xgamma runs to completion and reports the change made, but the screen is unchanged.
The software involved is Slackware 10.2, Kernel 2.4.31 or 2.6.13 and Xorg 6.8. The video driver is I810. The video hardware is an onboard Intel 82865G. This is evidently not a hardware problem because a Ubuntu live cd on the same hardware ( Kernel 2.6.? and Xorg 7.0) works fine. I don't know how to address this problem. Is it a kernel or an xorg issue?
I have examined Xorg.0.log and followed may red herrings but to no avail. Further complicating the issue - On another machine, Kernel 2.4.26, Xorg 6.7 with an ATI driver and card works fine.

Here are the relevant parts of xorg.conf

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82865G Integrated Graphics Con
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
|
|
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 03-20-2008, 05:49 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
On my system (PCLOS 2007) running xgamma does not affect xorg.conf. But--I cannot find what config file is changed???

You can also specify gamma directly in the xorg.conf file
 
Old 03-20-2008, 09:07 PM   #3
jmaron
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 0
I neglected to mention that trying to set gamma in the conf filed was also ineffective.
 
Old 03-22-2008, 12:04 PM   #4
jmaron
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Although there doesn't appear to be much interest in this subject,
here is some more info which may be a clue or another red herring.

Xorg.0.log gives:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
[drm] failed to load kernel module "i915"

Modprobe gives:
modprobe: Can't locate module i915

but a search for i915 finds:
/usr/X11R6/lib/modules/dri/i915_dri.so

I don't know why it is searching for i915 or if this has anything to do with setting gamma, but I will continue blundering about searching for a solution.
 
Old 03-22-2008, 01:49 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Lack of response does not necessarily mean lack of interest---maybe noone knows the answer.

I spotted something in the xorg.conf man page...to the effect that not all video cards support gamma control.

I would do some Google searches. Start with something like "monitor gamma control in linux"
 
Old 03-22-2008, 03:10 PM   #6
jmaron
LQ Newbie
 
Registered: Mar 2008
Posts: 22

Original Poster
Rep: Reputation: 0
Thank you for your attention. The problem does not seem to come from the card as it works fine with the ubuntu live cd.
I have been searching the internet for weeks now and have turned up a few queries describing the same problem but very few suggestions on how to proceed.
Does anyone know a good Xorg forum?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg unable to configure Sharp TV projekthosting Linux - Hardware 4 08-30-2007 05:56 PM
xorg issues, unable to get specific resolutions farkus888 Linux - Software 15 06-16-2007 07:54 AM
Can't Change Xorg Resolution! SolidSnakeX28 Linux - Software 18 06-27-2006 02:24 PM
change xv overlay gamma, possible? AndreasB Linux - Hardware 0 11-05-2003 04:42 PM
how to change gamma?? Mux Linux - Software 2 10-13-2002 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration