LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-16-2008, 10:01 AM   #1
khmerler2004
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
Smile Xlib: connection to ":0.0" refused by server


$ xhost + localhost
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xhost: unable to open display ":0.0"

This is the error that I am getting when I try to run a program that is using xserver through ssh.

I set up export DISPLAY=localhost:0.0
I set up xauth add displyinfo

When I run java program from the ssh terminal, I got error that said,
GTK can't open display.

I download gtk and install it. It does not work. I have try every document online. I still get the sam error.

I am using redhat fedora linux.

When I set it on ubuntu, it works fine.
 
Old 12-17-2008, 06:47 AM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,646

Rep: Reputation: 98
Hya

Does your ssh allow X to go through?

Happy Penguins!
 
Old 12-17-2008, 03:27 PM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
I seen this before, so I had a look at my notes and this is what I had:
Code:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
FIX: apt-get install --reinstall kde-guidance     Re-boot        Then reinstall NVIDIA drivers
I have Debian with KDE and Nvidia graphics. I originally though the fix would be this other note in my notes, I guess it wouldn't hurt to try this also:
Code:
Add to /root/.bashrc:
export XAUTHORITY=/home/your_user_name/.Xauthority
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Linux - Newbie 11 04-22-2015 09:17 AM
anybody familiar with this error "Xlib: connection to ":0.0" refused by server" ? rajnivanza Linux - Newbie 3 03-22-2009 05:10 PM
Xlib: connection to ":0.0" refused by server Xlib: No protocol ... ousoso@webmail.co.za Linux - Newbie 1 05-06-2008 07:46 AM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified rajnivanza Linux - Software 1 03-13-2008 01:16 PM
Xlib: connection to ":0.0" refused by server Xlib: No protocol specified eyalkz Programming 1 03-02-2004 08:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 03:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration