-   Linux - Server (
-   -   XFS Filesystem not mounting (

pbrunnen 09-13-2010 12:54 PM

XFS Filesystem not mounting
Hello all,

I have an XFS filesystem (not my root filesystem) that is not mounting.

We had a power failure over the weekend. All but one of our XFS mounts is comming up. Its a large mount (2TB) and I am not seeing errors per se...

But after attempting to mount it, it has been 4 hours and all we see in either dmesg output or in the messages file from the kernel is:

"Starting FXS recovery on filesystem: sdd1 (logdev: internal)"

Our mount process is dead and I don't see any disk i/o going on. Am I missing something here on this?

I rebooted the box once earlier and was able mount read-only with norecovery...

I tried xfs_check and it also produced a dead "xfs_df -i -p xfs_check -c check /dev/sdd1"

Thoughts? Ideas?

Thanks!! -Peter.

mcd 09-13-2010 09:25 PM

Can you see the partition table with fdisk? Does dmesg say anything? Or /var/log/messages? What kind of disk is it? You might be able to check the SMART status:

smartctl -Hc /dev/sda

If you have another 2TB lying around you could try using dd to copy data

dd if=/dev/sdd1 of=/dev/sde1

When you say

and it also produced a dead "xfs_df -i -p xfs_check -c check /dev/sdd1"
, what do you mean? Did it produce an error? Did it hang? How long did you leave it running?

pbrunnen 09-13-2010 11:18 PM

Hi mcd,

The partition is sitting on a RAID 6 sas disk array. All the other filesystems on the array are fine... Hardware diags are clean for the controller and no failed disks.


When you say
and it also produced a dead "xfs_df -i -p xfs_check -c check /dev/sdd1"
* Sorry, there was a typo there. It should read xfs_db not xfs_df...

When I run xfs_check on /dev/sdd1, nothing reports. From another terminal, when I do ps ax|grep xfs, I see the xfs_db as D and xfs_check as sleeping.

Nothing in dmesg or /var/log/messages outside the normal "Starting FXS recovery on filesystem: sdd1 (logdev: internal)"... no disk activity either.

Almost like there is something in the journal log causing it to hang on recovery...
A mount with -o ro,norecovery works. I am copying the files now before I 'experiment' on this volume any further.

Real puzzler here.

Thanks so much! :-)
-Cheers, Peter.

Coburn64 09-14-2010 05:43 AM

Backup and reformat the drive(s). It could be a internal filesystem glitch.

I prefer using EXT4 over XFS, EXT4 is super fast.

mcd 09-14-2010 09:33 AM

I agree, reformat it and see if that helps.

pbrunnen 09-14-2010 11:37 AM

Ended up getting it resolved with "xfs_repair -L" from a newer clonezilla live cd.

The log was apparently corrupted somehow... but just was not 'mentioning' it.

Either way... got my files back and only lost what what happening during the crash. -- understandable.

Thanks everyone.
-Cheers, Peter.

All times are GMT -5. The time now is 07:49 PM.