LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-02-2011, 12:25 PM   #1
Eddie Adams
LQ Newbie
 
Registered: Sep 2007
Posts: 22

Rep: Reputation: 0
wrong fs type, bad option, bad superblock


mount: wrong fs type, bad option, bad superblock on /dev/mapper/VolGroup01-LogVol00,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Above error showed up after a reboot. I am able to mount another partition of this disk (content with the home directories). However I cannot mount the main partition, so cannot read the Centos 5.2 syslog.

My suspicion is that mysql service made a large amount of temporary tables flooding the hdd space.

Is there any command I can run from a live distro to fix this?
 
Old 03-02-2011, 02:41 PM   #2
jcalzare
Member
 
Registered: Aug 2009
Location: Chicago
Distribution: CentOS
Posts: 114

Rep: Reputation: 34
What's in /etc/fstab?
 
Old 03-02-2011, 02:42 PM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
fsck ?
 
1 members found this post helpful.
Old 03-02-2011, 04:47 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
NEVER RUN fsck ON THE PARTITION CONTAINING A Logical Volume. (Excuse the shout, but I killed a whole volume with that mistake.)

Look at your /etc/fstab. It's possible that that LV is swap space, and, therefore, not mountable. In any case, look at the lvm tools to see what they think about the volume.
 
Old 03-02-2011, 11:30 PM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 18,146

Rep: Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935Reputation: 2935
Making wild generalized claims based on a single event is worse that the shouting.

fsck is a filesystem tool - it is irrelevant (to fsck) whether the filesystem is on a LV or a "real" partition. Anytime you have to run fsck to rectify problems you have the potential to lose data. Sad but true - fsck is a tool to ensure the validity of the filesystem, not your data necessarily.
 
Old 03-03-2011, 09:07 AM   #6
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
Quote:
Originally Posted by PTrenholme View Post
NEVER RUN fsck ON THE PARTITION CONTAINING A Logical Volume. (Excuse the shout, but I killed a whole volume with that mistake.)

Look at your /etc/fstab. It's possible that that LV is swap space, and, therefore, not mountable. In any case, look at the lvm tools to see what they think about the volume.
Eh, Just mentioning the fsck tool. Sorry you lost a volume that way. But, I think we all have -- i mean really isn't the first line of the fsck manual page "You might lose data using this tool" or something?

anyway... fsck should not be used on mounted volumes -- use a boot-cd and make sure that the volume is not mounted. You have a good idea though for the swap space check though.

I think, when using LV's, you'll want to fsck the Logical Volume itself, which a quick google of "fsck lvm" will turn up. To find your LV's, you can do a:
Code:
lvdisplay
Then to fsck them:

Code:
fsck.ext3 /dev/VolGroup00/LogVol01 (or whatever path they list as)

Last edited by szboardstretcher; 03-03-2011 at 09:20 AM.
 
1 members found this post helpful.
Old 03-03-2011, 12:18 PM   #7
Eddie Adams
LQ Newbie
 
Registered: Sep 2007
Posts: 22

Original Poster
Rep: Reputation: 0
lvdisplay output:

--- Logical volume ---
LV Name /dev/VolGroup01/LogVol00
VG Name VolGroup01
LV UUID 6YpwEF-wphp-i13f-VWcN-1NzS-9wLd-14WzPp
LV Write Access read/write
LV Status available
# open 0
LV Size 64.53 GiB
Current LE 2065
Segments 1
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 253:0

--- Logical volume ---
LV Name /dev/VolGroup01/LogVol02
VG Name VolGroup01
LV UUID kgrW14-qfRN-dyrT-tSzg-jqCV-Kbuq-8ivg2f
LV Write Access read/write
LV Status available
# open 0
LV Size 48.84 GiB
Current LE 1563
Segments 1
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 253:1

--- Logical volume ---
LV Name /dev/VolGroup01/LogVol01
VG Name VolGroup01
LV UUID qr7g0r-kTyN-23FU-8J5J-PGQL-P9de-VpVXox
LV Write Access read/write
LV Status available
# open 0
LV Size 1.00 GiB
Current LE 32
Segments 1
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 253:2

Guessing the 1.0 GB /dev/VolGroup01/LogVol01 is the swap partition.

I did the following:

root@Microknoppix:~# vgscan --mknodes
Reading all physical volumes. This may take a while...
Found volume group "VolGroup01" using metadata type lvm2
root@Microknoppix:~# vgchange -ay
3 logical volume(s) in volume group "VolGroup01" now active
root@Microknoppix:~# lvscan
ACTIVE '/dev/VolGroup01/LogVol00' [64.53 GiB] inherit
ACTIVE '/dev/VolGroup01/LogVol02' [48.84 GiB] inherit
ACTIVE '/dev/VolGroup01/LogVol01' [1.00 GiB] inherit
root@Microknoppix:~# mkdir /mnt/somename
root@Microknoppix:~# mount /dev/VolGroup01/LogVol02 /mnt/somename
root@Microknoppix:~# ll /mnt/somename/
total 144

/dev/VolGroup01/LogVol02 is the volume i CAN mount.

root@Microknoppix:~# mkdir /mnt/somename2
root@Microknoppix:~# mount /dev/VolGroup01/LogVol00 /mnt/somename2
mount: wrong fs type, bad option, bad superblock on /dev/mapper/VolGroup01-LogVol00,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or s

So the following command should be used?:

fsck.ext3 /dev/VolGroup01/LogVol02
 
Old 03-03-2011, 12:23 PM   #8
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
Quote:
Originally Posted by Eddie Adams View Post
So the following command should be used?:

fsck.ext3 /dev/VolGroup01/LogVol02
I thought LogVol00 was the one you were having issues with?
 
1 members found this post helpful.
Old 03-03-2011, 12:31 PM   #9
Eddie Adams
LQ Newbie
 
Registered: Sep 2007
Posts: 22

Original Poster
Rep: Reputation: 0
YOU ARE RIGHT!

fsck.ext3 /dev/VolGroup01/LogVol00

Should do it?
 
Old 03-03-2011, 01:43 PM   #10
Eddie Adams
LQ Newbie
 
Registered: Sep 2007
Posts: 22

Original Poster
Rep: Reputation: 0
It did! After some default yesses (50 or so) I managed to mount and shortly after rebooted succesfully. Thanks!
 
Old 03-03-2011, 02:01 PM   #11
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
Quote:
Originally Posted by Eddie Adams View Post
It did! After some default yesses (50 or so) I managed to mount and shortly after rebooted succesfully. Thanks!
Congrats. Please mark this thread solved, and click 'yes' on any posts you found helpful.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
Cannot mount NFS share (wrong fs type, bad option, bad superblock)... martinezpt Linux - Server 3 04-25-2010 08:44 PM
mount: wrong fs type, bad option, bad superblock on /dev/sda1 yekim Linux - Hardware 10 07-05-2007 11:28 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration