-   Linux - Server (
-   -   vsftpd server not listing ( 425 Failed to establish connection) (

oscargim 07-02-2012 01:54 PM

vsftpd server not listing ( 425 Failed to establish connection)
Yesterday my ftp was working and today when I try to connect from my ftp client to my server (remotely) I get this:

[02/07/2012 03:39:33 p.m.] REST 0
[02/07/2012 03:39:33 p.m.] 350 Restart position accepted (0).
COMANDO:> [02/07/2012 03:39:33 p.m.] PORT 192,168,1,30,210,251
[02/07/2012 03:39:33 p.m.] 200 PORT command successful. Consider using PASV.
COMANDO:> [02/07/2012 03:39:33 p.m.] LIST
[02/07/2012 03:40:33 p.m.] 425 Failed to establish connection.

I read somewhere that could be a firewall issue so I tried disabling firewall but nothing.

This is my vsftpd conf:


I didnt make any changes on the server to crash ftp

I also did a

/etc/init.d/iptables save


/etc/init.d/iptables stop

to disable iptables and now I cant see my old iptables config :/

Please any help I dont want to crash my entire server.

I have a centOS 5.8 32 bits server.

Thanks in advance

Kustom42 07-02-2012 02:00 PM

Its kind of an off the wall solution but something I have run into on CentOS w/ vsftpd is problems with the ip_conntrack_ftp module not being loaded correctly causing this issue.

Try this:

modprobe ip_conntrack_ftp

oscargim 07-02-2012 02:08 PM

Sorry for bother but it was my client ftp set on PORT I set it to AUTO and now works.

Its weird cause I set it to PORT cause before I had errors on AUTO, but now is the opposite.

And because of this now I cant see my iptables conf!

Is any way to restore the /etc/init.d/iptables save command to get it like before?


Kustom42 07-02-2012 02:14 PM

Yes, see the man page for "iptables-restore".

When you ran the save command it should have saved it to your /tmp/ directory at /tmp/$IPTABLES.XXXXXX

paysol 09-05-2012 10:41 PM

modprobe ip_conntrack_ftp;
Thank you Kustom42 , I had the same issue on the CentOS6. this command solved it for me.:D

All times are GMT -5. The time now is 12:57 AM.