LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-22-2010, 03:33 PM   #1
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Rep: Reputation: 44
vsftpd read access for user accounts but needs write access


Confusing thread title I know. I'm having a brain fart here.

I have an ftp server(vsftpd CentOS 5.2) that has an account that I need to share files with others. But I only want the people to have read access to the files yet need the account owner to have write access. How can I have a user account own the files yet have the end users read only?

I've tried making 2 users:

user 1: accountowner(read/write/etc)
user 2: readonly(read/download only)

I made accountowner and readonly users. Made them both have the same home directories. Made the owner accountowner with 750 permissions. Then made the readonly a member of accountowner's group. When I try to FTP I get "FAIL LOGIN:"


What am I missing here? Or is there a better way to do this?


thanks!
 
Old 04-23-2010, 09:15 AM   #2
r0b0
Member
 
Registered: Aug 2004
Location: Europe
Posts: 608

Rep: Reputation: 50
Please, post the contents of your vsftpd.conf file. Specifically, check variable write_enable=YES - unless this is allowed, you only have read-only ftp server.
 
Old 04-23-2010, 11:51 AM   #3
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Original Poster
Rep: Reputation: 44
I have write_enable=YES in vstpd.conf


Here's what I ended up doing and it seems to be working.

Created a new account: accountowner and its home directory is the same as the readonly account. I made accountowner the owner and group for the directory. I added accountowners group to the readonly account and made the permissions of the directory 750. Added both users to the user_list, set both accounts shell to /sbin/nologin.


For some reason thats pretty much what I tried before making this thread and it didnt' work. Then it started working. Im sure there was user error on my part somewhere.


What do you think? Ok way of doing this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd read-only/write per user. arashi256 Linux - Software 2 01-26-2009 08:04 PM
User accounts can't access NTFS partition Agent Cobalt Linux - General 6 04-30-2006 10:56 PM
where a service should place a folder so every user can have read/write access. shahidawan Linux - Security 3 05-07-2005 02:25 PM
read write access phoenix_wolf Linux - Newbie 2 12-05-2004 10:35 AM
Disabled access to user accounts! HELP! Adeas Mandriva 2 09-07-2003 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 09:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration