LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-19-2012, 09:29 AM   #1
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
Question VSFTPD Change login prompt (not banner)


Connected to 192.168.0.1.
220 My Banner message
Name (192.168.0.1:trey85stang):


How do I change "Name (192.168.0.1:trey85stang):"

to be something other then the ip address? This server is behind a firewall and I dont want people logging into it to know the internal ip I need them to see the external ip or a hostname.

I've searched online but all I can find is how to change the banner.
 
Old 04-19-2012, 11:32 AM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
That's not displayed by the server, it's the ftp client showing the ip you're coming from and the default username that will be sent to the server. If you just press enter, that's who you'll log in as.
 
Old 04-19-2012, 02:40 PM   #3
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by kbp View Post
That's not displayed by the server, it's the ftp client showing the ip you're coming from and the default username that will be sent to the server. If you just press enter, that's who you'll log in as.
no, that's not what is happening. I have an external connection that is getting the internal ip of the ftp server... I think this is a bug as the old setup I had did not do this upon further investigation. It should the ip address that the client connected to but now its showing hte actual ip address of the host in question.
 
Old 04-19-2012, 03:39 PM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
Sorry, I was thinking more about the username than the ip address. You may need to check that the firewall is translating the content of PASV responses.
 
Old 04-19-2012, 04:38 PM   #5
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by kbp View Post
Sorry, I was thinking more about the username than the ip address. You may need to check that the firewall is translating the content of PASV responses.
hmm... Ill check that there are PASV vsftpd options regarding hostname and source addresses. Thanks for the suggestions.
 
Old 04-20-2012, 02:16 AM   #6
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
It's not vsftpd options that you need to worry about, it's whether the firewall is smart enough to rewrite the content of the PASV response packet with the NATed address.
 
Old 04-20-2012, 10:06 AM   #7
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Original Poster
Rep: Reputation: 41
ok, I got with the firewall guy and he setup some application layer gateway, and that seems to be making things work like I need them to. Thanks for the help.
 
Old 04-28-2012, 10:12 AM   #8
em31amit
Member
 
Registered: Apr 2012
Location: /root
Distribution: Ubuntu, Redhat, Fedora, CentOS
Posts: 190

Rep: Reputation: 55
if you open a ftp connection from ftp cli client with using IP address it will shows IP address or if you open a connection using FQDN/hostname, it will shows FQDN/hostname. so i would better suggest to you to configure a DNS, hosts file into system. if client OS is linux than you can change /etc/hosts, if it is windows update this file "%SystemRoot%\system32\drivers\etc\hosts"


see this..

Quote:

C:\Users\Amit>ftp ftp.redhat.com
Connected to ftp.redhat.com.
220 Red Hat FTP server ready. All transfers are logged. (FTP) [no EPSV]
User (ftp.redhat.comnone)): ^C
C:\Users\Amit>ping ftp.redhat.com

Pinging ftp.redhat.com [209.132.183.61] with 32 bytes of data:
Reply from 209.132.183.61: bytes=32 time=398ms TTL=235

Ping statistics for 209.132.183.61:
Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 398ms, Maximum = 398ms, Average = 398ms
Control-C
^C
C:\Users\Amit>ftp 209.132.183.61
Connected to 209.132.183.61.
220 Red Hat FTP server ready. All transfers are logged. (FTP) [no EPSV]
User (209.132.183.61none)): ^C
C:\Users\Amit>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VSftpd doesn't prompt a login generalachoo Linux - Software 11 07-08-2008 12:01 AM
How to change telnetd Login banner ihweb Linux - Newbie 3 02-23-2008 09:04 PM
vsftpd login locally, but not remotely. get a login prompt though! ajkett Linux - Server 0 02-22-2007 04:18 AM
How to: Change Login Prompt wildem Linux - General 1 05-24-2006 07:02 PM
how to change login prompt ChronusDark Linux - General 2 03-03-2005 01:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration