LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   VNC viewer showing black screen. unable to connect VNC server remotely on the server? (https://www.linuxquestions.org/questions/linux-server-73/vnc-viewer-showing-black-screen-unable-to-connect-vnc-server-remotely-on-the-server-4175502396/)

cyberdome 04-20-2014 04:27 PM

VNC viewer showing black screen. unable to connect VNC server remotely on the server?
 
Hello everyone,


I am running Fedora 20. On my windows 8.1 machine when I run VNC client to connnect to my Fedora server. All I am getting is a black screen with the small sqare for the mouse cursor. Tried looking online for a solution. unable to get solution.

I did run the command yum groupinstall basic desktop.

still getting blank screen. started vncserver in fedora, I am running GNOME and KDE. I installed vnc-server using YUM. I installed KDE later. Also, it was working perfectly before. And now just getting a black screen.

vncserver:1 not working. below is my xstartup file.

Code:

#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
OS=`uname -s`
if [ $OS = 'Linux' ]; then
  case "$WINDOWMANAGER" in
    *gnome*)
      if [ -e /etc/SuSE-release ]; then
        PATH=$PATH:/opt/gnome/bin
        export PATH
      fi
      ;;
  esac
fi
if [ -x /etc/X11/xinit/xinitrc ]; then
  exec /etc/X11/xinit/xinitrc
fi
if [ -f /etc/X11/xinit/xinitrc ]; then
  exec sh /etc/X11/xinit/xinitrc
fi
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
startkde &


I am not sure as to what I am doing wrong?

any help is greatly appreciated.

devdol 08-01-2014 08:21 AM

Well now, any help: I had somewhat similar problems for a long time - a tiny twm desktop via vnc, but any KDE application would only start with long delays an lot of errors if started from the commandline;
Code:

Error: Can not contact kdeinit4!
being one of the significant hints.

It turned out that my xstartup file, where I spent a long time to searching for improvements, was not the issue at all. Instead, the way you start your vncserver is relevant:

As KDE4 is designed to run only as single instance on a given PC and for a given user, any KDE application needs contact to that first instance (on the local desktop). They will only reach it if you start your vncserver process by "dbus-launch vncserver"!

Good luck, as it may help in your case, too.


All times are GMT -5. The time now is 11:28 PM.