LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-19-2011, 05:12 AM   #1
Nerdio
LQ Newbie
 
Registered: Sep 2011
Posts: 27

Rep: Reputation: Disabled
User configuration on Samba


I want to be able to setup up Samba on a Red Hat Linux Server, so user authentication is done by Active Diretory . I have started to read through the various Wiki's and HowTo's and it is coming clearer what needs to be done, but I have a few questions.

1) I understand that the RH Server needs a Machine trust account setting up on AD. From what I have read though the password is 'negotiated' between the two. Is this right or have I got hold of the wrong end of the stick?

2) From what I can see, once Samba is configured I need to use smbpasswd to set up Samba user accounts. Is this just a matter of declaring the user accounts that exist in AD, that will need authenticating on this RH machine?

3) Having setup a user through Samba, do I need to still set a normal Linux user to specify the GID, and home directories etc.?

4) Is it fair to assume that the root account, if not configured in Samba will remain as it is now (without Samba)?

5) Extending point 4), is it therefore possible to have users that authenticate through Samba, and some that don't. Or is Samba going to provide the only method.

I am a relative newbie to Linux Sys Admin, so any help / guidance you can offer would be appreciated.

Thanks in anticipation
 
Old 09-20-2011, 02:34 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Hi there,

Quote:
I want to be able to setup up Samba on a Red Hat Linux Server, so user authentication is done by Active Diretory . I have started to read through the various Wiki's and HowTo's and it is coming clearer what needs to be done, but I have a few questions.

1) I understand that the RH Server needs a Machine trust account setting up on AD. From what I have read though the password is 'negotiated' between the two. Is this right or have I got hold of the wrong end of the stick?
If you are setting up authentication for Samba users via Active Directory which runs on LDAP instead of using smbpasswd then it will be considered as "passthrough authentication". In passthrough authentication credentials are passed to the domain controller for authentication but file system rights will be picked up from server hosting samba share. So, your active directory domain controller in this case will become authentication server and your RH server file system rights will be enforced on samba share.


Quote:
2) From what I can see, once Samba is configured I need to use smbpasswd to set up Samba user accounts. Is this just a matter of declaring the user accounts that exist in AD, that will need authenticating on this RH machine?
If you are configuring Samba to authenticate againt smbpasswd then it will considered as "local authentication". Authentication via smbpasswd and authentication via AD are two different things. In smbpasswd you can only add local user accounts. However, in LDAP based directory services like AD the accounts will be global.


Quote:
3) Having setup a user through Samba, do I need to still set a normal Linux user to specify the GID, and home directories etc.?
When you say that "setup a user through Samba" I am assuming that you are talking about adding a user in smbpasswd file. If that is the case then you do not need to create two user account. Your normal user account can be added to smbpasswd file. Remember the approach will be different if you want to setup AD user account.

Quote:
4) Is it fair to assume that the root account, if not configured in Samba will remain as it is now (without Samba)?
Yes.

Quote:
5) Extending point 4), is it therefore possible to have users that authenticate through Samba, and some that don't. Or is Samba going to provide the only method.
I am assuming the query is specific to smbpasswd and not AD. Users will able to authenticate as long as they are there in /etc/passwd. However, only those users who are there in smbpasswd file will be able to mount samba share if your backend authentication is set to smbpasswd.

I hope this helps.

I am a relative newbie to Linux Sys Admin, so any help / guidance you can offer would be appreciated.

Thanks in anticipation
 
1 members found this post helpful.
Old 09-20-2011, 05:59 PM   #3
Felipe
Member
 
Registered: Oct 2006
Posts: 294

Rep: Reputation: 31
Hallo:

I've spent a lot of time trying to configure samba on RH, so I'll try to help you (and thus save you some time...).

You don't say what RH are using. I've used RH3,4,5.
What I can say (I'm not an expert):

You can join the RH to AD. If you do so then:
- All the users of the AD can start a sessions in the RH (except you limit it) with his credentials.

- You do not need to create any account nor any information for the users in RH. They are assigned default parameters, which can be configured.

- All services, ssh, ftp, X session, telnet,... can be configured to use AD credentials. So all users in AD can access RH. The first time the user connects, hi is created his home directory with default directories/files.

- If you use Win2003 R2, you can extend the schema of the AD to save the uid, gid and home of the users (it's possible using Win2003 CD and from the Control Panel, add programs from windows...).
If you use Win2000, Win2003 (<R2), then system assigns a uid, gid automatically. That means that the uid, gid can be different from one system to another for the same user. But this can be solve using an option of samba, called "idmap domain".

- In /etc/samba/smb.conf you can configure default parameters. Ej: home directory (by default is /home/DOMAIN/username), shares,..
In that file, you specify directories/files shared with samba. By default, root is not configured with samba. For security reason, what I do is to share user home directory ([homes] section), and a share, /data, where I put all the information). For limiting access to the share, you can use ACL (as in windows). So you can say what can be accessed and who can access to it. And you even can control the access to the directories/files based on groups (and nested groups) of AD. And permissions of directories and files in the share, can be changed from a client of Windows with explorer if the user has the necessary permissions.

- By default, when a users try to access, it tries authentication with samba and later with local accounts (or reverse, I don't remember, it can be configured). By default, users of AD have to authenticate with DOMAIN\username as username, so there is no problem to know if the user is local or of AD (this also can be changed).

- In RH5 I've tried the GUI for authentication and worked fine. It joins your computer to AD and register your machine in the DNS.
Very important before you run the join command:
- By default, RH assigns the public IP to localhost. Modify /etc/hosts and put the public IP to the public name of the hostname.If your computer is called "computer1" and your AD domain "domain1.com", give the host the name "computer1.domain1.com" and put it and the public IP in the /etc/hosts (better if it's in the first not commented line).
- Be sure your computer is synchronized with AD. More that 5 minutes difference and won't work. Configure ntp or run (and later configure ntp):
# net time set -S computer1.domain1.com
- Limit the access to RH. You can say that only users of a certain group of AD can access the system. This is done in /etc/pam.d/system-auth, adding in auth of samba "require_member_ship_of DOMAIN\group" (don't remember if this is exactly that syntax)
- Limit the access to the shares with ACL. You can even limit the access to the root of the shares specifying in /etc/samba/smb.conf "valid users = DOMAIN\group, DOMAIN\user, .."
- If you have problems with Win7 and shamba shares, please, read:
http://superuser.com/questions/11533...o-samba-shares
- You can do a SSO between Linux and Windows systems, so you can connect from Windows lo Linux (and from Linux to Linux) without being prompted to enter user/password. For SSO from Windows to Linux using ssh, you can use Quest Putty.

Not sure if this can be interesting for you....

Regards

Last edited by Felipe; 09-20-2011 at 06:04 PM.
 
1 members found this post helpful.
Old 09-22-2011, 03:48 PM   #4
Felipe
Member
 
Registered: Oct 2006
Posts: 294

Rep: Reputation: 31
Hallo again.
As I've been asked in others threads for information of Linux-AD, I want to add:
- What I've configured has been RH5/Centos5 with AD Win2003R2 (with Win2003 I've some problems with SSO). I've not tried Win2008.
- Is possible to do a SSO Windows(XP, Win2003)-Linux or Linux-Linux using kerberos, so you can connect from one system to another using current user and not being ask for password.
It has worked for the next services:
- Files share: Configuring Samba.
You can use explorer for accessing Linux shares.
From Linux (to Linux or windows), Konqueror work fine and a url like next allow to browse remote files:
smb://sever.domain.com or just \\server.domain.com\
Using Konqueror, you can connect to the remote machine and list files, edit or play a .mp3, movie,..
Not all programs work fine. Ex: If you use kwrite, you can edit a file remotely. But this works fine because it's a Kde application. If you edit it with OpenOffice/FreeOffice, it won't work (I've not checked last releases).
If you use Nautilus (Gnome), remote files can be edited with all programs.
- X sessions (local or remote): No problem to start a session using AD user/password (in this case, it's not a SSO of course).
- Remote session: Using Quest Putty for connection from Windows(XP, Win2003, ..) to Linux and ssh for Linux-Linux.
- Telnet, ftp: Using kerberized clients.
- Sfp: Works fine.
- Apache: I know is possible, but I've not tried it because I authenticate web users using a proxy: squid.
- Proxy: Squid allows authenticate users against AD using kerberos and NTLM (also plain text, but in this case, you have to type user/password). Checked with users using IIS, Chrome, Firefox and Konqueror.
Even a certificate can be used to authenticate users against AD (or another repository:ldap, database, file, service,...).
I use it as a reverse proxy to authenticate users against web applications. It allows to select different ways to authenticate: Using certificate, navigator credentials (SSO kerberos/NTLM), user/password (this really doesn't exist, I create a cookie for this method which identifies the user). Also a combination of all this methods is possible and for each url (or regular expression of URL). And is possible to allow access to the different url depending of groups of AD (or groups in another repository).
Ex: http://server.domain.com/apli1/... --> Allow users of group "apli1" of AD (or in another repository).
http://server.domain.com/apli2/... --> Allow users of group "apli2" of AD (or in another repository).

I don't remember having configured other products, but is possible.

If any want to try it, as AD is composed for products which also exist in Linux LDAP (openLdap), kerberos, DHCP, DNS,.. It is possible to create a Domain Controller Win2003 compatible.

Regards

Last edited by Felipe; 09-22-2011 at 03:58 PM.
 
1 members found this post helpful.
Old 09-23-2011, 05:59 AM   #5
centos123
Member
 
Registered: Apr 2011
Posts: 397

Rep: Reputation: 15
go throughout with my thed linked below
might be it will help you

http://www.linuxquestions.org/questi...ain-pc-888539/

---------- Post added 09-23-11 at 05:59 AM ----------

go throughout with my thed linked below
might be it will help you

http://www.linuxquestions.org/questi...ain-pc-888539/
 
Old 09-28-2011, 06:33 AM   #6
Nerdio
LQ Newbie
 
Registered: Sep 2011
Posts: 27

Original Poster
Rep: Reputation: Disabled
Smile

Thanks for all the replies, which I have read with interest. I have had some success in getting Kerberos, Samba, and Winbind up and running. But I still have a problem....

Just to recap, the reqt. is to make all authentication of users logging into my Linux box authenticate using the Windows AD credentials.

I have joined my server (SECTEST) to the domain.

This is my smb.conf file (abbreviated, and modified).

[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = EU

# server string is the equivalent of the NT Description field
server string = sectest server

realm = EU.MYDOMAIN.LOCAL

# security_level.txt for details.
security = ADS

# Use password server option only with security = server
password server = DC1.EU.MYDOMAIN.LOCAL


Where DC1 is the name of the PDC with AD on.

I then start winbind, and samba

wbinfo -u gives me a list of users, such as

EU\Fred

getent passwd does what I expect, and I can see the user EU\Fred

However, when I login using 'EU\Fred' as the user name, and a valid password, my attempt to login is denied.

The Winbind log says this

[2011/09/28 12:21:47, 1] nsswitch/winbindd.c:main(864)
winbindd version 3.0.9-1.3E.9 started.
Copyright The Samba Team 2000-2004

The smbd.log shows

[2011/09/28 12:21:51, 0] smbd/server.c:main(760)
smbd version 3.0.9-1.3E.9 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004

nmbd.log shows

[2011/09/28 12:21:51, 0] nmbd/nmbd.c:main(669)
Netbios nameserver version 3.0.9-1.3E.9 started.
Copyright Andrew Tridgell and the Samba Team 1994-2004

So, all looks well.

If I use kinit Fred@MYDOMAIN.LOCAL, and enter a password, then there is no reported problem, so I have to assume that is OK.

I seem to be missing something somewhere, and am running out of ideas for things to look at/try.

Can anyone offer some ideas, or encouragement please.

Many thanks in anticipation
 
Old 09-28-2011, 01:57 PM   #7
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Alright, so you want all authentication should take place via AD.

The thing that you are missing or getting confused about is Samba with ldap and ldap authentications. Here, you have configured your linux server to be the part of EU domain/workgroup and DC1 is your primary domain controller. This domain controller is only responsible for Samba authentications over ldap and not your regular authentication. Your regular authentication will still take place via /etc/passwd

You have to understand that Samba over ldap and solely ldap authentications are two different things.

The thing you have done so far is to authenticate your samba user against AD (pass through authentication). However, your system accounts which are there in /etc/passwd still authenticate via /etc/password

Tell me this is Fred user account exists in /etc/password? If yes, then this user will indeed try to authenticate using /etc/passwd.

If you want to configure authentication to take place using AD (ldap) then you have to configure a centralized server where user's home directories will be located. This location should be available on all linux server where user will login. Next, you have to create the user account as a ldap user not as local user. Once you have configured that way the user entry will be there in /etc/passwd but as an ldap user not as a local user.

Your nsswitch.conf file will contain the information about authentication as to how authentication will take place that is whether using /etc/passwd file or ldap.

Quote:
wbinfo -u gives me a list of users, such as

EU\Fred

getent passwd does what I expect, and I can see the user EU\Fred

However, when I login using 'EU\Fred' as the user name, and a valid password, my attempt to login is denied.

The Winbind log says this

[2011/09/28 12:21:47, 1] nsswitch/winbindd.c:main(864)
winbindd version 3.0.9-1.3E.9 started.
Copyright The Samba Team 2000-2004

The smbd.log shows

[2011/09/28 12:21:51, 0] smbd/server.c:main(760)
smbd version 3.0.9-1.3E.9 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004

nmbd.log shows

[2011/09/28 12:21:51, 0] nmbd/nmbd.c:main(669)
Netbios nameserver version 3.0.9-1.3E.9 started.
Copyright Andrew Tridgell and the Samba Team 1994-2004

So, all looks well.
Are you trying to mount the samba share here? If not, then you will not see any errors in the log files you mentioned. It appears to me as you are trying to login to linux machine using that user account. As mentioned before it will not work until you create that user as an ldap user and not as a local user.

I hope this helps.
 
Old 09-28-2011, 05:55 PM   #8
Felipe
Member
 
Registered: Oct 2006
Posts: 294

Rep: Reputation: 31
If you use Samba as ADS security, you don't have to configure users locally and do nothing for each user.Everything is created the first time he connects.

Here is my configuration (supposing two domains, course and systems).

smb.conf
Quote:
[global]
workgroup = COURSE
realm = COURSE.NET
server string = server1
security = ADS
passdb backend = tdbsam
use kerberos keytab = Yes

# Only if you user a Win2003 <R2 or you don't use AD extensions for users of Unix/Linux, you can say how to generate the id
idmap domains = COURSE,SYSTEMS
idmap config COURSE:backend = rid
idmap config COURSE:range = 10000-999999
idmap config SYSTEMS:backend = rid
idmap config SYSTEMS:range = 1000000-1999999

template shell = /bin/bash
winbind use default domain = Yes
winbind offline logon = Yes
winbind refresh tickets = Yes
valid users = "@COURSE\\Usu. de server1"
allow trusted domains = no
read only = No
create mask = 0770
directory mask = 0770
inherit permissions = Yes
inherit acls = Yes
map acl inherit = Yes
local master = No

cups options = raw

[homes]
comment = Users
browseable = No

[datos]
comment = Applications
path = /data
volume = data

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No
/etc/krb5.conf
Quote:
[logging]
default = FILE:/var/log/krb5libs.log
kdc = FILE:/var/log/krb5kdc.log
admin_server = FILE:/var/log/kadmind.log

[libdefaults]
default_realm = COURSE.NET
default_tkt_enctypes = des-cbc-crc
default_tgs_enctypes = des-cbc-crc
ticket_lifetime = 600


[realms]

SYSTEMS.COM = {
kdc = domainserver1.systems.com
kdc = domainserver2.systems.com
admin_server = domainserver1.systems.com
admin_server = domainserver2.systems.com
default_domain = systems.com
}

COURSE.NET = {
kdc = domainserver01.course.net
kdc = domainserver02.course.net
admin_server = domainserver01.course.net
admin_server = domainserver02.course.net
default_domain = course.net
}

[domain_realm]

systems.com = systems.com
.systems.com = systems.com
course.net = COURSE.NET
.course.net = COURSE.NET

[appdefaults]
autologin = true
forward = true
forwardable = true
encrypt = true
/etc/nsswitch.conf
Quote:
...
passwd: files winbind
shadow: files winbind
group: files winbind
....
/etc/pam.d/system-auth
Quote:
#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_env.so
auth sufficient pam_unix.so nullok try_first_pass
auth requisite pam_succeed_if.so uid >= 500 quiet
# Limit access to users of group "Usu. de server1". You can write the group, but if has special characters, write the SID of the group.
auth sufficient pam_winbind.so cached_login use_first_pass krb5_auth krb5_ccache_type=FILE require_membership_of=S-1-5-21-222334365486-1763237450-1926432576-33411
auth required pam_deny.so

account required pam_unix.so broken_shadow
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 500 quiet
account [default=bad success=ok user_unknown=ignore] pam_winbind.so cached_login
account required pam_permit.so

password requisite pam_cracklib.so try_first_pass retry=3
password sufficient pam_unix.so md5 shadow nullok try_first_pass use_authtok
password sufficient pam_winbind.so cached_login use_authtok
password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
session optional pam_mkhomedir.so
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so
After configured, test if your host ip is fine, you have the time clock synchronous with AD and joint the computer to AD with:
Quote:
# net ads join -S serverdc.domain.com -U user_of_ad_with_pemissions
An remember that if your are asked to insert domain and user from a console, you have to write:
DOMAIN\\user
Nevertheless, if you enable
Quote:
winbind use default domain = Yes
, you don't have to specify domain. So don't use the same name for local that AD users.

Regards

Last edited by Felipe; 09-29-2011 at 03:41 AM.
 
Old 09-29-2011, 03:38 AM   #9
Felipe
Member
 
Registered: Oct 2006
Posts: 294

Rep: Reputation: 31
Forget so say:

Before joining the AD, you have to restart your services:
# service smb restart
# service winbind restart
 
Old 09-29-2011, 03:59 AM   #10
Nerdio
LQ Newbie
 
Registered: Sep 2011
Posts: 27

Original Poster
Rep: Reputation: Disabled
Thanks for these replies. Most informative.

We had rather come to the conclusion that T3RM1NVT0R had suggested, which is that we were only authenticating against local credentials, and that our attempts to authenticate were not getting out of the Linux box.

I think now I need to read up on integrating LDAP, and so creating LDAP users. I had rather been under the view that the nsswitch.conf file specified the order in which attempts to authenticate were attempted. ie local (files), and then on AD (winbind). If my understanding is correct, I need to create LDAP users that 'mirror' the users on AD. Or to be more precise, create the LDAP users for the users in the AD that I want to be able to login on the Linux box.

I think I will have more questions in due course. For now though I am happy to read on. Thanks again.
 
Old 09-29-2011, 04:18 AM   #11
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Am glad that you found the suggestions useful.

Yes, you have to create ldap users instead. You have to change the way user authenticate. As of now they are authenticating via /etc/passwd. You have to make linux aware that the credentials should be passed to AD for authentication.
 
Old 09-30-2011, 04:11 AM   #12
Nerdio
LQ Newbie
 
Registered: Sep 2011
Posts: 27

Original Poster
Rep: Reputation: Disabled
I have had a look at what you suggested, but I am missing something because this does not fit in with what I know already, and can find elsewhere.

All I want to do is use Active Directory to authenticate, and allow me to log on to a Linux box. There is no need, at this stage at least, to create any shares.

All the documentation that I have read so far, and the example that I have worked through suggests that I need Kerberos, Samba, and winbind. My nsswitch.conf file states that passwd is done by file first, then winbind. If I run the following

wbinfo -a EU\\Fred%Password

this comes back positively, and says that authentication is OK, so I think all of the Kerberos/Samba/winbind stuff is working just fine

T3RM1NVT0R suggests I need to create LDAP users for all the users that need to authenticate against LDAP. I'm afraid I am a bit of a newbie, and I am not sure what needs to be done, or how to do it. Can anyone help/guide me.

I had rather thought, or at least been under the impression that I would not need to have any accounts created locally be they LDAP, or Local ones, and that nsswitch.conf would sort this out for me, by first trying /etc/passwd, then AD. It appears not.

As ever, any help/advice is gratefully accepted.

Thanks
 
Old 09-30-2011, 02:43 PM   #13
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Here is the document which might help with the configuration part: http://spiralbound.net/blog/2007/04/...tive-directory

When I say that the user need to be a ldap user I mean to say that the user should exist in AD. Let me try to make it a bit simple. Suppose you have a user name Fred which is there in /etc/passwd but not in AD. You have another user name Mike which is there in AD but not in /etc/passwd (you first need to get him in /etc/passwd by getent passwd username). Now user Mike will be able to authenticate to AD because his username does exist in AD. On the other had if you will try to authenticate Fred against AD he will not be able to authenticate as he is not there in AD.

Basically, if you are enabling LDAP (AD) authentication then you have to make sure that the users should be there in AD. Users which are there in /etc/passwd file only will not be able to authenticate using WORKGROUP\username or DOMAIN\usernameformat because they are not part of domain/workgroup.

I hope this helps.
 
Old 10-03-2011, 02:22 AM   #14
Nerdio
LQ Newbie
 
Registered: Sep 2011
Posts: 27

Original Poster
Rep: Reputation: Disabled
Wink Working now.

Thanks T3RM1NVT0R, your answer is perfectly clear.

I have now got this all working. . There was a problem with my nsswitch.conf file, and I also made some changes to PAM (made it reference winbind).

Thanks to everybody for their input it is very much appreciated. Now I can get on with the real job of deploying this across all of our servers.

Thanks again
 
Old 10-03-2011, 01:22 PM   #15
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

You're welcome. Could you please mark this thread as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA - unix user created, added to samba, and valid users on share, still cannot... mitchell7man Linux - Server 12 03-17-2010 08:37 PM
Is there any way to log user samba who delete or move files/folders on samba server ? b-RAM Linux - Server 1 02-09-2010 12:33 AM
proftpd multi-user configuration, user cannot show contents of directories uglyoldbob Linux - Server 6 09-15-2008 11:18 PM
samba(global security=user) useful tools for client.ex: user change password. hocheetiong Linux - Newbie 1 03-18-2008 09:20 AM


All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration