LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-16-2008, 01:06 PM   #1
wadigzon
LQ Newbie
 
Registered: Aug 2007
Location: San Diego
Posts: 3

Rep: Reputation: 0
Cool URL missing "\" makes a difference


Hi there just today (it was working in the past)
I noticed that when I typed:

http://myserver/mantis

the web browser sends me to a page in Red Hat saying:
Page Not Found (404)
and shows me this address on the address bar:
http://www.redhat.com/mantis/

BUT when I type
http://myserver/mantis/

it works just fine, as it used to work in the past, as you can see, my server is hosting a Mantis server

thanks in advance, I'd appreciate for any ideas you might have

-wadi

Last edited by wadigzon; 06-17-2008 at 07:44 PM.
 
Old 06-17-2008, 05:42 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hmmm.

Going to http://myserver/mantis will have resulted in an HTTP 301 redirect to http://myserver/mantis/ . It may have redirected to the wrong place.

I'd check your 'ServerName' and 'VirtualHost' directives in httpd.conf and see if there's anything weird in there.

Dave
 
Old 06-17-2008, 08:02 PM   #3
wadigzon
LQ Newbie
 
Registered: Aug 2007
Location: San Diego
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ilikejam View Post
Hmmm.

Going to http://myserver/mantis will have resulted in an HTTP 301 redirect to http://myserver/mantis/ . It may have redirected to the wrong place.

I'd check your 'ServerName' and 'VirtualHost' directives in httpd.conf and see if there's anything weird in there.

Dave

Thanks that worked, I edited
/etc/httpd/conf/httpd.conf

changed the line (what the hell was that doing there?)
ServerName RedHat

with this:
ServerName my.ip.address
 
Old 06-18-2008, 02:39 AM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
That's a bit odd. Ah well, as long as it's working...

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 04:08 PM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Can you explain the difference between "Free Software (GNU)" and "Open Source"? vharishankar General 5 03-03-2005 09:40 AM
difference between "Web server local URL" and "IPv4 address"? kpachopoulos Linux - General 2 09-17-2004 01:30 PM
"User" & "System" CPU load difference JJX Linux - General 3 06-06-2004 01:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration