LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 01-31-2008, 05:00 AM   #1
the_gripmaster
Member
 
Registered: Jul 2004
Location: VIC, Australia
Distribution: RHEL, CentOS, Ubuntu Server, Ubuntu
Posts: 364

Rep: Reputation: 38
Updating Spamassassin


Distro: RHEL 5
Spamassassin v 3.1.7

I am using sa-update to update spamassassin. However, I am not sure if it is getting updated as "echo $?" from the prompt always returns a 1.

I would like to know:
1. what port and protocol does SA use for updating itself?
2. does a value of 1 for "echo $?" mean SA could not update itself?

Thanks.

Last edited by the_gripmaster; 01-31-2008 at 05:05 AM.
 
Old 01-31-2008, 08:09 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
Quote:
Originally Posted by the_gripmaster View Post
what port and protocol does SA use for updating itself?
Code:
rpm -ql spamassassin|grep sa-upd
cat /etc/cron.d/sa-update
cat /usr/share/spamassassin/sa-update.cron
grep '_get' /usr/bin/sa-update
If that's not enough "evidence" run sa-update in the background and something like 'lsof -w -n -i -a -p `pidof sa-update`' or 'netstat -ntp|grep sa-upd'


Quote:
Originally Posted by the_gripmaster View Post
does a value of 1 for "echo $?" mean SA could not update itself?
Code:
/bin/true; echo $?
/bin/false; echo $?
 
Old 01-31-2008, 01:22 PM   #3
the_gripmaster
Member
 
Registered: Jul 2004
Location: VIC, Australia
Distribution: RHEL, CentOS, Ubuntu Server, Ubuntu
Posts: 364

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by unSpawn View Post
Code:
/bin/true; echo $?
/bin/false; echo $?
I am actually running "echo $?" immediately after running "sa-update": a 1 is always returned.
Code:
sa-update; echo $?
So...?

And I will try out the other solutions when I get to work. Thanks.

Last edited by the_gripmaster; 01-31-2008 at 01:50 PM.
 
Old 02-01-2008, 05:49 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
With running '/bin/true; echo $?' I tried to explain that if a process ends and shows exit value "$?" = zero it completed w/o errors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Adding And Updating SpamAssassin Rulesets With RulesDuJour LXer Syndicated Linux News 0 11-26-2007 02:40 PM
Updating VMWare After Updating CentOS Linux31 Red Hat 2 09-18-2007 02:49 PM
Need some help with SpamAssassin, please? Posterboy Fedora 1 03-07-2007 05:06 AM
spamassassin khamesi Linux - Networking 2 11-16-2006 11:49 PM
spamassassin w/ procmail vs. spamassassin w/sendmail bleunuit Linux - Networking 1 08-01-2004 07:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration