LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-22-2008, 04:35 AM   #1
dobberph
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
Updateproblems from php4 to php5 on debian sarge vserver


Hi all,

I have a vserver by server4you.de .
I want to update from php4 to php5. Provided by an howto I have to install follwing packages:
Code:
#apt-get install libapache2-mod-php5 libapache2-mod-perl2
 php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-imap
 php5-ldap php5-mhash php5-mysql php5-odbc
Unfortunately there are some "broken dependencies" and as a complete beginner in linux I do need some help:

Code:
libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
                       Depends: libdb4.4 but it is not installable
                       Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
                       Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
                       Depends: libxml2 (>= 2.6.27) but 2.6.16-7sarge1 is to be installed
  php5-cli: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
            Depends: libdb4.4 but it is not installable
            Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
            Depends: libncurses5 (>= 5.4-5) but 5.4-4 is to be installed
            Depends: libreadline5 (>= 5.2) but it is not going to be installed
            Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
            Depends: libxml2 (>= 2.6.27) but 2.6.16-7sarge1 is to be installed
  php5-curl: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
             Depends: libcurl3 (>= 7.15.5-1) but 7.13.2-2sarge5 is to be installed
             Depends: libidn11 (>= 0.5.18) but 0.5.13-1.0 is to be installed
             Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
             Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
  php5-gd: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
           Depends: libfreetype6 (>= 2.2) but 2.1.7-8 is to be installed
           Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-1 is to be installed
  php5-imap: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
             Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
             Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
  php5-ldap: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
             Depends: libsasl2-2 but it is not installable
  php5-mhash: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
  php5-mysql: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
              Depends: libmysqlclient15off (>= 5.0.27-1) but it is not going to be installed
  php5-odbc: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
             Depends: unixodbc (>= 2.2.11-1) but it is not going to be installed
libc6 (2.3.6-6) e.g. is only available in unstable I think. But how can I install it then?

Thanks and best regards,
DerTobi
 
Old 02-22-2008, 10:31 AM   #2
mpgram
Member
 
Registered: Sep 2003
Location: Dallas TX
Distribution: Red Hat
Posts: 59

Rep: Reputation: 15
Try adding the following to your repositories located at "/etc/apt/sources.list"

Make a backup of this file before you do that. Then run your upgrade commands and see what happens.


deb http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted

## Major bug fix updates produced after the final release of the
## distribution.

deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

##Universe

deb http://us.archive.ubuntu.com/ubuntu/ gutsy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates universe

## Multiverse

deb http://us.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

## Backports

deb http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Canonical Partner Repository

deb http://archive.canonical.com/ubuntu gutsy partner
deb-src http://archive.canonical.com/ubuntu gutsy partner
deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse

## PLF REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://packages.medibuntu.org/ gutsy free non-free
 
Old 02-23-2008, 04:39 AM   #3
dobberph
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
thank mgram, i tried it with some debian-sourcelists and then it worked.

Thanks,
Tobi
 
Old 02-25-2008, 09:09 AM   #4
mpgram
Member
 
Registered: Sep 2003
Location: Dallas TX
Distribution: Red Hat
Posts: 59

Rep: Reputation: 15
Could you post those source lists for others in case they need them. And by others, I mean me, because I am probably going to load a Debian box in the next week or so.

Thanks!!
 
Old 02-26-2008, 05:45 AM   #5
dobberph
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Original Poster
Rep: Reputation: 0
My Debian source list:

Code:
deb http://ftp.debian.de/debian sarge main contrib non-free
deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb http://security.debian.org/ sarge/updates main contrib non-free
deb http://ftp.de.debian.org/debian-volatile/ sarge/volatile main contrib non-free

# Uncomment if you want the apt-get source function to work
deb-src http://http.us.debian.org/debian sarge main contrib non-free
deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free


deb http://people.debian.org/~dexter php5 sarge
deb-src http://people.debian.org/~dexter php5 sarge
deb http://packages.dotdeb.org sarge all
deb-src http://packages.dotdeb.org sarge all
deb http://backports.debian.or.at/backports.org/ sarge-backports main contrib non-free
Best regards,
Tobi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 not processing PHP4 pages on Debian Sarge blue penguin Linux - Software 8 08-24-2006 02:56 PM
Building php4 as a DSO on Debian Sarge debhelp3 Linux - Server 0 08-12-2006 10:40 PM
Php5 >> Php4 Eric45008 Slackware 22 04-25-2005 07:37 PM
Apache PHP4 Debian Sarge (2.6.8) Mauler Linux - Software 1 11-24-2004 06:24 PM
upgradeing from php4 to php5 mgarcia001 Debian 0 09-30-2004 07:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration