LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-20-2013, 10:50 AM   #1
itbuddhika
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Rep: Reputation: 0
Unhappy unable to start httpd service on fc 18


I am using fedora/rhel both.
i install fc 18 to my dynabook laptop and i try to start httpd service in several times. But every times i failed. Then i install and remove several time still i failed. I cant reinstall entire system please help anyone if know. I ran following command

systemctl enable httpd.service
systemctl start httpd.service

I got following errors upto now;
**Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.
Sep 20 21:19:34 chahan.chathu.karu systemd[1]: Starting The Apache HTTP Server...
Sep 20 21:19:34 chahan.chathu.karu httpd[16420]: httpd: Syntax error on line 351 of /etc/httpd/conf/httpd.conf: Sy...osed.
Sep 20 21:19:34 chahan.chathu.karu systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Sep 20 21:19:34 chahan.chathu.karu httpd[16422]: httpd: Syntax error on line 351 of /etc/httpd/conf/httpd.conf: Sy...osed.
Sep 20 21:19:34 chahan.chathu.karu systemd[1]: httpd.service: control process exited, code=exited status=1
Sep 20 21:19:34 chahan.chathu.karu systemd[1]: Failed to start The Apache HTTP Server.
Sep 20 21:19:34 chahan.chathu.karu systemd[1]: Unit httpd.service entered failed state.

**
 
Old 09-20-2013, 04:20 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,658

Rep: Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817
Quote:
Sep 20 21:19:34 chahan.chathu.karu httpd[16420]: httpd: Syntax error on line 351 of /etc/httpd/conf/httpd.conf: Sy...osed.
You should go to line 351 of /etc/httpd/conf/httpd.conf and see what the problem is.
 
Old 09-21-2013, 12:56 AM   #3
KoopaTroopa
Member
 
Registered: Aug 2003
Location: Dallas, TX
Distribution: CentOS
Posts: 43

Rep: Reputation: 15
If you can't figure it out post that section of your config here for us to help with and sanitize any private info you may have in it.
 
Old 09-22-2013, 11:05 PM   #4
itbuddhika
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: 0
vim /etc/httpd/conf/httpd.conf +351

# Load config files in the "/etc/httpd/conf.d" directory, if any.
IncludeOptional conf.d/*.conf

Thank a lot your kind help in this regard
 
Old 09-23-2013, 02:02 AM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,658

Rep: Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817
Quote:
Originally Posted by itbuddhika View Post
vim /etc/httpd/conf/httpd.conf +351

# Load config files in the "/etc/httpd/conf.d" directory, if any.
IncludeOptional conf.d/*.conf

Thank a lot your kind help in this regard
I guess your FC18 does not recognize the "IncludeOptional" directive. You may change it to just
Code:
Include conf.d/*.conf
 
Old 09-24-2013, 06:03 PM   #6
itbuddhika
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Now comming this error

httpd: Syntax error on line 153 of /etc/httpd/conf/httpd.conf: Can...ctory

and i vim /etc/httpd/conf/httpd.conf +153

result is

LoadModule authn_alias_module modules/mod_authn_alias.so

please help me to solve this issue
 
Old 09-24-2013, 07:46 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,483

Rep: Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610
just HOW did you install the apache stack on fedora 18
using yum
or
manual build and install from source ( my preferred install )

using yum and the default apache for fedora 18
should auto start and have no problems
you should see the the apache " congratulations , apache is installed" page from
127.0.0.1:80

from there you need to set up your CMS and everything else


PS.
it also is NOT advisable to run a server on fedora
and using the old version is even worse
ALL and i mean ALL support for fedora 18 ends VERY soon , in about 90 DAYS
you will be forced to reinstall apache and everything related to is and the site when fedora 18 hits it's END OF LIFE

you will need to install fedora 20 and redo everything you have done

Last edited by John VV; 09-24-2013 at 07:50 PM.
 
Old 09-26-2013, 08:51 PM   #8
itbuddhika
LQ Newbie
 
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Now Successfully started httpd as instructed on following link
http://www.server-world.info/en/note...ora_18&p=httpd

But Still I commented following option on httpd.conf file

#IncludeOptional conf.d/*.conf

How do I enable it again. I cannot start httpd when enable it.

Thank you all who are motivate me.
 
Old 09-26-2013, 09:06 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,483

Rep: Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610Reputation: 2610
quickly going over that link above
it is full of some rather bad advice
Quote:

rm -f /etc/httpd/conf.d/welcome.conf
removing the "welcome" page before you know it is running is never a good idea

linking perl to usr/local
fedora dose not use the "local" folder and is not in the system $PATH
and it will NEED to be added to the system environmental variables

Quote:
Options FollowSymLinks ExecCGI
"ExecCGI" should be DISABLED unless you DO need it
and might cause problems with SELinux

Quote:
AllowOverride All
is never a good idea until you KNOW exactly what you need to allow and not allow


to start the web server in Fedora 16 and UP run ( the newer versions of fedora use SystemD and NOT intV )
Code:
systemctl start httpd.service
 
Old 09-27-2013, 12:54 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,658

Rep: Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817
Quote:
Originally Posted by itbuddhika View Post
Now Successfully started httpd as instructed on following link
http://www.server-world.info/en/note...ora_18&p=httpd

But Still I commented following option on httpd.conf file

#IncludeOptional conf.d/*.conf

How do I enable it again. I cannot start httpd when enable it.

Thank you all who are motivate me.
Replace it with
Code:
Include conf.d/*.conf
as advised in my previous post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to start httpd service amartlk Linux - Newbie 1 07-22-2011 04:24 AM
httpd service start up error ramesh14 Linux - Software 6 05-16-2011 06:25 AM
I cannot start httpd service skyplus Linux - Server 4 12-04-2007 04:34 AM
Service httpd Start bajpaipuneet Linux - Server 1 03-07-2007 05:22 PM
httpd service won't start GavB Linux - Newbie 4 01-19-2007 07:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration