LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 10-29-2010, 12:33 AM   #1
pushpa_dwivedi
LQ Newbie
 
Registered: Oct 2010
Posts: 2
Blog Entries: 1

Rep: Reputation: 0
Unable to run any command on server with RHEL 3 ES due to Relocation Error.


Hi,
In oreder to run an application software on RHEL 3 ES server, I created a link forcefully using following command from root id:
# cd /lib64/tls/
# ln -sf libc-2.3.4.so libc.so.6
before that I copied file libc-2.3.4.so from a workstation with OS RHEL 4 WS so that a link can be created.
Now I am unable to run any command except cd & pwd and it gives error messaage as given below:
ls:relocation error:/lib64/tls/libc.so.6:symbol _rtld_global_ro,version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2with link time reference.

Before running this command libc.so.6 was pointing to libc-2.3.so file in path /lib64/libc-2.3.2.so.
I am now unable even to open a new window on the server.

Please send me some solution as early as possible because this server is running production data and many users are runnig application on this server.

Thanks & Regds,
Pushpa Dwivedi
 
Old 10-29-2010, 12:56 AM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,145
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Try to go to rescue mode and unlink the the links you created.

do man unlink to know more about unlink.
 
Old 10-29-2010, 02:23 AM   #3
pushpa_dwivedi
LQ Newbie
 
Registered: Oct 2010
Posts: 2
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
Hi,

Try to go to rescue mode and unlink the the links you created.

do man unlink to know more about unlink.
Thanks for reply!
Will it allow to run unlink command in rescue mode ? since right now it is not accepting any command.only cd & pwd are running.
If yes, please send me steps how to do that? One more thing I want to know what will happen to other file systems having oracle and application software on this server.

Thanks & Regds,
Pushpa Dwivedi
 
Old 10-29-2010, 02:25 AM   #4
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,145
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
You have to try.That's the only option you have i suppose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to run wi fi on rhel 5 geekvikrant Linux - Newbie 4 10-15-2010 01:50 PM
unable to run wi fi on rhel 5 geekvikrant Linux - Newbie 2 10-15-2010 01:50 PM
Unable to install due to C compiler error icexvi Linux - Newbie 2 03-03-2010 11:23 PM
Unable to boot server due to APF firewall jokingelephant Linux - Server 1 01-29-2009 08:55 PM
Unable to Run sudo due to getresuid() Not Working on CentOS 3.1 Xyrael Linux - Security 14 02-06-2008 08:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration