LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Unable to boot into ubuntu server 20.04 (https://www.linuxquestions.org/questions/linux-server-73/unable-to-boot-into-ubuntu-server-20-04-a-4175682060/)

chainlynx 09-13-2020 03:55 PM

Unable to boot into ubuntu server 20.04
 
Hello everyone. This is my first post in this forum and if I posted this in the wrong spot, admins feel free to move. So my issue in a nutshell is that my Ubuntu Server Machine is not booting into the OS.

The machine is a Dell Precision T7600
-Dell PERC H710P HBA
-4 Hitachi 2TB HDDs
-32GB RAM ECC
-Intel Xeon E5-2609
-Ubuntu Server 20.04

This issue randomly started happening after an update. When I turn on the machine I am greeted to a grub prompt. Unfortunately I have tried some things that probably have made things worse. I have used Ubuntu desktop bootable media to access a terminal and used the boot-repair tool several times. the last time I used it and tried to boot the machine up, the grub prompt is gone and now its a grub rescue screen.

I dont know what to do

Currently im following the steps here: https://help.ubuntu.com/community/Grub2/Installing

trying to reinstall GRUB2

Im at the point when I am trying to run:
sudo grub-install --boot-directory=/boot /dev/sda2

The output is:

Installing for i386-pc platform
grub-install: error: failed to get canonical path of '/cow'

The last time I ran the boot-repair tool, I received this URL:

https://paste.ubuntu.com/p/b5DZxY49WW/

Any idea how I can proceed? I use this machine as a file server and it hosts my plex media server

jefro 09-15-2020 02:52 PM

"randomly started happening after an update"

I'd assume some update may have caused it. Some timing I'd think. Try to boot to previous kernel and see if it still fails.

Doubt fixing grub or other deals will fix it.


All times are GMT -5. The time now is 01:51 AM.