Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 04-16-2008, 07:44 AM   #1
LQ Newbie
Registered: Apr 2008
Posts: 6

Rep: Reputation: 0
Umask-ing with VsFTPD

Hi guys,

I have been trying for ages to make this work, and searched Google and the lot to find things, but it still won't work.

I am trying to make my FTP server set the permissions on uploaded files to 644.

I had a umask of 0022, but did nothing. I have changed the Umask in Vsftpd.conf to various things, and it seems to do nothing...

Below is my Vsftpd conf file.


# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Run standalone? vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
ftpd_banner=Wakefield FHS FTP Service2
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may restrict local users to their home directories. See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
# You may specify an explicit list of local users to chroot() to their home
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
# Debian customization
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default. These settings are more Debian-friendly.
# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
# This string is the name of the PAM service vsftpd will use.
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.

Old 04-16-2008, 12:56 PM   #2
Registered: Feb 2008
Location: Texas
Distribution: Fedora, RHEL, CentOS
Posts: 488

Rep: Reputation: 78
If this mask is for anonymous user(s), you'll want to use the anon_umask= option. I did not see this in your conf provided above.

Originally Posted by man vsftpd.conf
The value that the umask for file creation is set to
for anonymous users. NOTE! If you want to specify octal
values, remember the "0" prefix otherwise the value will
be treated as a base 10 integer!

Default: 077
Hope this help.
Old 04-18-2008, 05:38 AM   #3
LQ Newbie
Registered: Apr 2008
Posts: 6

Original Poster
Rep: Reputation: 0

But, It's for local users only, anonymous users arn't allowed to log in.

Originally Posted by rayfordj View Post
If this mask is for anonymous user(s), you'll want to use the anon_umask= option. I did not see this in your conf provided above.

Hope this help.
Old 04-22-2008, 02:51 AM   #4
Registered: Aug 2007
Posts: 47

Rep: Reputation: 15
open the 'man vsftpd.conf' page and search for 'umask'.
there are 2 options there called file_open_mode and local_umask.
read up.
Old 04-23-2008, 03:11 AM   #5
LQ Newbie
Registered: Apr 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Originally Posted by GhostCow View Post
open the 'man vsftpd.conf' page and search for 'umask'.
there are 2 options there called file_open_mode and local_umask.
read up.
Thanks, it's ok, I had local_umask in the file.... however I was editing the wronge vsftpd.conf! Which is why it was taking no effect..



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd umask settings fluffyvoidbunny Linux - Software 2 02-07-2006 03:06 PM
VSFTPD Umask options and ownership dkrysak Linux - Software 0 09-10-2004 07:30 AM
vsftpd umask not working k-bot Linux - Software 1 03-10-2004 04:29 PM
vsftpd umask-problem hihachi Linux - Software 0 03-19-2003 04:16 PM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:43 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration