LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-28-2009, 01:59 PM   #1
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Time on Server keeps changing whether I'm using NTP or not.


Hello,

It seems that my time keeps "shifting" and I'm not sure why...I tried manually setting the clock...and it still shifts and then comes back to normal time...

I tried enabling NTP but the "shift" still happens....

Example...
Code:
[root@antelope ~]# date
Tue Apr 28 12:05:56 PDT 2009
[root@antelope ~]# date
Tue Apr 28 11:51:33 PDT 2009
[root@antelope ~]# date
Tue Apr 28 11:51:50 PDT 2009
[root@antelope ~]# date
Tue Apr 28 12:06:21 PDT 2009
[root@antelope ~]# date
Tue Apr 28 12:06:25 PDT 2009
[root@antelope ~]# date
Tue Apr 28 11:51:59 PDT 2009
[root@antelope ~]# date
Tue Apr 28 12:06:53 PDT 2009
[root@antelope ~]# service ntpd start
Starting ntpd:                                             [  OK  ]
[root@antelope ~]# date
Tue Apr 28 12:07:19 PDT 2009
[root@antelope ~]# date
Tue Apr 28 11:52:47 PDT 2009
[root@antelope ~]# date
Tue Apr 28 12:07:21 PDT 2009
[root@antelope ~]# date
Tue Apr 28 11:52:50 PDT 2009
[root@antelope ~]#
I was typing date within seconds from each other. So for fun I did this...

Code:
[root@antelope ~]# while :
> do
> sleep 2
> date
> done
Tue Apr 28 12:04:11 PDT 2009
Tue Apr 28 12:04:13 PDT 2009
Tue Apr 28 12:04:15 PDT 2009
Tue Apr 28 12:04:17 PDT 2009
Tue Apr 28 12:04:19 PDT 2009
Tue Apr 28 12:04:21 PDT 2009
Tue Apr 28 12:04:23 PDT 2009
Tue Apr 28 12:04:25 PDT 2009
Tue Apr 28 12:04:27 PDT 2009
Tue Apr 28 12:04:29 PDT 2009
Tue Apr 28 12:04:31 PDT 2009
Tue Apr 28 12:04:33 PDT 2009
Tue Apr 28 12:04:35 PDT 2009
Tue Apr 28 12:19:57 PDT 2009
This "hung" on the last one and I had to ^C out of it...

Here is another interesting thing...when the time is "wrong" it takes longer to comeback.
Code:
[root@antelope ~]# time date
time date
Tue Apr 28 12:10:01 PDT 2009

real    /+m,..625s
user    0m0.000s
sys     0m0.002s
[root@antelope ~]# time date
time date
Tue Apr 28 12:25:43 PDT 2009

real    15m41.410s
user    0m0.001s
sys     0m0.001s
Here is my OS info:
Code:
[root@antelope ~]# cat /etc/redhat-release 
CentOS release 5.2 (Final)
[root@antelope ~]# uname -a
Linux antelope 2.6.18-92.1.22.el5 #1 SMP Tue Dec 16 11:57:43 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
[root@antelope ~]#
Any ideas?

Last edited by custangro; 04-28-2009 at 02:12 PM.
 
Old 04-28-2009, 03:11 PM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

1. Have you made sure that NTP logging is globally enabled?

2. Do you see anything in /var/log/ntpd.log or /var/log/messages?

3. Do you see anything in any log when you deliberately update the NTP time, refresh the NTP daemon, or manually run "date"?

4. Are there multiple entries in your NTP servers file?
 
Old 04-28-2009, 03:29 PM   #3
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Code:
[root@antelope log]# grep ntp messages*
messages:Apr 28 11:52:45 antelope ntpd[14293]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages:Apr 28 11:53:04 antelope ntpd[14293]: ntpd exiting on signal 15
messages.1:Apr 28 07:58:28 antelope ntpd[20005]: ntpd 4.2.2p1@1.1570-o Thu Apr  9 12:53:31 UTC 2009 (1)
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: precision = 157.000 usec
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface wildcard, ::#123 Disabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface lo, ::1#123 Enabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: kernel time sync status 0040
messages.1:Apr 28 07:58:28 antelope ntpd[20006]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.1:Apr 28 08:00:08 antelope ntpd[20006]: ntpd exiting on signal 15
messages.1:Apr 27 12:59:17 antelope ntpd[20358]: ntpd 4.2.2p1@1.1570-o Thu Apr  9 12:53:31 UTC 2009 (1)
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: precision = 180.000 usec
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface wildcard, ::#123 Disabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface lo, ::1#123 Enabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: kernel time sync status 0040
messages.1:Apr 27 12:59:17 antelope ntpd[20359]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.1:Apr 27 12:59:18 antelope ntpd[20359]: ntpd exiting on signal 15
messages.1:Apr 27 12:59:18 antelope ntpd[20381]: ntpd 4.2.2p1@1.1570-o Thu Apr  9 12:53:31 UTC 2009 (1)
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: precision = 1.000 usec
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface wildcard, ::#123 Disabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface lo, ::1#123 Enabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: kernel time sync status 0040
messages.1:Apr 27 12:59:18 antelope ntpd[20382]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.1:Apr 27 12:59:20 antelope ntpd[20382]: ntpd exiting on signal 15
messages.1:Apr 27 12:59:20 antelope ntpd[20402]: ntpd 4.2.2p1@1.1570-o Thu Apr  9 12:53:31 UTC 2009 (1)
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: precision = 1.000 usec
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface wildcard, ::#123 Disabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface lo, ::1#123 Enabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: kernel time sync status 0040
messages.1:Apr 27 12:59:20 antelope ntpd[20403]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.1:Apr 27 12:59:46 antelope ntpd[20403]: ntpd exiting on signal 15
messages.2:Mar 25 06:05:14 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 25 08:22:58 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 08:56:02 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 25 09:30:30 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 12:05:02 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 25 12:57:03 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 13:13:21 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 25 13:47:41 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 14:56:28 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Mar 25 15:48:02 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 16:21:52 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Mar 25 16:39:34 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 25 18:36:32 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 25 20:02:31 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 25 20:15:23 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 26 09:25:52 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 26 09:43:00 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 26 10:15:31 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 26 14:32:17 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 26 14:50:48 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Mar 26 15:59:08 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 26 16:48:17 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 26 22:13:39 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 26 23:38:01 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 27 02:46:22 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 27 09:35:29 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 27 12:43:48 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 27 13:02:14 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 27 14:10:49 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 27 16:42:26 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 27 16:59:24 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 27 19:50:13 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 27 21:15:21 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 27 23:32:52 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 30 10:09:22 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 30 11:48:46 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 30 11:51:58 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 30 11:54:08 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 30 14:11:06 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Mar 30 14:29:05 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 30 15:16:38 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 30 16:20:46 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 30 19:15:43 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 30 19:52:30 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 31 11:46:00 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 31 12:06:29 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 31 12:20:10 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 31 13:12:06 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 31 13:13:23 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Mar 31 14:05:01 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 31 17:45:05 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 31 18:21:12 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Mar 31 18:56:05 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Mar 31 22:17:52 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Mar 31 23:10:07 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 00:34:29 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  1 00:42:26 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 00:52:09 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  1 01:24:26 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 02:53:19 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Apr  1 04:18:41 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 07:43:39 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr  1 09:09:09 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  1 09:19:55 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 09:23:50 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  1 12:31:57 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Apr  1 13:24:46 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  1 15:23:03 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  1 15:24:33 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr  1 18:50:25 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  2 00:45:55 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  2 02:12:06 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  2 02:28:22 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  2 03:02:32 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  2 09:54:39 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr  2 10:12:18 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  2 16:26:44 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Apr  2 17:18:18 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  3 16:38:30 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Apr  3 17:29:46 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  3 18:04:03 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.2:Apr  3 18:21:20 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  3 20:01:37 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  3 20:19:40 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  3 20:35:46 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr  3 22:19:10 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  8 14:11:48 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr  8 16:11:01 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr  9 13:30:39 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr  9 14:04:51 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr 10 19:38:52 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr 10 21:21:23 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr 15 11:46:14 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.2:Apr 15 13:29:08 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.2:Apr 15 14:05:34 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.2:Apr 16 09:37:09 antelope ntpd[2532]: ntpd exiting on signal 15
messages.2:Apr 16 09:42:34 antelope ntpd[4324]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: precision = 1.000 usec
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:42:34 antelope ntpd[4325]: kernel time sync status 0040
messages.2:Apr 16 09:42:35 antelope ntpd[4325]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:42:36 antelope ntpd[4325]: ntpd exiting on signal 15
messages.2:Apr 16 09:42:36 antelope ntpd[4366]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: precision = 1.000 usec
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: kernel time sync status 0040
messages.2:Apr 16 09:42:36 antelope ntpd[4367]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:42:38 antelope ntpd[4367]: ntpd exiting on signal 15
messages.2:Apr 16 09:43:01 antelope ntpd[4446]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: precision = 1.000 usec
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: kernel time sync status 0040
messages.2:Apr 16 09:43:01 antelope ntpd[4447]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:43:35 antelope ntpd[4447]: ntpd exiting on signal 15
messages.2:Apr 16 09:43:35 antelope ntpd[4463]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: precision = 1.000 usec
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: kernel time sync status 0040
messages.2:Apr 16 09:43:35 antelope ntpd[4464]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:44:23 antelope ntpd[4464]: ntpd exiting on signal 15
messages.2:Apr 16 09:44:23 antelope ntpd[4585]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: precision = 918.000 usec
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: kernel time sync status 0040
messages.2:Apr 16 09:44:23 antelope ntpd[4586]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:44:57 antelope ntpd[4586]: ntpd exiting on signal 15
messages.2:Apr 16 09:45:47 antelope ntpd[4688]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: precision = 1.000 usec
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: kernel time sync status 0040
messages.2:Apr 16 09:45:47 antelope ntpd[4689]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:46:42 antelope ntpd[4689]: ntpd exiting on signal 15
messages.2:Apr 16 09:46:43 antelope ntpd[4750]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: precision = 1.000 usec
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: kernel time sync status 0040
messages.2:Apr 16 09:46:43 antelope ntpd[4751]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:50:04 antelope ntpd[4751]: synchronized to LOCAL(0), stratum 10
messages.2:Apr 16 09:50:04 antelope ntpd[4751]: kernel time sync enabled 0001
messages.2:Apr 16 09:52:36 antelope ntpd[4751]: ntpd exiting on signal 15
messages.2:Apr 16 09:53:49 antelope ntpd[5050]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: precision = 1.000 usec
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: kernel time sync status 0040
messages.2:Apr 16 09:53:49 antelope ntpd[5051]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:54:22 antelope ntpd[5051]: ntpd exiting on signal 15
messages.2:Apr 16 09:54:22 antelope ntpd[5078]: ntpd 4.2.2p1@1.1570-o Tue Jun 10 00:07:14 UTC 2008 (1)
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: precision = 744.000 usec
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:54:22 antelope ntpd[5079]: kernel time sync status 0040
messages.2:Apr 16 09:54:23 antelope ntpd[5079]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:55:09 antelope ntpd[5079]: ntpd exiting on signal 15
messages.2:Apr 16 09:56:57 antelope yum: Updated: ntp - 4.2.2p1-9.el5.centos.1.x86_64
messages.2:Apr 16 09:57:34 antelope ntpd[5345]: ntpd 4.2.2p1@1.1570-o Thu Apr  9 12:53:31 UTC 2009 (1)
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: precision = 730.000 usec
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface wildcard, 0.0.0.0#123 Disabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface wildcard, ::#123 Disabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface lo, ::1#123 Enabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface lo, 127.0.0.1#123 Enabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: Listening on interface eth0, 192.168.3.65#123 Enabled
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: kernel time sync status 0040
messages.2:Apr 16 09:57:34 antelope ntpd[5346]: frequency initialized 15.557 PPM from /var/lib/ntp/drift
messages.2:Apr 16 09:58:12 antelope ntpd[5346]: ntpd exiting on signal 15
messages.3:Mar  4 17:03:18 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.3:Mar  4 17:05:28 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 19 11:29:19 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.3:Mar 19 14:20:58 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 19 19:10:15 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.3:Mar 19 19:27:51 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 19 20:38:04 antelope ntpd[2532]: synchronized to 209.67.219.106, stratum 3
messages.3:Mar 19 21:05:34 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 20 11:59:43 antelope ntpd[2532]: synchronized to 208.53.158.34, stratum 3
messages.3:Mar 20 13:25:27 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 20 20:29:42 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
messages.3:Mar 20 22:12:37 antelope ntpd[2532]: synchronized to LOCAL(0), stratum 10
messages.3:Mar 24 14:43:14 antelope ntpd[2532]: synchronized to 207.171.30.106, stratum 1
 
Old 04-28-2009, 03:29 PM   #4
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Code:
[root@antelope log]# cat /etc/ntp.conf
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default kod nomodify notrap nopeer noquery

# Permit all access over the loopback interface.  This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1 

# Hosts on local network are less restricted.
#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

# Use public servers from the pool.ntp.org project.
# Please consider joining the pool (http://www.pool.ntp.org/join.html).
server timehost.4over.com
####server 0.rhel.pool.ntp.org
####server 1.rhel.pool.ntp.org
####server 2.rhel.pool.ntp.org

#broadcast 192.168.1.255 key 42         # broadcast server
#broadcastclient                        # broadcast client
#broadcast 224.0.1.1 key 42             # multicast server
#multicastclient 224.0.1.1              # multicast client
#manycastserver 239.255.254.254         # manycast server
#manycastclient 239.255.254.254 key 42  # manycast client

# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. 
fudge   127.127.1.0 stratum 10

# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
driftfile /var/lib/ntp/drift

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography. 
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8
restrict timehost.4over.com mask 255.255.255.255 nomodify notrap noquery
 
Old 04-29-2009, 10:50 AM   #5
suhas!
Member
 
Registered: Mar 2007
Posts: 100

Rep: Reputation: 17
quite interesting... can you try to remove your network cable and see if time changes? this will tell us if your system time is being set locally or remotely because of any exploits.. by chance
 
Old 04-29-2009, 05:51 PM   #6
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Another thing I noticed...when I try to "manually" set the time I get this...not sure if it's a "problem" or not...

Code:
[root@antelope ~]# tail /var/adm/messages
Apr 29 15:22:09 antelope ntpd[9572]: Listening on interface lo, ::1#123 Enabled
Apr 29 15:22:09 antelope ntpd[9572]: Listening on interface eth0, fe80::230:48ff:fe2e:819a#123 Enabled
Apr 29 15:22:09 antelope ntpd[9572]: Listening on interface lo, 127.0.0.1#123 Enabled
Apr 29 15:22:09 antelope ntpd[9572]: Listening on interface eth0, 192.168.3.65#123 Enabled
Apr 29 15:22:09 antelope ntpd[9572]: kernel time sync status 0040
Apr 29 15:22:09 antelope ntpd[9572]: frequency initialized 0.000 PPM from /var/lib/ntp/drift
Apr 29 15:25:30 antelope ntpd[9572]: synchronized to LOCAL(0), stratum 10
Apr 29 15:25:30 antelope ntpd[9572]: kernel time sync disabled 0001
Apr 29 15:25:30 antelope kernel: time.c: can't update CMOS clock from 1 to 55
Apr 29 15:29:48 antelope ntpd[9572]: synchronized to 207.171.30.106, stratum 1
is this of concern?

Apr 29 15:25:30 antelope kernel: time.c: can't update CMOS clock from 1 to 55

What's interesting is that the "shift" in time happens whether i use ntp or not...this one is a head scratcher... hmmm

-C
 
Old 04-29-2009, 06:10 PM   #7
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Are you sure you don't have another time service running - ntpdate for example?
 
Old 04-29-2009, 06:27 PM   #8
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by billymayday View Post
Are you sure you don't have another time service running - ntpdate for example?
Not unless another admin did somthing (which is entirely possible)

Code:
[root@antelope ~]# /etc/init.d/ntpd status
ntpd is stopped
[root@antelope ~]# crontab -l
no crontab for root
[root@antelope ~]# ps -ef |grep ntp
root      2884  2847  0 16:27 pts/1    00:00:00 grep ntp
[root@antelope ~]# ps -ef |grep date
root      2886  2847  0 16:27 pts/1    00:00:00 grep date
 
Old 04-29-2009, 08:25 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,320

Rep: Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008Reputation: 4008
In addition post the output of the command (ntpd needs to be started):
ntpq -p

ntpdate is not a service but could be run via a cron script.

Last edited by michaelk; 04-29-2009 at 08:29 PM.
 
Old 04-29-2009, 08:36 PM   #10
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Sorry - my mistake that one
 
Old 04-29-2009, 09:29 PM   #11
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by michaelk View Post
In addition post the output of the command (ntpd needs to be started):
ntpq -p

ntpdate is not a service but could be run via a cron script.
Here you go...
Code:
[root@antelope ~]# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 timehost   .INIT.          16 u    -   64    0    0.000    0.000   0.001
 LOCAL(0)        .LOCL.          10 l    -   64    0    0.000    0.000   0.001
timehost is our NTP host (that works for EVERY HOST except this one..).

At first I thought that it was the NTP server...but the "shift" still happens when I "manually" set the clock (i.e. I turn off ntp).
 
Old 05-07-2009, 06:02 PM   #12
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
OK...out of desperation I reinstalled the OS...

outcome: The problem still exists!!!

The time STILL "shifts" whether I use NTP **OR** whether I "manually" set the time even AFTER a clean install.

So one may think that this is a hardware issue...so for kicks I installed Windows to see if the problem exists on Windows....and you know what....the problem went away!

WTF?!?

How is Windows time good and RHEL time "shift" (even after a "clean" reinstall)?



-C
 
Old 05-08-2009, 01:08 PM   #13
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Now this is interesting....

I'm not a hardware guy...but do you know what this means?
Attached Thumbnails
Click image for larger version

Name:	Picture 1.png
Views:	134
Size:	53.2 KB
ID:	569  
 
Old 05-12-2009, 02:41 PM   #14
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978

Original Poster
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
**solved**

So it turned out to be a hardware issue.

The server had 2 physical CPUs on it; and it turned out that one of the CPU was "newer" than the other one (same clock speed, same socket, both Intel Xeon...but one had the number SD70T and the other had SD70P...)

Not sure why that it caused problems with the clock...but for some reason Linux cared...

Anyway...took out the "older" CPU and running off of one CPU with no problems.

-C
 
Old 05-12-2009, 03:28 PM   #15
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 4,070

Rep: Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897Reputation: 897
Quote:
Originally Posted by custangro View Post
...The server had 2 physical CPUs on it; and it turned out that one of the CPU was "newer" than the other one (same clock speed, same socket, both Intel Xeon...but one had the number SD70T and the other had SD70P...)
I can only offer a slightly handwaving 'explanation'. Presumably one cpu had a microcode bug that wasn't present in the other. Now this is normal and happens all the time, sort of, but usually you either have the bug and the kernel code has to work around it, or you don't and it doesn't. It looks as if your situation in which one cpu has the bug and the other doesn't, doesn't get worked around succesfully. I'm guessing whether the developers thought about it or not, they were unable to do this 'half and half' testing when they wrote the code.

Good that you've found a work-around, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I reduce ntp server time? scbops Linux - General 4 07-02-2008 03:51 AM
NTP Server giving central time instead of eastern time wjleon Linux - Networking 3 11-01-2007 04:04 PM
[root] Changing time without using ntp/ntpdate ? frenchn00b Linux - Newbie 1 07-22-2007 03:53 PM
Running your own NTP Time Server darkarcon2015 Red Hat 1 05-16-2006 12:06 PM
NTP Time Server on FC4 jdavidbakr Linux - Software 2 08-25-2005 08:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration