LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-22-2008, 04:19 AM   #1
wanghao
Member
 
Registered: Mar 2007
Distribution: centos
Posts: 126

Rep: Reputation: 15
The oracle error pls-00103


PLS-00103: PLS-00103: Encountered the symbol "begin" when expecting one of
the following:
:=( not null range
default character
symbol ";" was substitued by "begin" to continue.

I got the error when create a procedure,as following:
create or replace procedure test_pl as
tempdate net_grid.device_name%type
begin
select device_name
info tempdate
where netmask='255.255.255.0';
dbms_output.put_line(to_char(tempdate));
end;


Any friend who knows it do help you ,all you best!
 
Old 05-22-2008, 08:03 PM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 17,735

Rep: Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523Reputation: 2523
Well, the syntax checker can be a bit off; I notice that

'info' should be 'into'
 
Old 05-23-2008, 04:44 AM   #3
wanghao
Member
 
Registered: Mar 2007
Distribution: centos
Posts: 126

Original Poster
Rep: Reputation: 15
yes,thanks.i make such a mistake ,but as i changed the problem still and have the same error!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Verli error help pls Jderu_de_MM Slackware 5 05-17-2006 01:55 AM
strange error.pls. bruse Linux - Newbie 3 09-06-2005 08:28 AM
Disk Error need Help pLS. bngrhl Linux - Newbie 3 08-17-2004 06:17 AM
pls pls pls help me ! i'm tired with httpd config on fedora apache 2.0.48 AngelOfTheDamn Fedora 0 01-24-2004 05:12 PM
dma_intr: error=0x84 (common error, but pls read) devendra112 Linux - Hardware 0 02-06-2003 01:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration