LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Terrible performance on a mounted NAS device on RHEL3 (https://www.linuxquestions.org/questions/linux-server-73/terrible-performance-on-a-mounted-nas-device-on-rhel3-606957/)

jkeegan123 12-15-2007 10:50 AM

Terrible performance on a mounted NAS device on RHEL3
 
I am running Redhat Enterprise Linux 3 (RHEL3), and have mounted a NAS device using SMB. On my RHEL3 server, I am sharing a folder structure using SAMBA, which works fairly well. I created a subdirectory in my shared SAMBA folder tree, and created a SYMlink to the mounted NAS device.

The result is: The Windows users that access the SAMBA shared folder are also able to access the NAS device as a subdirectory of the existing shared SAMBA tree. This works perfectly....except that the performance while accessing this folder it MISERABLE, both from the linux system directly, or through the SAMBA mapping on the Windows workstations.

What can I check to diagnose why this could be performing so poorly? When Windows users access the NAS device directly, performance is great....but we need them to access it in the context of the SAMBA subdirectory.

I know that back in the days of DOS and Novell, setting file handles, etc...helped optimize file access, especially when the directories contained lots of files (which this NAS device and Samba server does).

How can I baseline the performance of this server, and maybe pinpoint where the bottleneck is?

- Server is in a 10/100 switch and has negotiated 100 FULL
- NAS device is in a 10/100 switch and has negotiated 100 FULL

Thoughts are appreciated, thanks!


All times are GMT -5. The time now is 03:39 PM.