-   Linux - Server (
-   -   Telnet server Fedora14 (

Sipenyu 11-23-2012 03:29 AM

Telnet server Fedora14
Hye I have a problem to start telnet service in my fedora14.
Here is the command output which describe my problem.
please help .tQ

[linux@localhost ~]$ su-
Command not found.
[linux@localhost ~]$ cd /etc/xinetd.d
[linux@localhost xinetd.d]$ service xinetd start
[linux@localhost xinetd.d]$ service telnet start
telnet: unrecognized service
[linux@localhost xinetd.d]$

Lexus45 11-23-2012 04:04 AM

Are you sure you have telnet server installed? SSH is de-facto, do you really want to use telnet?
I don't know about Fedora, but in Ubuntu the package is named 'telnetd'.
'telnet' is just a client, not server.

DutchGeek 11-23-2012 07:33 AM

As Lexus45 said, sshd is much better than telnet. ssh is basically a secure version of telnet (nothing gets sent in plaintext), so no one can sniff your password when you login.

michaelk 11-23-2012 08:03 AM

As stated telnet is insecure and not recommended. Use ssh instead however you can enable it by editing /etc/xinetd.d/telnet and changing disable=yes to disable=no. Then restart xinetd.

Fedora 14 has reached end of life and therefore you will not be able to download updates any more. Upgrading to the latest version is recommended. Be sure to backup any and all important data.

John VV 11-23-2012 12:26 PM

and to add
fedora might not have installed telnet
you might have to install it from the dead and unsupported fedora 14 repos
currently ONLY fedora 16 and 17 are supported

If you 100% MUST use a dead version of fedora and a insecure program on a insecure "out of date" operating system

you might want to post on the
thread over at Fedoraforum

also from the FIRST post you are using this "su-"
That is wrong
it is "su" then a blank space and then a "dash"
then you type in your root account password

Sipenyu 11-23-2012 10:33 PM

My project uses Fedora 14.
I should run telnet server in fedora 14. and i think i already install telnet.

[linux@localhost ~]$ su -
[root@localhost ~]# rpm -q telnet
[root@localhost ~]# cd /etc/xinetd.d
[root@localhost xinetd.d]# ls
chargen-dgram daytime-dgram discard-stream rsync time-dgram
chargen-stream daytime-stream echo-dgram tcpmux-server time-stream
cvs discard-dgram echo-stream telnet

and already changed the configuration:

# default: on
# description: The telnet server serves telnet sessions; it uses \
# unencrypted username/password pairs for authentication.
service telnet
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID

i also already change the firewall setting . but when i want to start the telnet the following error occur:

[root@localhost xinetd.d]# vi telnet
[root@localhost xinetd.d]# service xinetd restart
Stopping xinetd: [ OK ]
Starting xinetd: [ OK ]
[root@localhost xinetd.d]# chkconfig xinetd on
[root@localhost xinetd.d]# chkconfig telnet on
[root@localhost xinetd.d]# setup
[root@localhost xinetd.d]# service xinetd restart
Stopping xinetd: [ OK ]
Starting xinetd: [ OK ]
[root@localhost xinetd.d]# service telnet restart
telnet: unrecognized service

Before this i already configure the same telnet server but on Fedora 13 and it works.
But why in fedora 14 it became unrecognized service in the end?

michaelk 11-24-2012 07:24 AM

telnet runs via xinetd, there is not a standalone telnet daemon so what you see is ok. What happens when try to connect on the same computer i.e.

telnet localhost

chrism01 11-26-2012 01:56 AM

You should use sshd instead, but if you are willing to risk being broken into, you'll need the server SW telnetd (note the 'd').

server = /usr/sbin/in.telnetd
At the moment, your rpm cmd only shows the telnet client installed.

All times are GMT -5. The time now is 11:03 AM.