Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 08-16-2010, 12:23 PM   #1
Registered: Oct 2005
Posts: 540

Rep: Reputation: 32
system-config-bind unable to save

Hi, not sure why but I keep on getting the ERROR: Path is not writable when I'm trying to add a Slave Zone.

The server was commissioned by someone else and I remotely installed GNOME group, and vncserver as per the official CentOS instructions here.

Initially I tried using a normal (ie non root) user's credential for my VNC session. However, instead of asking me for my root password when I tried to open system-config-bind, it just doesn't load up. I ended up allowing the user "root" to connect to the server remotely via VNC, and was able to get system-config-bind to start.

However, I am now unable to save the settings, despite having done:
cd /var
chmod -R 777 named
Please help!
Attached Thumbnails
Click image for larger version

Name:	config-bind.jpg
Views:	11
Size:	91.7 KB
ID:	4328  
Old 08-16-2010, 01:04 PM   #2
LQ Guru
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,566

Rep: Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794
Since you're running Centos, it could be SELinux preventing the tool to write configuration.

I ended up allowing the user "root" to connect to the server remotely via VNC, and was able to get system-config-bind to start.
You should log-in as a regular user and use su or sudo to run system commands for security reasons.

Old 08-16-2010, 02:03 PM   #3
Registered: Jan 2008
Distribution: RHEL, CentOS, Ubuntu
Posts: 379

Rep: Reputation: 38
It may be a Howto but not a Whento...
I would turn off VNC immediatly if it's not too late already.
If you are connecting from another linux machine just use 'ssh -Y' and you can open the system-config apps tunneled through ssh.
It's possible that bind is running chrooted and there is a problem saving the files from the gui due to symlinks or something.
Are your zone files symlinks to /var/named/chroot/var/named/...?
Have checked /var/log/messages?
Old 08-22-2010, 02:59 AM   #4
Registered: Oct 2005
Posts: 540

Original Poster
Rep: Reputation: 32
Okay this is somewhat messed up. Don't know why and if someone does, please let me know so I can learn. Apparently SELinux was disabled and by enabling it I am now able to save the settings from the BIND GUI tool. How did I find out? I saw the following block in the /etc/sysconfig/named file....
# ENABLE_ZONE_WRITE=yes  --  If SELinux is disabled, then allow named to write
#                            its zone files and create files in its $ROOTDIR/var/named
#                            directory, necessary for DDNS and slave zone transfers.
#                            Slave zones should reside in the $ROOTDIR/var/named/slaves
#                            directory, in which case you would not need to enable zone
#                            writes. If SELinux is enabled, you must use only the
#                            'named_write_master_zones' variable to enable zone writes.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
system-config-network-gui does not save IP information greyarea Linux - Networking 2 09-23-2009 09:04 AM
Bind problem: config files are missing after re-install bind 9.5 on Fedora Core 8 elvisious Linux - Software 1 07-15-2008 07:49 PM
system-config-bind issues jessicaK Linux - Server 4 03-18-2008 10:03 AM
system-config-bind ziz300 Linux - Networking 1 05-26-2006 05:48 AM
system-config-bind -- save error labMonkey Linux - Networking 0 01-26-2005 01:42 PM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 11:45 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration